PINE64

Full Version: Trying to boot first PADI (SOLVED)
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
OK, I just got the Assembled breadboard adapter and 10 other Padis. I have it wired up on the breadboard and tried hooking up this USB to TTL http://www.friendlyarm.com/index.php?rou...uct_id=178 without using power or ground. I'm using a separate 3.3v PSU to power the Padi and tried the following.

Quick start guide said connect RxD to IoT Stamp GA4 (UART2_OUT) an TxD to IoT Stamp GA0 (UART2_IN). I can type a ATS? and the red Padi led comes on for a bit, but I get no output. I assume the red light comes on when transmitting data?

I saw someone say this was incorrect and use GB0 & GB1 pins instead, but this results in the Padi's green LED always being on and commands do nothing. In both cases I see the device in /dev and the terminal program can connect.
bad connections?
(02-02-2018, 06:42 PM)dkryder Wrote: [ -> ]bad connections?

I tried plugging directly into the Padi adapter (no bread board) and plugging USB-TTL into PC without USB cable. Tried different jumper wires, etc. I just want to verify that UART2 is the correct one from the quick start guide as well.
yes, uart2, Ga0,Ga4, but either might work. do you have the lines reversed? anyway, it takes a bit to get it working, once you do you're ok. another source of info besides searching this forum, [there is a goldmine of stuff on this forum] is,
https://www.rtl8710forum.com/viewforum.p...55698491be
but, there may be a need for common gnd, [The stamp & host computer] not sure. also, GB1,GB0,GND,3.3 might also work if all lines from the usb to serial or as you point out GA0,GA4. i have 3 stamps but have not used them since this time last year so it's kinda fuzzy.
You need to use a common ground, and make sure your usb to serial chip is set to 3V3 because you want the voltage levels for communication to be the same as the padi voltage even if it is not powering the padi. It seems you want to be connected to GA0 and GA4 which are for the general purpose serial port, for interacting with the preloaded firmware. Pins GB1 and GB0 are the debug serial port that will show boot loader debug messages and other stuff.

When powering the padi with an external supply you need a shared ground connection, RxD -> GA4, TxD -> GA0, and your serial console set to 38400
(02-05-2018, 12:54 PM)Dan Wrote: [ -> ]You need to use a common ground, and make sure your usb to serial chip is set to 3V3 because you want the voltage levels for communication to be the same as the padi voltage even if it is not powering the padi. It seems you want to be connected to GA0 and GA4 which are for the general purpose serial port, for interacting with the preloaded firmware. Pins GB1 and GB0 are the debug serial port that will show boot loader debug messages and other stuff.

When powering the padi with an external supply you need a shared ground connection, RxD -> GA4, TxD -> GA0, and your serial console set to 38400

The quick start guide was correct. I ended up just using a NanoPi Duo and it worked Smile It was totally common ground, thanks!
[attachment=1107]
(02-05-2018, 12:54 PM)Dan Wrote: [ -> ]You need to use a common ground, and make sure your usb to serial chip is set to 3V3 because you want the voltage levels for communication to be the same as the padi voltage even if it is not powering the padi. It seems you want to be connected to GA0 and GA4 which are for the general purpose serial port, for interacting with the preloaded firmware. Pins GB1 and GB0 are the debug serial port that will show boot loader debug messages and other stuff.

When powering the padi with an external supply you need a shared ground connection, RxD -> GA4, TxD -> GA0, and your serial console set to 38400

Thanks for sharing the knowledge with us.