PINE64

Full Version: Overscan problems (can't fix on TV)
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2
I'm using the latest Debian Mate image from https://www.pine64.pro/downloads/, and my TV is unfortunately cropping a bit off the edge of the entire screen. Even more unfortunately, the display settings on the TV do not include an option that fixes it (just a few that make it worse).

When I had this problem with my RPi, I went into raspi-config and set the overscan value and it was fixed right away. I've now spent a few hours trying to scour the internet for a solution to this, all to no avail. Most seem to suggest using xrandr, but that doesn't appear to be an option either (unless I'm missing something), since it gives me this output, and won't let me set any properties for the monitor:

Code:
[email protected]:~$ xrandr
xrandr: Failed to get size of gamma for output default
Screen 0: minimum 1280 x 720, current 1280 x 720, maximum 1280 x 720
default connected 1280x720+0+0 0mm x 0mm
   1280x720       0.00*

Are there any other fixes anyone has found? Also, strangely, this is a 1080p TV, so hopefully that resolution can be improved somehow as well?
ok that answers the other thread's question I posted.

comment out or remove the line optargs=disp.screen0_output_mode=720p60 from /boot/uEnv.txt if you want 1080p Wink

let me know how that went
(05-24-2016, 01:44 PM)lenny.raposo-pine64.pro Wrote: [ -> ]ok that answers the other thread's question I posted.

comment out or remove the line optargs=disp.screen0_output_mode=720p60 from /boot/uEnv.txt if you want 1080p Wink

let me know how that went

Thanks! Now I have 1080, but as a result even more pixels are lost! I'm just lucky I can make an educated guess about where the menus are up top Smile

To answer your question from the other thread (sorry about that), yup, that is the driver listed:

Code:
Section "Device"
        Identifier      "Allwinner A10/A13 FBDEV"
        Driver          "fbturbo"
        Option          "fbdev" "/dev/fb0"

        Option          "SwapbuffersWait" "true"
EndSection
ok now it's the overscan issue that needs resolving.

do you have some sort of zoom feature in your tv menu probably a setting under video/picture?

if so play with that and perhaps you will be able to get it to display properly Wink
(05-24-2016, 02:29 PM)lenny.raposo-pine64.pro Wrote: [ -> ]ok now it's the overscan issue that needs resolving.

do you have some sort of zoom feature in your tv menu probably a setting under video/picture?

if so play with that and perhaps you will be able to get it to display properly Wink

Unfortunately, as stated above, the TV's zoom feature doesn't include an option that fixes it. It's currently set at "Normal," the other options are all worse because they crop even more (Wide, Cinema, and Zoom). Those are the only options listed.

EDIT: I know this might be a bit of an aside, but is there some reason that xrandr doesn't work? Is there a workaround to get it working? I'm guessing that it has something to do with the Mali drivers not playing well with it?
it has to do with the fact the framebuffer as a driver

Mali drivers are not implemented as we are awaiting a response from AllWinner. They are working on the first 64bit Mali 400 driver for Linux at this moment. We'll have to wait an see for now.
I'm also suffering from this issue. It's a good job I have a Raspberry Pi that I can use while I wait for AllWinner to provide an Open Source 64-bit Mali 400 driver.
(05-25-2016, 06:10 AM)dhardingham Wrote: [ -> ]I'm also suffering from this issue. It's a good job I have a Raspberry Pi that I can use while I wait for AllWinner to provide an Open Source 64-bit Mali 400 driver.

I somehow doubt it'll end up being truly open source based on their track record, but I look forward to being proven wrong. Same here, I'm trying some other images but in the meantime back to RPi.
(05-24-2016, 01:44 PM)lenny.raposo-pine64.pro Wrote: [ -> ]ok that answers the other thread's question I posted.

comment out or remove the line optargs=disp.screen0_output_mode=720p60 from /boot/uEnv.txt if you want 1080p Wink

let me know how that went

I'm trying everything I can to remove the line above from uEnv.txt but the text file is read only, and I have no idea, even after a couple hours of searching how to edit that file. I'm a linux virgin, so please be patient with me if this question has an obvious answer that I'm missing. 

How do I edit the uEnv.txt file?

Thanks,
Brad
Code:
sudo nano /boot/uEnv.txt

Then edit, then CTRL+X, type "y" then Enter. Then reboot.
Pages: 1 2