kodi-git build script for mainline hwaccel media decoding
#11
you probably need to add your user to the input group.: sudo adduser <user> input
  Reply
#12
(06-14-2020, 07:47 PM)xmixahlx Wrote: you probably need to add your user to the input group.: sudo adduser <user> input
Yep that was the trick! I actually found that on some Kodi thread somewhere

Now video playback fails to work, there's no content and it just gives me a nice cursor trail instead Big Grin

The kodi.log is getting spammed with:
CDVDVideoCodecDRMPRIME::GetFormat - unsupported pixel format
CDVDVideoCodecDRMPRIME::AddData - send packet failed: Invalid data found when processing input (-1094995529)

Not sure where I went wrong
  Reply
#13
your build steps need to be linux > (mesa) > ffmpeg > (libudfread) > kodi, with (package) being optional, but recommended. is that what you did?
  Reply
#14
(06-15-2020, 11:35 AM)xmixahlx Wrote: your build steps need to be linux > (mesa) > ffmpeg > (libudfread) > kodi, with (package) being optional, but recommended. is that what you did?
Just tried building all these again in that order, getting the same result
  Reply
#15
are you building mesa? do you have X/wayland running?
kill X/wayland
run: ffmpeg -re -hwaccel drm -hwaccel_device /dev/dri/card0 -i <VIDEOFILE> -pix_fmt bgra -report -t 1 -f fbdev /dev/fb0
upload the log here. it will be ffmpeg_date.log in the terminal directory.
  Reply
#16
(06-13-2020, 09:28 AM)spikerguy Wrote: Hi @xmixahlx

I have added your vdec patch to `linux-pinebookpro` it built fine then I tried building ffmpeg full but it have too many extra libs enabled so I moved to ffmpeg with only v4l2_request and it was build just fine.

Now I am stuck with kodi-git I tried my PKGBuild with your config and it fails with errors then I think I will just run your script and it fails with missing deps and after I install those deps then it fails with missing packages which are not part of arch linux example `fstrcmp` and `libdvdread` errors.

Have you tried building using the kodi script on your pbp-tools repo? Can you add full dep list?

Thanks for your work.

@spikerguy

see CMakeLists.txt and note the -DENABLE_INTERNAL_?=OFF entries, and the ON entries under general. you may have to toggle those. also review required dependencies, and optional:
https://github.com/xbmc/xbmc/blob/master/CMakeLists.txt

from:
https://gitlab.manjaro.org/manjaro-arm/p...r/PKGBUILD
https://aur.archlinux.org/cgit/aur.git/t...h=kodi-git

try:
pacman -S afpfs-ng bluez-libs cmake curl doxygen glew gperf hicolor-icon-theme java-runtime libaacs libass libbluray libcdio libcec libgl mariadb-libs libmicrohttpd libmodplug libmpeg2 libnfs libplist libpulse libva libvdpau libxrandr libxslt lirc lzo mesa nasm python-pycryptodomex python-pillow python-pybluez python-simplejson shairplay smbclient taglib tinyxml swig upower giflib rapidjson ghostscript desktop-file-utils hicolor-icon-theme mesa python-pycryptodomex python-pillow python-simplejson xorg-xdpyinfo shairplay git meson gtest bluez-libs curl lcms2 libass libbluray libcdio libcec libinput libmicrohttpd libnfs libpulse libva libxkbcommon libxslt lirc mariadb-libs python smbclient taglib tinyxml libpng giflib libjpeg-turbo lzo afpfs-ng bluez python-pybluez libplist pulseaudio upower

cmake .. \
-DCORE_PLATFORM_NAME=gbm \
-DGBM_RENDER_SYSTEM=gles \
-DFFMPEG_PATH=/usr/local \
-DENABLE_TESTING=OFF \
-DCMAKE_INSTALL_LIBDIR=/usr/local/lib/aarch64-linux-gnu \
-DENABLE_INTERNAL_FFMPEG=OFF \
-DENABLE_INTERNAL_FMT=ON \
-DENABLE_INTERNAL_CROSSGUID=ON \
-DENABLE_INTERNAL_FSTRCMP=ON \
-DENABLE_INTERNAL_FLATBUFFERS=ON \
-DENABLE_INTERNAL_SPDLOG=ON

you may need to pair these down. when you get something that works, LMK.
  Reply
#17
(06-15-2020, 04:34 PM)xmixahlx Wrote: are you building mesa? do you have X/wayland running?
kill X/wayland
run: ffmpeg -re -hwaccel drm -hwaccel_device /dev/dri/card0 -i <VIDEOFILE> -pix_fmt bgra -report -t 1 -f fbdev /dev/fb0
upload the log here. it will be ffmpeg_date.log in the terminal directory.
Yes I'm building mesa (KDE works great with it) and yes I'm trying to run kodi without x/wayland running at the time

That test seems to work fine, I tried clearing my .kodi directory too but I'm really at a loss here


.log   ffmpeg-20200615-225201.log (Size: 44.61 KB / Downloads: 112)
  Reply
#18
i updated the ffmpeg and kodi scripts. hopefully that solves both of your issues.

unclear why i don't see the same problems, but we'll figure it out.

@spikerguy try BUILDCONFIG=internal ./pbp-build-kodi

there is a change in installdirs:
manually delete the old ffmpeg includes in /usr/local/include/aarch64-linux-gnu
manually delete kodi libs in /usr/local/lib, i moved them to /usr/local/lib/aarch64-linux-gnu
  Reply
#19
(06-16-2020, 02:23 AM)xmixahlx Wrote: i updated the ffmpeg and kodi scripts. hopefully that solves both of your issues.

unclear why i don't see the same problems, but we'll figure it out.

My latest build is working now, great work!
1080p H.264 and H.265 (even 10 bit!) are both working well

Now hopefully some day the userspace apis will get figured out and we can run MPV on x/wayland but this is more than good enough for now
  Reply
#20
excellent. i've been pleased with kodi + inputstream.adaptive + youtube + jellyfin for most of my media. there is some new progress with gstreamer that i am following that looks promising. more to come.
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  Battery gauge issue (mainline kernel) lfourquaux 0 135 04-03-2021, 10:12 AM
Last Post: lfourquaux
  UBOOT - Mainline not booting from SD card / BSP OK Anarethos 1 579 01-10-2021, 12:33 AM
Last Post: Anarethos
  How does one get working deep/S3 sleep with Ubuntu Focal/5.7 mainline kernel? Syonyk 7 3,153 10-26-2020, 02:03 PM
Last Post: edward
  A true mainline Linux Kernel for the Pinebook Pro tsys 151 79,652 10-22-2020, 01:00 AM
Last Post: mara
  Funny Conky like script to monitor your PBP state as400 1 1,023 08-19-2020, 12:57 PM
Last Post: xmixahlx
  mainline kernel hardware acceleration xmixahlx 33 21,660 06-11-2020, 10:41 AM
Last Post: xmixahlx
  Default Manjaro KDE build download link for Pinebook Pro? qeek 8 2,932 03-21-2020, 09:41 AM
Last Post: MrDitchy
  Kodi on Manjaro brent.thierens 12 5,236 03-16-2020, 09:10 AM
Last Post: spikerguy
  rkmpv Accelerated Media Player issues zaius 3 1,436 03-11-2020, 05:49 AM
Last Post: agD0i7rY
Shocked Pinebook Pro Build Script Issues TDC_PBP 3 1,985 03-01-2020, 04:24 PM
Last Post: jwhall

Forum Jump:


Users browsing this thread: 2 Guest(s)