br_netfilter
#1
Hi all,
I flashed the 0.10.12 linux image with container capability. But I am facing a problem : the file /proc/sys/net/bridge/brige-nf-call-iptables is missing and I cannot initialize Kubernetes (kubeadm init) : an error rises.
modprob br_netfilter returns an error because the module is not found

I will try with the stable version.

LMM
  Reply
#2
the br_netfilter module seems to be part of the 4.4 linux kernel (build-in) but not in the 5.6 kernel, and neither in the /lib/module directories. I do not know how to build it from source.
  Reply
#3
I used the below guides to enable things in the pinephone kernel and it was relatively straightforward. You might be able to do the same for your board.

https://github.com/umiddelb/armhf/wiki/H...ARM-device
https://debian-handbook.info/browse/stab...ation.html
  Reply
#4
Wink 
(04-22-2020, 11:16 AM)nas Wrote: I used the below guides to enable things in the pinephone kernel and it was relatively straightforward. You might be able to do the same for your board.

https://github.com/umiddelb/armhf/wiki/H...ARM-device
https://debian-handbook.info/browse/stab...ation.html

Thank you for you reply. 
Actually, I found a I a generic way to compile the module :
- install the header of the 5.6 kernel compiled by Ayufan
- download the source from GitHub
-  prepare the build the module :
Code:
make oldconfig
make prepare
make script
- build the module net/bridge module :
Code:
make -C /lib/modules/$(uname -r)/build  M=$(pwd)/net/bridge modules

- the result : I only obtain the bridge.ko module though I also expected to have the br_netfilter.ko module  Huh and the ver magic is the good one (note that I also tried with the git clone source and I obtained a vermagic with a "-dirty" extension" which will prevent the module to be loaded : error format and dmesg indicate that the vermagic is not the one expected)
- This is certainly a problem of the config of the build then I changed the Kconfig of the net repository to enable the generation of br_netfilter --> same result Dodgy
- I removed the "-C /lib/modules/..." option and the br_netfilter is generated but the vermagic is 5.6.0 (missing the -1137-ayufan-ge57f05e7bf8f extension)  Sad
- force option (--force or --force-vermagic) for installation does not work  Angry

Some command :
modinfo : gives info on the module


I will finally abandon for the moment and use the 4.4 kernel.  Undecided
  Reply
#5
@Luke @ayufan , is it possible to add this br_netfilter module for the container image for the main line kernel (it is necessary to install Kubernetes and probably docker) ?
  Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)