micro SD Card Slot Spring not working, Cant boot
#1
Hi,

I have a rockpro64 board and I was booting up till now with micro SD card.
Today I was not able to push the microSD card in slot by the usual spring.
What I see that after applying power no white/red leds are on.
I updated the armbian image from the one on armbian website but no luck.

Is there anyway I can boot from USB ?

-Thanks
mj
#2
So I tried with MaskRom option,

Since the SD card is not getting recognised I see the device going in Mask ROM Mode.
But I am not sure which Image to flash to boot from SPI.

Please help


Possibly Related Threads…
Thread Author Replies Views Last Post
  Installation Debian on emmc: which U-Boot and where? vongillus 3 184 07-02-2022, 09:24 AM
Last Post: dkebler
  enble boot after power loss/restore dkebler 11 985 06-22-2022, 09:39 PM
Last Post: dkebler
  ROCKPRO64 PCI SSD SD-boot Install pspgarret 0 91 06-09-2022, 10:56 AM
Last Post: pspgarret
  RockPro64 has no white led, nor will it boot past... AnjinMeili 2 156 05-31-2022, 09:19 AM
Last Post: Rocklobster
  no boot white led flashing moserwi 3 554 03-28-2022, 07:26 PM
Last Post: Rocklobster
  Cannot get my board to boot deutschlmao 10 1,505 03-19-2022, 07:45 PM
Last Post: Rocklobster
  Enabling secure boot arturkow 4 1,119 11-25-2021, 04:57 AM
Last Post: arturkow
  Device unable to boot Lunix33 9 3,745 09-23-2021, 01:38 AM
Last Post: LMM
  Flashed SPI, able to ping RP64 but not boot from sdcard/usb korefuji 2 1,420 08-26-2021, 11:41 AM
Last Post: LMM
  Mainline U-Boot with SPI, NVMe and SATA boot support sigmaris 103 65,670 07-08-2021, 04:55 PM
Last Post: Mentaluproar

Forum Jump:


Users browsing this thread: 1 Guest(s)