Touchpad broken?
(04-02-2020, 11:41 AM)rookieone Wrote: Howdy all!

Starting today the touchpad on my Pinebook doesn't seems to function anymore Sad

Mouse pointer is not moving, and touchpad clicks also do not seem to work.

I've tried several different sdcards with linux installs that I normally use, but none have the touchpad working.

Looking for HAILUCK output in dmesg shows:

[    8.108906] usb 2-1.1: Manufacturer: HAILUCK CO.,LTD
[   13.661714] input: HAILUCK CO.,LTD USB KEYBOARD as /devices/platform/soc/1c1b000.usb/usb2/2-1/2-1.1/2-1.1:1.0/0003:258A:000C.0001/input/input2
[   13.753783] hid-generic 0003:258A:000C.0001: input,hidraw0: USB HID v1.10 Keyboard [HAILUCK CO.,LTD USB KEYBOARD] on usb-1c1b000.usb-1.1/input0
[   13.758553] input: HAILUCK CO.,LTD USB KEYBOARD Mouse as /devices/platform/soc/1c1b000.usb/usb2/2-1/2-1.1/2-1.1:1.1/0003:258A:000C.0002/input/input3
[   13.760344] input: HAILUCK CO.,LTD USB KEYBOARD System Control as /devices/platform/soc/1c1b000.usb/usb2/2-1/2-1.1/2-1.1:1.1/0003:258A:000C.0002/input/input4
[   13.829730] input: HAILUCK CO.,LTD USB KEYBOARD Consumer Control as /devices/platform/soc/1c1b000.usb/usb2/2-1/2-1.1/2-1.1:1.1/0003:258A:000C.0002/input/input5
[   13.870252] input: HAILUCK CO.,LTD USB KEYBOARD Wireless Radio Control as /devices/platform/soc/1c1b000.usb/usb2/2-1/2-1.1/2-1.1:1.1/0003:258A:000C.0002/input/input6
[   13.873930] hid-generic 0003:258A:000C.0002: input,hiddev0,hidraw1: USB HID v1.10 Mouse [HAILUCK CO.,LTD USB KEYBOARD] on usb-1c1b000.usb-1.1/input1

To be honest I am not sure the trackpad is there (is it the mouse entry?)

I've tried Fn F2, but that doesn't help either...

Suggestions anyone?

Many thanks in advance!

p.s. Connecting a mouse works ;-)

Ok this is weird. I used my pinebook some more, touchpad didn't work, used an external wireless mouse.

Opened and disconnected the touchpad, tried to pry it out, failed, connected everything again, and the the touchpad still did not work.

Now, next day, booting the pinebook, working with keyboard only for a bit (while enjoying the sun in the garden Wink, touchpad still does not work.

I run inside to get the wireless mouse+usb dongle and the charging cable + powerbank.

I connect the wireless mouse/usb dongle, and the charging cable+powerbank and work with the external mouse for a bit.

I accidently touch the touchpad, AND,I notice the touchpad WORKS again!!!

Super weird!!! Perhaps something was reset by connecting power??

Never had this before... Really happy it works againSmile

Messages In This Thread
Touchpad broken? - by rookieone - 04-02-2020, 11:41 AM
RE: Touchpad broken? - by bcnaz - 04-02-2020, 08:21 PM
RE: Touchpad broken? - by rookieone - 04-03-2020, 05:07 AM
RE: Touchpad broken? - by bcnaz - 04-03-2020, 07:11 AM
RE: Touchpad broken? - by rookieone - 04-05-2020, 05:53 AM

Possibly Related Threads…
Thread Author Replies Views Last Post
  touchpad on pinebook issues? ron_burgundy 14 8,470 12-19-2020, 06:55 PM
Last Post: ron_burgundy
  keyboard broken? Erik 0 1,415 05-20-2019, 02:52 AM
Last Post: Erik
  PSU broken Erik 1 2,087 06-06-2018, 04:30 AM
Last Post: pfeerick
  broken keyboard -> transplant all organs into an thinkpad? stereo 1 2,033 05-19-2018, 03:25 PM
Last Post: stereo

Forum Jump:

Users browsing this thread: 1 Guest(s)