sw4 jumper for disabling eMMC boot / multiboot
#1
Ran into the following: I wanted to connect a little switch to choose between sdcard and emmc boot.

Didn't work: Open was fine - eMMC booted.

But closed seemed to boot from eMMC, too, but the archlinux didn't come up and got stuck while looking for its root device.

After some fiddling around, trying and reading serial console I tried a _jumper_.

Worked. As described in the layout the jumper shortens the clock of the emmc to ground. Is it possible that already a 5cm wire has too much resistance to disable the eMMC?

And if so, is there a smarter way to multiboot?
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  RockPro64 eMMC boot euu 0 194 06-27-2020, 10:51 PM
Last Post: euu
  Mainline U-Boot with SPI, NVMe and SATA boot support sigmaris 35 5,046 06-18-2020, 05:20 AM
Last Post: sivar93
  RockPro64 so problematic! Boot issues PorterDon 1 185 06-04-2020, 12:25 PM
Last Post: dukla2000
  Failure to boot atcwells 1 168 05-10-2020, 03:06 PM
Last Post: atcwells
  RockPro 64 V2.1 Boot problem only DDR Version ... message nutilius 5 558 05-02-2020, 03:26 AM
Last Post: freeviv
  micro SD Card Slot Spring not working, Cant boot mjembd 1 144 04-16-2020, 12:30 AM
Last Post: mjembd
  Rockpro64 boot issues larsgn 11 1,434 08-01-2019, 12:12 PM
Last Post: imapc99
  Availability of 128GB eMMC ? Arwen 1 412 07-22-2019, 11:28 AM
Last Post: Arwen
  RockPro64 boot problem MaxPesenti 2 401 06-21-2019, 01:17 AM
Last Post: MaxPesenti
  rockpro64 4gb dont boot mehdy 6 898 05-26-2019, 10:05 AM
Last Post: Nikolay_Po

Forum Jump:


Users browsing this thread: 1 Guest(s)