External display stopped working, "dpcd read failed: -22" in dmesg
#1
Yesterday, I was having no serious problems driving an external display from my PBP via a USB-C-to-HDMI adapter (J5create model JCA379).

This morning, I boot it up (it was shut off for the night), plug in the adapter, and the external display isn't recognized, and I see a flood of error messages in dmesg:


Code:
fusb302 4-0022: CC connected in CC1 as DFP
cdn-dp fec00000.dp: [drm:cdn_dp_pd_event_work] Not connected. Disabling cdn
fusb302 4-0022: PD connected as DFP, supporting 5V
fusb302 4-0022: DP config successful, pin_assignment 0x8
cdn-dp fec00000.dp: [drm:cdn_dp_pd_event_work] Not connected. Disabling cdn
fusb302 4-0022: attention, dp_status 9a
cdn-dp fec00000.dp: [drm:cdn_dp_pd_event_work] Connected, not enabled. Enabling cdn
cdn-dp fec00000.dp: [drm:cdn_dp_dpcd_read] *ERROR* dpcd read failed: -22
[57 repeated messages suppressed]
usb 3-1: new high-speed USB device number 2 using xhci-hcd
cdn-dp fec00000.dp: [drm:cdn_dp_dpcd_read] *ERROR* dpcd read failed: -22
[23 repeated messages suppressed]
usb 3-1: New USB device found, idVendor=2109, idProduct=2210
usb 3-1: New USB device strings: Mfr=1, Product=2, SerialNumber=0
usb 3-1: Product: USB2.0 Hub
usb 3-1: Manufacturer: VIA Labs, Inc.
cdn-dp fec00000.dp: [drm:cdn_dp_dpcd_read] *ERROR* dpcd read failed: -22
hub 3-1:1.0: USB hub found
hub 3-1:1.0: 4 ports detected
cdn-dp fec00000.dp: [drm:cdn_dp_dpcd_read] *ERROR* dpcd read failed: -22
[87 repeated messages suppressed]
usb 3-1.2: new high-speed USB device number 3 using xhci-hcd
cdn-dp fec00000.dp: [drm:cdn_dp_dpcd_read] *ERROR* dpcd read failed: -22
[33 repeated messages suppressed]
usb 3-1.2: New USB device found, idVendor=2109, idProduct=0100
usb 3-1.2: New USB device strings: Mfr=1, Product=2, SerialNumber=3
usb 3-1.2: Product: USB 2.0 BILLBOARD
usb 3-1.2: Manufacturer: VIA Technologies Inc.
usb 3-1.2: SerialNumber: 0000000000000001
cdn-dp fec00000.dp: [drm:cdn_dp_dpcd_read] *ERROR* dpcd read failed: -22
[94 repeated messages suppressed]
cdn-dp fec00000.dp: [drm:cdn_dp_check_sink_connection] *ERROR* Get sink capability timed out
cdn-dp fec00000.dp: [drm:cdn_dp_pd_event_work] *ERROR* Enable dp failed -19

What might be wrong?  I reiterate that this did work yesterday, and there have been no software updates since.  I'm running the stock install and mrfixit_update.sh reports nothing to do.
#2
Update: I tried installing unstable Debian using danielt's script, which brings a substantially newer kernel (5.5.0).  The flood of "dpcd read failed: -22" errors do not happen with this kernel, but I still get the "Get sink capability timed out" error, and the external display doesn't activate:


Code:
[    4.345616] cdn-dp fec00000.dp: [drm:cdn_dp_pd_event_work [rockchipdrm]] Not connected. Disabling cdn
[    4.501049] cdn-dp fec00000.dp: [drm:cdn_dp_pd_event_work [rockchipdrm]] Connected, not enabled. Enabling cdn
[    9.692480] cdn-dp fec00000.dp: [drm:cdn_dp_check_sink_connection [rockchipdrm]] *ERROR* Get sink capability timed out
[    9.694181] cdn-dp fec00000.dp: [drm:cdn_dp_pd_event_work [rockchipdrm]] *ERROR* Enable dp failed -19


I also tested the cable and USB-C adapter using a different computer (running Windows) and they seem to be fine.

please help i'm at my wits' end here
#3
Hi,

I am currently investigating myself why during a travel session at the beginning of February I suddently could not drive an external monitor anymore.

I now reinstalled the OS based on danielt's scripts with crypted Debian Buster - the dptx.bin file is present in initramfs and loads.

The errors I see are the exact same as in zackw's last post.

I got three different adapters - 2x DP Alternative Mode to HDMI and 1x a pure DP one.

I don't remember which adapter worked before, but one most definitively did. Now all three only result in "Enable dp failed -19".
It makes no difference if i use the 5.4 or the 5.5 kernel - so far I did not install the stock OS again.

Any other part of the adapters(Network, USB-A, microSD Readers) work.

Its all a bit strange.
#4
Hi,

Here I experiment the same problem, USB-C to hdmi adapter works like a charm for more than two month, and today, not even after a upgrade or update, I can see the exact same error as in zackw's post and no external monitor.

I will try to investigating too. I try two different adaptator which worked before.

Its all a bit strange.

Hi, me again,

Without any change, it magical reworks - I am only making some manipulations (test with differents adaptator, plug and unplug)

https://github.com/torvalds/linux/blob/m...-dp-core.c
The timeout is for 5 seconds.
Maybe in some case, it's not enough, and we shoud  ?

In the code we have this comment :

Code:
/*
* Attempt to read sink count, retry in case the sink may not be ready.
*
* Sinks are *supposed* to come up within 1ms from an off state, but
* some docks need more time to power up.
*/


Possibly Related Threads…
Thread Author Replies Views Last Post
  Slackware Linux working on PBP vxzero 0 112 06-05-2024, 04:30 PM
Last Post: vxzero
Exclamation 'failed to open panfrost' after system update using archarm Puckla 1 502 03-01-2024, 06:46 PM
Last Post: Puckla
  No external monitorvia USB-C over Dockingstation bnjmnhg 14 3,591 11-28-2023, 01:35 PM
Last Post: zaius
  Nethunter default password failed lamlarryyyy 0 463 11-23-2023, 02:48 AM
Last Post: lamlarryyyy
  Manjaro ARM: enabling external monitors & fixing Broadcom WiFi after updating trifleneurotic 2 1,109 11-14-2023, 10:57 AM
Last Post: trifleneurotic
  USB 3 port not working with Armbian zaius 3 1,064 11-13-2023, 01:54 PM
Last Post: zaius
  Sleep and external display - Are there any options? chris88233 7 2,081 09-04-2023, 09:03 PM
Last Post: wdt
  Camera not working with Cheese cypresstwist 1 1,351 08-18-2023, 02:02 AM
Last Post: juliamenendez
  5GHz wifi not working snorwood 11 6,028 01-16-2023, 03:41 PM
Last Post: ehcorn
Question Debian (Vanilla) no output on display after Kernel update (6.0.8-1) as365n4 1 1,359 12-09-2022, 12:43 PM
Last Post: as365n4

Forum Jump:


Users browsing this thread: 1 Guest(s)