No Android build working!
#11
Hello everyone,
I'm also having the same problem here with the latest PBP batch.
I have tried etcher on windows and manjaro, both complain about the boot section not being found. And if i ignore the error and carry on with flashing the micro sd card, i can't boot from sd once flashing is finished.
Any idea why this is happening? maybe something related to the boot installed on emmc on latest PBPs ?
  Reply
#12
Looks like it is caused by Uboot from Manjaro.
The Q4OS team is also investigating, but their first attempt to fix failed on my machine.
https://forum.pine64.org/showthread.php?...3#pid68383
  Reply
#13
(06-17-2020, 03:44 PM)jiyong Wrote: Looks like it is caused by Uboot from Manjaro.
The Q4OS team is also investigating, but their first attempt to fix failed on my machine.
https://forum.pine64.org/showthread.php?...3#pid68383
Ok thanks for the information. I'll keep an eye on the other thread Smile
  Reply
#14
Again, if you're using any Android img other than http://files.pine64.org/os/PinebookPro/A...oot.img.gz it WILL NOT BOOT on your PBP. For some reason the others just don't boot.
  Reply
#15
(06-17-2020, 03:57 PM)tophneal Wrote: Again, if you're using any Android img other than http://files.pine64.org/os/PinebookPro/A...oot.img.gz it WILL NOT BOOT on your PBP. For some reason the others just don't boot.

Even this image won't boot. uboot version on manjaro is different from the one present in debian stock PBP from what i understand.
  Reply
#16
I see your issue is the botched uboot not booting SD? There a new update to Manjaro uboot that was pushed the other day. Since Manjaro was made aware of the fault, hopefully it’s a fix
  Reply
#17
(06-18-2020, 05:25 AM)tophneal Wrote: I see your issue is the botched uboot not booting SD? There a new update to Manjaro uboot that was pushed the other day. Since Manjaro was made aware of the fault, hopefully it’s a fix

Oops sorry i forgot to mention that i was trying to boot android from SD indeed. I'll wait for the fix then, thank you for the information
  Reply
#18
(06-18-2020, 06:11 AM)slow_motion Wrote: Oops sorry i forgot to mention that i was trying to boot android from SD indeed. I'll wait for the fix then, thank you for the information

It's actually pretty easy to fix (and get deep sleep in Manjaro) by flashing the v2 uboot from the original Debian build. The first paragraph in this section of the wiki has a link to mrfixits repo, where you can get the 3 uboot imgs and a script to help write them to the emmc. Just be sure you're one the v2 branch. https://wiki.pine64.org/index.php/Pinebo...root_drive
  Reply
#19
(06-18-2020, 06:30 AM)tophneal Wrote:
(06-18-2020, 06:11 AM)slow_motion Wrote: Oops sorry i forgot to mention that i was trying to boot android from SD indeed. I'll wait for the fix then, thank you for the information

It's actually pretty easy to fix (and get deep sleep in Manjaro) by flashing the v2 uboot from the original Debian build. The first paragraph in this section of the wiki has a link to mrfixits repo, where you can get the 3 uboot imgs and a script to help write them to the emmc. Just be sure you're one the v2 branch. https://wiki.pine64.org/index.php/Pinebo...root_drive

Ok so if i understood your explanation, all i need to do is download the three binaries and execute the bash script, this would maintain manjaro as the primary os on emmc, and i would then be able to boot android from sd.
The next question is how can i be sure that i have the v2 branch please?
  Reply
#20
(06-18-2020, 07:11 AM)slow_motion Wrote: Ok so if i understood your explanation, all i need to do is download the three binaries and execute the bash script, this would maintain manjaro as the primary os on emmc, and i would then be able to boot android from sd.
The next question is how can i be sure that i have the v2 branch please?

That is correct! On the Github page, right under the Code tab, there's a branch dropdown selector.
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  Google on Android? KC9UDX 17 4,798 01-23-2021, 11:47 PM
Last Post: KNERD
  Getting platform tools working like I'm used to? bastafari 20 5,701 12-24-2020, 01:14 AM
Last Post: jonnyhawk
  MD5 On Android jaysistar 0 720 03-14-2020, 08:38 AM
Last Post: jaysistar
  Arguments for android support metcalsr 20 8,189 02-08-2020, 12:12 PM
Last Post: Idaho
Exclamation All android buillds on wiki for Microsd missing GPT? TDC_PBP 14 5,954 01-31-2020, 11:22 PM
Last Post: tophneal
  Any word about Android builds? tophneal 36 14,599 01-26-2020, 12:06 AM
Last Post: Account
  Flashing Updated U-Boot on Android tophneal 6 2,803 01-16-2020, 06:05 AM
Last Post: tophneal

Forum Jump:


Users browsing this thread: 1 Guest(s)