pinebook pro does not turn on
#1
Hi good people

My pinebook pro does not turn on today. Sad
I have charged it for several hours now. Tried both the standard 5V charger and a USB-C charger. The red led next to power input is on.
When I press the power button on the keyboard there is a short green pulse on the power led. That is all. Screen is black.
I run the standard Debian on EMMC. I tried to burn Manjaro image to SD-card. No change, no boot.

I have the serial to usb cable, but nothing seems to be written here.

What is next to try?

Regards
#2
*******************UPDATE*********************
Added an attached image of the power bus cables for you
***********************************************

Hi,

I found that the battery pack is evidently defective for my PBP. 

Note my post from yesterday: UPDATE - NOW POWERED UP VIA MAINS! Re: PBP No Power

So, I effectively removed the bottom cover tested many avenues that have been recommended as you did.

I then disconnected the battery pack bus from the main board and removed the battery pack from the chassis, then took the red and black bus that is under
the yellow sticker and its female end that is  hidden under a piece of black anti-static shielding tape on the laptop chassis.
They connect and will allow direct power to flow from your AC adapter to the main board.

TO DO THIS THE BATTERY MUST BE DISCONNECTED AND REMOVED FIRST!

Once you make the red and black direct power connection, then try long pressing the power button on your keyboard.

Hope this helps!

I am still trying to obtain feedback on how to obtain a similar spec replacement battery. 

But in the interim I was able to boot with direct AC adapter power and back to working with my PBP.


Attached Files
.png   Mains.png (Size: 326.35 KB / Downloads: 243)
#3
Hi
I tried to disable EMC, no change... Except that the power led does not blink green now.

I measured on the battery. 4.16V DC between the red and black wires.
Nothing between the yellow and the black. What is the yellow wire?

Also, it does not boot when I connect the bypass cables.
Why is the bypass cable two wires (red and white) when they are soldered together on the main print.

.jpg   IMG_0091c.jpg (Size: 361.21 KB / Downloads: 234)

.jpg   IMG_0092c.jpg (Size: 340.3 KB / Downloads: 212)
Is that correct? Can someone confirm.

When the bypass cable is connected I cannot measure any voltage on the DC In test point (against e.g power in socket).
With bypass cable disconnected, the charging led blinks.

Any suggestions?

Best Regards


Possibly Related Threads…
Thread Author Replies Views Last Post
  Selling my Pinebook Pro brent.thierens 11 2,588 Yesterday, 06:13 AM
Last Post: mikesores
  Pinebook got wet walterbe 6 131 09-22-2021, 04:19 AM
Last Post: biketool
  ISO/UK Pinebook Pro for sale mstevens 4 275 09-17-2021, 10:49 AM
Last Post: mstevens
  Testing Some More Games on the Pinebook Pro! ImmyChan 3 226 09-16-2021, 07:06 AM
Last Post: poVoq
  Looking to buy a Pinebook Pro US Stucht13 11 1,073 09-11-2021, 06:40 PM
Last Post: drinkmorejava
  Pinebook Pro (ISO) for sale from Germany to Europe and UK 1yk0s 1 402 09-08-2021, 10:55 AM
Last Post: cypresstwist
Star Looking to buy a Pinebook Pro in Europe cypresstwist 0 137 09-04-2021, 02:02 PM
Last Post: cypresstwist
  Pinebook Pro Stopped Charging via USB-C MickTheGeek 4 363 08-25-2021, 02:51 PM
Last Post: MickTheGeek
  Pinebook Pro (ISO) for sale - UK Sootstone 2 450 08-24-2021, 03:08 PM
Last Post: Sootstone
  looking to buy one pinebook pro (mainland China) duanduan 0 137 08-24-2021, 08:53 AM
Last Post: duanduan

Forum Jump:


Users browsing this thread: 1 Guest(s)