Flash dhivael's SPI uboot (risky)
#41
You need serial cable Smile
  Reply
#42
I hope someone will find a way how to solve this without serial cable Smile At least I can play with Manjaro for a while, although I don't like it very much because of its bloatware.
  Reply
#43
By the chance, have anyone tried some Ubuntu based distro with this SPI uboot yet?
  Reply
#44
(02-21-2020, 12:28 PM)Wizzard Wrote: By the chance, have anyone tried some Ubuntu based distro with this SPI uboot yet?
@Wizzard ,

I relize that I have been using it while tyring to get a mainline kernel working with Armbian.  I have no problem booting an sd (i have Manjaro running on my ssd right now,  and don't want to remove at the moment) .

to get Armbian to boot,  I commented out this line 

if test "${devtype}" = "mmc"; then part uuid mmc ${devnum}:1 partuuid; fi

in the boot.cmd file and regenerated the boot.scr.


The instructions for regenerating the boot.scr file are at the bottom of the boot.cmd file.
  Reply
#45
Thanks, but it still boots to blank screen...
  Reply
#46
Hi all, I have been having some issues with my pinebook pro hoping this can help it out.

As of about a month ago I have not been able to boot it, it has been stuck in maskrom mode when I tested it with rkdeveloptools. I ordered the usb to emmc and have tried boot from this or the sd card: Manjaro preferentially but also the two types of Debian and Android but no life. Not even the led light (early on would turn green but not recently)

In desperation I tried this SPI flash. There was no issue at any point, write was successful! But at the end the power led turned orange instead of red and still cannot boot anything. Does anyone know what the orange ("amber") led means in this case? And perhaps something else to try I am out of ideas. Thanks in advance.
  Reply
#47
@LostZimbo on my pbp led is always amber until it finds a device that it can boot from. So it looks like yours is ok.
Did you try Manjaro ?
Do you have serial cable ?
  Reply
#48
@LostZimbo,

Have you tried removing the emmc AND throwing the switch which tells the system not to use the EMMC AND pressing the reset button, then doing a clean install of a distribution on an SD card which you are sure is good?

As @as400 has indicated, it really helps to be able to see the u-boot messages by using the serial cable, but by trying to boot only from the sd card and by being sure the emmc is not involved in any way, you should have some additional information.

How have you been writing the image to the sd or emmc--dd, etcher, something else? Had you made any changes to software or hardware immediately before it stopped booting? Let us know what happens.
  Reply
#49
If you don't have any, and if you are going for an serial cable, please check this Thread before ordering something.
  Reply
#50
Good news! Randomly I just tried to boot Manjaro off of a USB stick and it worked!! It is very slow, because the only spare USB I have is a piece of crap (ordered a new one to work with for now) but my pinebook pro is still alive!

Current status is that it will boot from USB, but not from SD or eMMC. I do not know about the NVMe, I bought the adapter from the pinestore on a whim but do not have one to test with. I do not have a serial cable, I intend to make one this weekend to try to gain more information from the eMMC boot. Thank you for the link I will include a 5V to 3.3V converter which I have plenty of.

Separately, I set the eMMC card up for my rockpro64 again with Manjaro (love this ARM distro) it booted without a problem.
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  How to rewrite uboot to emmc pineitup 5 1,718 12-27-2020, 10:35 AM
Last Post: nightranger73
  Extracting a copy of SPI NOR flash contents using micro SD card and u-boot hmuller 0 617 09-21-2020, 11:24 AM
Last Post: hmuller
  Program SPI NOR Flash on Pinebook Pro with u-boot on micro SD Card hmuller 0 810 09-21-2020, 10:02 AM
Last Post: hmuller
  In-Circuit Programming of SPI NOR Flash hmuller 13 6,741 09-13-2020, 01:20 PM
Last Post: hmuller
  Installing Ubuntu 20.04 (Focal) with BSP uBoot with deep sleep and sound Syonyk 43 16,880 07-28-2020, 03:18 PM
Last Post: SamWilts
  How to boot Manjaro from NVME with uboot on eMMC as400 47 18,177 06-07-2020, 02:37 AM
Last Post: as400
  (almost) upstream uboot/atf dhivael 27 10,437 02-08-2020, 10:18 PM
Last Post: Natrox
  Widevine-flash on Chromium-SD Card mamboman777 3 2,105 01-20-2020, 04:00 PM
Last Post: tophneal

Forum Jump:


Users browsing this thread: 1 Guest(s)