Hardware video codec
#11
I am running Manjaro now, so I can't reproduce this right now.

The upstream ffmpeg and mpv don't support rkmpp. When you run `ffmpeg` it shows you the compile flags. If you don't see "--enable-rkmpp" then you have the upstream version.

The Netflix problem is unrelated, no browser can do hardware video decoding on the PBP (except ChromeOS)

I have a question for people running the mainline kernel: Have you had any success utilizing the hantro-vpu driver? v4l2-ctl shows that there is support for a JPEG encoder and a mpeg2 and vp8 decoder. I could use the JPEG encoder with gstreamer, but the decoder doesn't seem to work on either ffmpeg or gstreamer.
#12
I downloaded the standard Debian image and put it onto a sd card and booted from there. The ffmpeg from the sd card behaves just the way you are describing.  I assume, the standard image contains a specifically built ffmpeg for the pbp.I'll ask on the 'standard os' thread, how to keep the standard os installation up to date without losing mrfixit2001's modifications.
#13
1. Does anyone have a full list of packages to be kept from updating?
2. Does anyone have mentioned packages from original default OS image (or files)?
#14
(02-12-2020, 12:12 PM)wrzomar Wrote: 1. Does anyone have a full list of packages to be kept from updating?
2. Does anyone have mentioned packages from original default OS image (or files)?

On a fresh install of default debian:

Code:
rock@Debian-Desktop:~$ dpkg  --get-selections|grep -v install
ffmpeg                      hold
ffmpegthumbnailer               hold
rock@Debian-Desktop:~$

And have a look at /etc/apt/apt.d.conf. Kernel and firmware is kept from upgrading.

On my already upgraded system on emmc: when i call ffmpeg from the sd card, on which the fresh install is located,
ffmpeg complais about a missing library:


Code:
u1@pbp:/media/u1/e9e67d6e-9693-4f25-bbd6-ae24f7c9e5bb/usr/bin$ ./ffmpeg
./ffmpeg: error while loading shared libraries: libavdevice.so.58: cannot open shared object file: No such file or directory


I copied the library from the sd to the emmc. After that, ffmpeg complained about another lib. After copying a few, I gave up.
#15
I've followed instructions from:
https://forum.pine64.org/archive/index.p...-7112.html

but freshly built mpv has segfault every time. I'm thinking about reflashing emmc and starting fresh.
#16
1. don't use aptitude
2. do use apt pinning
#17
I wasn't using aptitude. Does apt pinning protect from apt autoremove?
#18
Hello! Any news to fix this problem?

If Manjaro has solved the problem, how do I transfer the fix to Debian?
Pinebook Pro, standard config (Manjaro)
#19
manjaro solved this problem by using mainline linux and not relying on an easily breakable apt configuration.

mrfixit's approach is vulnerable to many issues and this is one of them. you probably need to copy all of the ffmpeg files from an updated default os.

one of the issues is that hwaccel in 4.4 is vastly different that mainline. honestly, mainline is still catching up, but will soon exceed.
#20
Looks like there is not much point in sticking with the default Debian install.
Manjaro wil be the default, starting with the next batch (see March update).
https://www.pine64.org/2020/03/15/march-...-software/

Meanwhile I found some info on the ODroid forum.
Just in case Manjaro doesn't activate the hardware encoder.
https://forum.odroid.com/viewtopic.php?t=30470
https://github.com/rockchip-linux/gstreamer-rockchip


Possibly Related Threads…
Thread Author Replies Views Last Post
  U-Boot, video console, and visual artifacts dsimic 19 7,916 06-21-2022, 05:28 AM
Last Post: Tazdevl
  Kdenlive or other video editing software?? SuttonWillow 4 2,103 05-26-2022, 09:11 PM
Last Post: IsraelRobinson
Question USB-C Video Out Issue dev 2 525 02-08-2022, 07:28 PM
Last Post: dev
  Hardware problems with PineBook Pro James Good 7 4,710 07-09-2021, 12:24 PM
Last Post: moonwalkers
  Video : Review of the PineBook Pro with Armbian NicoD-SBC 1 1,237 07-06-2021, 10:10 PM
Last Post: tllim
  Pinebook Pro not powering on when eMMC hardware switch is off vgrimaldi 2 1,409 06-29-2021, 05:19 AM
Last Post: KC9UDX
  HArdware issues while charging user18130814200115 2 1,546 05-01-2021, 04:13 AM
Last Post: gabeeg
  Video Editing Is Possible On The PineBook Pro! ImmyChan 8 2,437 04-01-2021, 09:27 PM
Last Post: dsimic
  Netflix, Amazon Prime Video, and Chromium. Nobot 13 12,374 03-12-2021, 10:46 AM
Last Post: spikerguy
  Kdenlive or other video editing software? ImmyChan 2 1,577 01-19-2021, 01:12 AM
Last Post: KC9UDX

Forum Jump:


Users browsing this thread: 1 Guest(s)