A quick tutorial on having the image work its best
#11
(02-09-2020, 07:46 AM)kop316 Wrote:
(02-08-2020, 10:08 PM)liamsgotgenes Wrote:
(02-08-2020, 12:21 PM)kop316 Wrote: Hello,

To confirm, this seems to be different than here:

https://megous.com/dl/tmp/modem.txt

Can I ignore the link above for Ubuntu touch, or is the shutdown still essential in the aboce link?

EDIT: The script from megous does not seem to work in Ubuntu Touch.

I believe the script will only work on megous' kernel they are working on: https://xff.cz/kernels/

Note that right before the script he says "...enable the modem in my kernel..."

Makes sense. It was hard to tell if that was already in Ubuntu Touch. It sounded like it was in here and Postmarket OS.

This is not in UT yet.
You can find me on IRC, Discord and Twitter


#12
Is there a way to save the modem settings without having to retype the commands upon reboot?
#13
(02-11-2020, 02:34 PM)cow_killer Wrote: Is there a way to save the modem settings without having to retype the commands upon reboot?

Just make a bash script and if you like a desktop file so it shows up as an app (I assume ubports uses desktop files)
#14
Better yet make an init script for whatever init system the OS is using and let that run things on start/stop. There may be something needed for suspend too, so that an incoming call or text can wake the phone.
#15
I installed the system image of the 12th of February 2020 and now the commands:
amixer -c 0 set 'AIF1 Slot 0 Digital DAC' unmute
and similar fails with message:
amixer: Unable to find simple control 'AIF1 Slot 0 Digital DAC' and similar ones
The image of the 11th of February 2020 didn't have this problem.
#16
(02-13-2020, 12:20 AM)ivanB1975 Wrote: I installed the system image of the 12th of February 2020 and now the commands:
amixer -c 0 set 'AIF1 Slot 0 Digital DAC' unmute
and similar fails with message:
amixer: Unable to find simple control 'AIF1 Slot 0 Digital DAC' and similar ones
The image of the 11th of February 2020 didn't have this problem.

That's weird because it seems that there have not been any changes committed since February 7, unless I'm misunderstanding the build history.
#17
(02-13-2020, 12:20 AM)ivanB1975 Wrote: I installed the system image of the 12th of February 2020 and now the commands:
amixer -c 0 set 'AIF1 Slot 0 Digital DAC' unmute
and similar fails with message:
amixer: Unable to find simple control 'AIF1 Slot 0 Digital DAC' and similar ones
The image of the 11th of February 2020 didn't have this problem.

Same for me, unable to have any speaker working
#18
(02-13-2020, 01:52 PM)pepo Wrote:
(02-13-2020, 12:20 AM)ivanB1975 Wrote: I installed the system image of the 12th of February 2020 and now the commands:
amixer -c 0 set 'AIF1 Slot 0 Digital DAC' unmute
and similar fails with message:
amixer: Unable to find simple control 'AIF1 Slot 0 Digital DAC' and similar ones
The image of the 11th of February 2020 didn't have this problem.

Same for me, unable to have any speaker working

I assume you started the line with 'sudo'?  The commands won't work without administrator privileges.
I refuse to tiptoe through life, only to arrive safely at death.
#19
(02-13-2020, 01:52 PM)pepo Wrote:
(02-13-2020, 12:20 AM)ivanB1975 Wrote: I installed the system image of the 12th of February 2020 and now the commands:
amixer -c 0 set 'AIF1 Slot 0 Digital DAC' unmute
and similar fails with message:
amixer: Unable to find simple control 'AIF1 Slot 0 Digital DAC' and similar ones
The image of the 11th of February 2020 didn't have this problem.

Same for me, unable to have any speaker working

I had that once, I solved it with (not sure why, but it worked):
Code:
echo "PULSE=no" > /etc/pulse/pulse.cfg
#20
(02-14-2020, 05:28 AM)PinePhoneCoder Wrote:
(02-13-2020, 01:52 PM)pepo Wrote:
(02-13-2020, 12:20 AM)ivanB1975 Wrote: I installed the system image of the 12th of February 2020 and now the commands:
amixer -c 0 set 'AIF1 Slot 0 Digital DAC' unmute
and similar fails with message:
amixer: Unable to find simple control 'AIF1 Slot 0 Digital DAC' and similar ones
The image of the 11th of February 2020 didn't have this problem.

Same for me, unable to have any speaker working

I had that once, I solved it with (not sure why, but it worked):
Code:
echo "PULSE=no" > /etc/pulse/pulse.cfg

how do you use this command? to me it opens a blank line with just a ">" , and then?

(02-13-2020, 06:33 PM)noeman5 Wrote:
(02-13-2020, 01:52 PM)pepo Wrote:
(02-13-2020, 12:20 AM)ivanB1975 Wrote: I installed the system image of the 12th of February 2020 and now the commands:
amixer -c 0 set 'AIF1 Slot 0 Digital DAC' unmute
and similar fails with message:
amixer: Unable to find simple control 'AIF1 Slot 0 Digital DAC' and similar ones
The image of the 11th of February 2020 didn't have this problem.

Same for me, unable to have any speaker working

I assume you started the line with 'sudo'?  The commands won't work without administrator privileges.

yes, no difference with or without sudo, in both cases the only result is a timid click coming from the speaker on the back when I tipe the first letter in the terminal, or on an app icon - but just the first letter, not the following ones


Possibly Related Threads…
Thread Author Replies Views Last Post
  Sound won’t work LMalilil 2 1,213 07-28-2020, 09:52 AM
Last Post: Cree
  wifi does not work - authentication problem? pphone-newbie 7 3,032 07-26-2020, 01:30 PM
Last Post: Cree
  dropdown menu doesn't work daniel 3 1,429 07-22-2020, 01:17 PM
Last Post: natasha
  Tutorial for new UBPorts CE users / list of known issues? ThatGeoGuy 2 1,886 07-21-2020, 05:54 PM
Last Post: natasha
  Image #58 Touchscreen Unresponsive BryWilson 3 1,833 06-27-2020, 02:38 AM
Last Post: Zweitaktmotor
  Does Miracast work? mercrapper 1 1,114 06-25-2020, 08:18 AM
Last Post: heng
  Image build guide? Djhg2000 3 1,955 06-18-2020, 02:04 PM
Last Post: bingo600
  Only the top few rows of pixels work on stable OTA 3 NoraCodes 0 741 06-18-2020, 09:18 AM
Last Post: NoraCodes
  Battery issues with latest image ashley123 6 2,754 06-14-2020, 11:06 AM
Last Post: KeithMcN
  Ubports OTA won't work on my braveheart none 12 5,242 06-13-2020, 03:23 AM
Last Post: tsar_chasm

Forum Jump:


Users browsing this thread: 1 Guest(s)