Booting from an SD card without the boot order update
I got a Pinebook Pro the other day.

I was getting no sound, and although wifi worked, the USB C hub with ethernet wasn't working either. I was going to try Manjaro, as someone on the fourm suggested, but I had an idea first: I'll just upgrade from strech to buster! Interestingly, the packages were mostly armhf, although there were a few arm64.

After trying to upgrade, something went wrong. The next time that I rebooted, I got an unblinking cursor at the top left after seeing a Debian login console for a fraction of a second.

I made the Manjaro SD card, but it doesn't look like the SD card is read. I saw in another post that there is an update that I should have done before anything else.

I'm guessing that what I need to do is open it up and disable the eMMC, and hope that doing so will make it no longer participate in the boot order.

I'd like to know for sure what I'm doing before opening it; can someone point me to a document that says where the dip switches are and what they do?
If you got your PBP recently, you should have the necessary update already I believe.

But first, can you get to a tty?

Also how did you write Manjaro to the SD?
I can't seem to get to a TTY. I've tried `Control` + `Alt` + `F1` through `F12` (even though I've rarely seen machines with anything past `F7`. I do still see the flash of the login prompt, but even before I was in this situation, I tried switching to a TTY, and it didn't work, so if I'm doing it wrong for this machine, please let me know.

I used Rufus on a Windows machine to write the Manjario `.img` file to the SD.
Balena Etcher seems to be a dependable (and simple) way to write to your SD cards...
. .> There are excellent directions on using etcher at their website,   though I think they may be listed also in the Pinebook Pro wiki.

The wiki also lists some proven distros for download.

The actual  'boot order' on a factory OEM loaded PBP is on your eMMC
   Donate to $upport
your favorite OS Team
Given that I believe that the SD card is correctly written (I could be wrong, but it seems to be correct), I opened the Pinebook Pro to look for a switch to disable the eMMC to force the SD card to be used. I only see the Reset and Recovery buttons, and no dip switches. Before I try anything else, I'd really like to better know what I'm doing: How do I force the SD card to be used to boot?
ITEM #24  on the wiki picture of the PBP's insides eMMC switch.

IF you really think that is best route for you.

If you have not changed anything on your original eMMC software...?  and it will not boot first from the SD card...  I would strongly suggest using Balena Etcher
and follow their directions to load your SD card.

That is just my opinion,  I do wish you Luck ether way.
   Donate to $upport
your favorite OS Team
I will try Balena Etcher first.
Thanks! It looks like the app used to write to the SD card was the problem after all.

Also, thanks for pointing me to the wiki. I didn't have to flip any switches, but it's good to know where they are, if I ever need to.

Possibly Related Threads…
Thread Author Replies Views Last Post
  upgrading u-boot--what version? where to get it? bsammon 11 735 05-22-2024, 09:33 AM
Last Post: wdt
  uboot wont boot to SD card after upgrade jbradley419 7 1,261 01-19-2024, 02:29 PM
Last Post: wdt
  Video Flashing/adjusting on boot and reboot jbradley419 0 422 01-16-2024, 09:17 AM
Last Post: jbradley419
  Brand new Pinebook Pro doesn't boot after Manjaro update johnboiles 8 2,695 12-15-2023, 02:11 PM
Last Post: wdt
  PBP won't boot after trying to reinstall Manjaro ARM soupgirl 3 954 12-13-2023, 08:17 PM
Last Post: trillobite
  Various freezes during boot & while running several Linux distros - hardware error? donuts 1 755 11-22-2023, 11:47 AM
Last Post: fxc
  Cannot boot to Kali SD card after uboot upgrade jbradley419 4 1,437 09-19-2023, 08:48 AM
Last Post: dachalife
  After update, multiple problems, pinebook pro. jd50i 1 1,209 09-16-2023, 09:41 AM
Last Post: jd50i
  Does latest Tow-Boot install/work correctly for everyone? tophneal 4 2,217 08-03-2023, 03:30 PM
Last Post: tophneal
  Boot into NVME drive, no wifi, sound, buttons... PaulQ 0 909 07-13-2023, 01:50 PM
Last Post: PaulQ

Forum Jump:

Users browsing this thread: 1 Guest(s)