(almost) upstream uboot/atf
#21
I gave this a shot but I was not able to get the NVME (Manjaro Arm) to work. Hangs on black screen. My uboot is on the eMMC.
  Reply
#22
(02-07-2020, 09:25 AM)Natrox Wrote: I gave this a shot but I was not able to get the NVME (Manjaro Arm) to work. Hangs on black screen. My uboot is on the eMMC.

Come to the discord/matrix/telegram/irc #pinebook channel and work it out with us.
  Reply
#23
(02-07-2020, 09:25 AM)Natrox Wrote: I gave this a shot but I was not able to get the NVME (Manjaro Arm) to work. Hangs on black screen. My uboot is on the eMMC.

do you have a uart cable? seeing uboot output for these failures would be very helpful for debugging, otherwise it's just poking in the dark.

can you boot from an sd card at least? if not you'll probably have to open your pinebook and disable emmc for a second during boot to boot from a known-good sd card and reinstall uboot from there
  Reply
#24
(02-07-2020, 11:34 AM)clover Wrote:
(02-07-2020, 09:25 AM)Natrox Wrote: I gave this a shot but I was not able to get the NVME (Manjaro Arm) to work. Hangs on black screen. My uboot is on the eMMC.

Come to the discord/matrix/telegram/irc #pinebook channel and work it out with us.

I'll hop on later! Thanks.

(02-07-2020, 02:32 PM)dhivael Wrote:
(02-07-2020, 09:25 AM)Natrox Wrote: I gave this a shot but I was not able to get the NVME (Manjaro Arm) to work. Hangs on black screen. My uboot is on the eMMC.

do you have a uart cable? seeing uboot output for these failures would be very helpful for debugging, otherwise it's just poking in the dark.

can you boot from an sd card at least? if not you'll probably have to open your pinebook and disable emmc for a second during boot to boot from a known-good sd card and reinstall uboot from there

I unfortunately didn't order an UART cable, so I might have to make one myself. I am able to boot from SD, so the new uboot does work. From there, I am able to restore my old uboot.
  Reply
#25
Natrox: Happy to hear that the new uboot ended up working!
  Reply
#26
Just gotta get it working for NVME now. Wink
Let's see if we can track down the problem somehow, could just be an issue on my side.
  Reply
#27
(02-07-2020, 10:14 PM)Natrox Wrote: Just gotta get it working for NVME now. Wink
Let's see if we can track down the problem somehow, could just be an issue on my side.

https://forum.pine64.org/showthread.php?tid=8804

I think this ^ forum post is a great way to start. and then once you get that down you can graduate to flashing the SPI (https://forum.pine64.org/showthread.php?tid=9053) Wink
  Reply
#28
(02-08-2020, 12:14 PM)clover Wrote:
(02-07-2020, 10:14 PM)Natrox Wrote: Just gotta get it working for NVME now. Wink
Let's see if we can track down the problem somehow, could just be an issue on my side.

https://forum.pine64.org/showthread.php?tid=8804

I think this ^ forum post is a great way to start. and then once you get that down you can graduate to flashing the SPI (https://forum.pine64.org/showthread.php?tid=9053) Wink

Oh yeah, I've got that uboot working a while ago. Smile  I was hoping the more upstream atf/uboot would help me get suspend-to-disk working. I think I'll hold off from messing about for now; I spent all day yesterday trying to get my PBP to come back to live (after fixing the short) and went through two Manjaro reinstalls (thankfully with some backups). 

On the second re-install I decided to clean up my backed up package list and remove anything sketchy or unneeded. Now my system still boots, so I believe one of the packages was responsible. Dunno which one though.

Anyway, I'm done tinkering for the weekend.  Tongue
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  How to rewrite uboot to emmc pineitup 5 1,716 12-27-2020, 10:35 AM
Last Post: nightranger73
  Installing Ubuntu 20.04 (Focal) with BSP uBoot with deep sleep and sound Syonyk 43 16,850 07-28-2020, 03:18 PM
Last Post: SamWilts
Exclamation Flash dhivael's SPI uboot (risky) clover 51 18,447 06-20-2020, 03:24 PM
Last Post: craftkiller
  How to boot Manjaro from NVME with uboot on eMMC as400 47 18,156 06-07-2020, 02:37 AM
Last Post: as400

Forum Jump:


Users browsing this thread: 1 Guest(s)