PBP ANSI Keyboard Mapping Issue
#1
All, just dropping a note.  Just opened my PBP and everything looks good.  Only issue I found was that while typing the double quote '"' and the at '@' were reversed.  It appears that this is because the default keyboard mapping was set to English(UK) instead of English(US).  

After changing it seems to be working as expected!

-Jared
  Reply
#2
It is indeed just that, ANSI uses US layout and the OS comes with UK as default.
  Reply
#3
(01-11-2020, 08:18 AM)fpex73 Wrote: It is indeed just that, ANSI uses US layout and the OS comes with UK as default.

Because initially we weren't planning on ANSI ...
You can find me on IRC, Discord and Twitter


  Reply
#4
(01-10-2020, 05:42 PM)JaredT66 Wrote: All, just dropping a note.  Just opened my PBP and everything looks good.  Only issue I found was that while typing the double quote '"' and the at '@' were reversed.  It appears that this is because the default keyboard mapping was set to English(UK) instead of English(US).  

After changing it seems to be working as expected!

-Jared

Thanks for posting this. Just got my PBP and noted the same problem (plus the pipe character is different). You saved me a lot of time tracking it down.
  Reply
#5
(01-11-2020, 04:15 PM)Luke Wrote:
(01-11-2020, 08:18 AM)fpex73 Wrote: It is indeed just that, ANSI uses US layout and the OS comes with UK as default.

Because initially we weren't planning on ANSI ...

Very glad you changed your minds!
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  Selling ANSI PBP US only edandjeanmcknight@gmail.com 0 111 05-03-2021, 06:52 AM
Last Post: edandjeanmcknight@gmail.com
  Sell me your broken keyboard for parts? Timpanogos Slim 0 240 03-21-2021, 01:39 PM
Last Post: Timpanogos Slim
  [SOLD] Pinebook Pro for sale - ISO keyboard - UK only c6Q$! 0 398 02-21-2021, 09:19 AM
Last Post: c6Q$!
  [split] U-Boot with NVMe support, keyboard & display working as400 83 32,433 01-27-2021, 12:48 AM
Last Post: as400
  No keyboard & trackpad leads to no display. RMA from the US. Free parts in Seattle BitterPine 4 1,707 12-30-2020, 06:14 AM
Last Post: BetteHoward
Bug [Fixed] Issue with mesa-git (Manjaro ARM Stable Update 2020-09-22)) JasonG-FR 20 6,295 12-12-2020, 05:09 AM
Last Post: mogwai
  SOLD! US: Selling ANSI Pinebook Pro qchapter1 11 2,161 12-10-2020, 04:21 PM
Last Post: qchapter1
  Keyboard settings not saved on reboot motezart 6 1,820 11-26-2020, 12:11 PM
Last Post: creaverse
  Pinebook Pro PCIe init issue R32Fanboy 4 1,322 11-05-2020, 09:59 AM
Last Post: vssz
  Boot issue (red light) pineitup 10 2,895 11-01-2020, 11:26 PM
Last Post: wdt

Forum Jump:


Users browsing this thread: 1 Guest(s)