Looking to commission a new Chromium build (COMMUNITY BOUNTY)
#41
Not really, I don't expect too much to be changed actually. I will try to get crostini working on the image install itself, given the things we discussed above. Widevine doesn't work (yet), of that I'm quite sure.

Okay, so this command
Quote:sudo crosvm run \
--cpus 6 \
--mem 3000 \
--socket /run/crosvm.sock \
-r /run/imageloader/cros-termina/12371.22.0/vm_rootfs.img \
/run/imageloader/cros-termina/12371.22.0/vm_kernel
fails, but it doesn't when we use mem 2000. The socket gives a problem though, I'm stuck at 'failed to notify host system that VM is ready'

(01-04-2020, 05:29 AM)obyknovenius Wrote: From source code of chromium I figured out the command that actually runs to start VM behind the GUI when you install Linux (Beta):
sudo crosvm run \
--cpus 6 \
--mem 3000 \
--socket /run/crosvm.sock \
-r /run/imageloader/cros-termina/12371.22.0/vm_rootfs.img \
/run/imageloader/cros-termina/12371.22.0/vm_kernel

Where mem is the maximum memory vm allowed to use and the value is about 2/3 of all memory the memory. From journalctl output I  found that vm cannot be started with the error: cannot allocate memory errno 12.. If you remove this mem option it actually starts!
I tried to enable compact memory flag like here: https://stackoverflow.com/questions/4646...-available. I also tried to play with other kernel flags (don't remember already).

Can you use Mac to build chromium? Or you did install Ubuntu on it?
Can I ask you where you found this? It would be very helpful Smile
#42
Oh shit! The camera works!!!!
#43
No way! Awesome, I fixed more than I broke Big Grin
#44
Tried running vm start foo, while looking into Crostini troubleshooting, and gave way more information that vmc start termina:

crosh> vmc start foo
Error: routine at frontends/vmc.rs:151 `vm_start(vm_name,user_id_hash,features)` failed: "Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken."
#45
Did you see the memory allocation error in journalctl?
#46
(02-06-2020, 02:48 AM)brent.thierens Wrote: Did you see the memory allocation error in journalctl?

No, I forgot to go into journalctl. I can jump in and grab that, though.


EDIT: Just had a thought while going through journalctl and thinking about the memory allocation error. After a convo with dhivael in IRC about the u-boots that can and can't be used by the CrOS builds, I'm wondering if this may not be related to the Debian kernel having some kind of dependency on the u-boot/ATF files. I recall the older u-boots having issues with rockchip-dmc and setting frequencies. I wonder if after it matures more, switching to mainline kernel may help us resolve parts of this.
#47
Started wondering this morning whether I got a reply from AtB, and started checking my junk folder (nothing good there,) which led me to just try searching "arnoldthebat rk3399" and it led me to this:

Quote:Stuart Naylor
AUGUST 19, 2018 AT 9:48 AM
Is there an image that will work with many of the new RK3399 boards avail as they would seem to be more a less a Arm Chromebook on a board.
I tried with the Rock64pro but it seems to fail to boot?

REPLY
arnoldthebat
AUGUST 28, 2018 AT 12:24 PM
Unlikely at the moment.

I'm going to guess that answer hasn't changed yet.

Oh well. Onward!

EDIT:

I just tried to rerun that command again this morning, to poke around in journalctl, and now /run/imageloader/ is empty. Trying to run sudo crosvm run now gives "unexpected argument: 'KERNEL'".
#48
Can you check in your settings and recreate the Linux image? (just turn it off and on)
#49
(02-07-2020, 01:07 AM)brent.thierens Wrote: Can you check in your settings and recreate the Linux image? (just turn it off and on)

Yea, I'll do that. Interesting, I didn't realize CrOs moved those items around when installing the Linux Tools. Good to know, though.

EDIT: Just removed/turned off Linux tools in settings, but i'm still seeing an empty /run/imageloader/cros-termina through ls.
#50
No idea how that is caused. Can you recreate the image through vmc?
Btw, camera isn't working here... Did you do anything special?


Possibly Related Threads…
Thread Author Replies Views Last Post
  Black screen on both FydeOS as Chromium from github QuinTeknoLife 0 2,672 04-15-2021, 11:44 AM
Last Post: QuinTeknoLife
  Chromium OS 78? obyknovenius 2 5,079 02-04-2020, 02:11 PM
Last Post: brent.thierens
Question Does the Pinebook Pro support chromium developer mode? TDC_PBP 3 5,494 12-07-2019, 02:33 PM
Last Post: TDC_PBP
  Possible to use different uboot with Chromium? tophneal 1 3,206 11-04-2019, 08:38 AM
Last Post: tophneal

Forum Jump:


Users browsing this thread: 1 Guest(s)