All android buillds on wiki for Microsd missing GPT?
(01-31-2020, 09:24 AM)morrolinux Wrote:
(01-31-2020, 07:36 AM)tophneal Wrote:
(01-31-2020, 05:05 AM)morrolinux Wrote: I'm not sure I understand what you actually did here.
You rebooted OSX and tried again flashing with Etcher? You flashed under Ubuntu with Etcher?

I first tried writing the img with Etcher on MacOS on a MBP. It didn't work, so I rebooted into an Ubuntu install on that same machine. It didn't work either, so I then wrote it using Etcher in MacOS on a Mac Pro. That one worked.

Wow even that sounds pretty random! I actually just tried the same: except I'm getting different results: on my main computer Etcher 1.5.70 warns about the missing partition table but proceeds. The PBP won't boot anyway.
On two other machines I tested (including a Macbook Pro) Etcher will simply refuse to burn the images because of that (version 1.5.72) so no luck either.

(01-31-2020, 05:05 AM)morrolinux Wrote: Also what do you mean by "it was the stock Rockchip img, not one of the SD-prepared ones, in case anyone's wondering" ?
you haven't used the one called "Stock Android for DD method [micro SD Boot] [20190918]" but the other one called "Stock for RK Flash tool [SD Boot] [20190427]" ?
Don't you need a windows tool to burn the latter?

I used this image: Stock for RK Flash tool [SD Boot] [20190427]
The wiki does say a specific program is required, but I had no issue booting it after Etcher wrote it.

It wasn't the same for me. However, I guess the wiki should be updated to reflect that reality in that case.

(01-31-2020, 05:05 AM)morrolinux Wrote: What I found out myself is: 
- My sandisk extreme micro SD cards won't boot or will get stuck on a "dead android" logo boot loop (but others have reported no issues with their sandisk extreme... maybe a different version?)

1) I tried with a cheap 16GB kingston card and it "booted" to an "Erasing" screen, followed by a reboot to the typical "Android" logo boot splash screen, except I never got past that screen, even after 1 hour it was stuck there.

2) After forcing a shutdown from point 1) I pulled the SD card and plugged it back in my main computer where I used testdisk to recover the GPT partition table, four partitions were detected. I've mounted all of them, One of those needed to be fsck'ed.

3) Then I tried again to boot the SD card and this time after a couple of minutes I got an actual Android login prompt, where I used the password "rock" but then got a message saying that my "data" (partition) is corrupt and cannot be decrypted, inviting me to press "factory reset", so I did.

Here is where things got extremely random and frustrating:

4) The first time I did all the above I was brought to the Android recovery where I did wipe "data" myself. Then I rebooted and received an error complaining that "cache" was corrupt and needed to be wiped too (awkard since the recovery reported to have wiped the cache as well). Anyway I never managed to get into the recovery again. Even repeating the exact same previous steps for all the evening. 

5) Now it just get stuck on the Android boot splashscreen.

That is odd. Which image did you use?

I was talking about the 16GB "Stock Android for DD method [micro SD Boot] [20190918]" image.
Actually have you still got a booting Android sdcard without your personal stuff in it? (I'd assume you didn't really use it)
Because right now it would be really handy if you could hand it over so that I can test on my unit.

If you're not in a rush @tllim says he'll be providing a fresh Android 9 img in the near future.

Yeah well he said he'd explore that possibility and although I think it should be fairly easy to port the Android 9 image for the RockPro64 (which I don't understand why it doesn't already work on the PBP given it's pretty much the same product, or at least I thought) it must be said that he didn't really talk about time, and even your assumption for near future... well I find that expression pretty subjective ;-)

It's not really possible to add any account info to the Android image I have on SD, since there are no Play Services. (In fact trying to add an account in Settings will launch Email, and immediately crash.) It's not fresh, though, as I've already set my time zone and installed a few apps.

You're right, it is subjective, but it's also based off of previous instances where he has provided the community with updated Android images. It doesn't usually take him long. If he expects there to be obstacles, he's been very upfront about it in the past.

Messages In This Thread
RE: All android buillds on wiki for Microsd missing GPT? - by tophneal - 01-31-2020, 10:20 AM

Possibly Related Threads…
Thread Author Replies Views Last Post
  Google on Android? KC9UDX 18 8,367 03-15-2021, 03:21 AM
Last Post: Djokovich
  No Android build working! pin 59 28,412 02-16-2021, 02:06 PM
Last Post: Vinay
  MD5 On Android jaysistar 0 990 03-14-2020, 08:38 AM
Last Post: jaysistar
  Arguments for android support metcalsr 20 11,185 02-08-2020, 12:12 PM
Last Post: Idaho
  Any word about Android builds? tophneal 36 19,376 01-26-2020, 12:06 AM
Last Post: Account
  Flashing Updated U-Boot on Android tophneal 6 3,825 01-16-2020, 06:05 AM
Last Post: tophneal

Forum Jump:

Users browsing this thread: 1 Guest(s)