S3 sleep / suspend to ram on Ubuntu 18.04
#11
(01-17-2020, 11:53 AM)danielt Wrote: Anything running Debian Bullseye is, assuming you used my installer and didn't change it afterwards, configured to do something called suspend-to-idle.

It means that when the laptop is asked to suspend to memory the kernel will prevent any tasks from being scheduled and close down most of the device drivers. Then it just waits... in other words is relies on normal kernel power management (cpufreq, cpuidle, etc) to minimise standby power. In principle by eliminating wakeups then we ensure that cpuidle can descend to it's deepest sleep state.

Is this something you added to the kernel, or was it already part of tsys'? (I've done a little mucking around in my Manjaro install, so if it was I probably wouldn't see it now lol)
#12
(01-17-2020, 11:53 AM)danielt Wrote: Anything running Debian Bullseye is, assuming you used my installer and didn't change it afterwards, configured to do something called suspend-to-idle.

It means that when the laptop is asked to suspend to memory the kernel will prevent any tasks from being scheduled and close down most of the device drivers. Then it just waits... in other words is relies on normal kernel power management (cpufreq, cpuidle, etc) to minimise standby power. In principle by eliminating wakeups then we ensure that cpuidle can descend to it's deepest sleep state.

There are some power savings in this state (for example all the radios will get turned off) but they are pretty modest. I compared an s2idle system against a system doing nothing with the backlight turned off... s2idle ended up saving about a watt. So, not completely useless, but if I am going away for more than an hour I generally do a real power off instead.

It is configured this way because I wasn't able to get the system to turn back on after going into a deeper suspend state. There are some power savings but more importantly the laptop shouldn't hang when you close the lid: most desktop environments are configured to automatically suspend on lid-close and adopting s2idle means we don't have to hack each one separately to avoid the suspend.

Could you clarify please, how to change s2idle to suspend to ram/disk? I want to test how it works for me.
PBP ISO / Debian Bullseye (unofficial installer)
#13
(01-21-2020, 10:10 AM)wasgurd Wrote:
(01-17-2020, 11:53 AM)danielt Wrote: Anything running Debian Bullseye is, assuming you used my installer and didn't change it afterwards, configured to do something called suspend-to-idle.

It means that when the laptop is asked to suspend to memory the kernel will prevent any tasks from being scheduled and close down most of the device drivers. Then it just waits... in other words is relies on normal kernel power management (cpufreq, cpuidle, etc) to minimise standby power. In principle by eliminating wakeups then we ensure that cpuidle can descend to it's deepest sleep state.

There are some power savings in this state (for example all the radios will get turned off) but they are pretty modest. I compared an s2idle system against a system doing nothing with the backlight turned off... s2idle ended up saving about a watt. So, not completely useless, but if I am going away for more than an hour I generally do a real power off instead.

It is configured this way because I wasn't able to get the system to turn back on after going into a deeper suspend state. There are some power savings but more importantly the laptop shouldn't hang when you close the lid: most desktop environments are configured to automatically suspend on lid-close and adopting s2idle means we don't have to hack each one separately to avoid the suspend.

Could you clarify please, how to change s2idle to suspend to ram/disk? I want to test how it works for me.

If you used the unofficial debian installer and want to switch from s2idle as the default suspend mode, remove the following file (or move it somewhere else for backup).
Quote:/etc/tmpfiles.d/force-s2idle.conf

Reboot, then check the default

Quote:cat /sys/power/mem_sleep

You want to see


Quote:s2idle [deep]

If the brackets are around s2idle. Do the following.


Quote:echo deep > /sys/power/mem_sleep
Note if you run into permission issues, try doing a sudo. If the permission issue persists, do a sudo su. Then try again.

Once this is set, test out suspend

Quote:echo deep > /sys/power/state
or try (if mem_sleep was set to deep upon reboot)
systemctl suspend


Then verify the output

Quote:sudo journalctl |grep suspend
 



I noticed that suspend is much more reliable with the terminal command.


Possibly Related Threads…
Thread Author Replies Views Last Post
  How to make manjaro sleep or hibernate? KDE? regretfulpineuser 0 91 06-20-2022, 12:56 AM
Last Post: regretfulpineuser
  Working suspend on Manjaro brzegorz 3 2,279 12-03-2021, 01:39 PM
Last Post: rik-shaw
  reset sound after suspend to memory (deep sleep) Der Geist der Maschine 16 9,170 10-18-2021, 07:31 PM
Last Post: Syonyk
Question Help: Pinebook Pro will not enter sleep [Manjaro 20.04] EverythingIsInput 49 42,283 05-07-2021, 06:21 AM
Last Post: line72
  After update in Ubuntu bionic mate system crashed Wawe 2 1,736 04-18-2021, 04:52 AM
Last Post: Wawe
  Anyone can get deep sleep fully works with NVME rootfs? plumlis 0 1,263 01-11-2021, 09:58 AM
Last Post: plumlis
  Ubuntu Installation on PBP narinderpal10 5 3,335 12-18-2020, 12:22 PM
Last Post: narinderpal10
  Ubuntu MATE 18.04 Can't boot after update hankg 2 1,914 12-15-2020, 01:53 AM
Last Post: BryanF
  Installing Ubuntu 20.04 (Focal) with BSP uBoot with deep sleep and sound Syonyk 17 11,783 11-19-2020, 03:16 AM
Last Post: FeMike
  Pinebook pro crashing when put to sleep?? [Manjaro] edward 13 8,374 11-17-2020, 07:17 AM
Last Post: ab1jx

Forum Jump:


Users browsing this thread: 1 Guest(s)