Ayufan apt repository?
At http://deb.ayufan.eu/orgs/ayufan-rock64 there's no Buster.  I was careful to look for an Ayufan Buster image
https://github.com/ayufan-rock64/linux-b...m64.img.xz But I worked with it for a week or so before I discovered there are no Ayufan repositories in the sources.list it contains.

I managed to get X running but without acceleration (modesetting works), I built the armsoc driver from source.  But there's still something missing because it gives me a black screen and in the xorg log I see
[ 80174.089] (EE) AIGLX error: dlopen of /usr/lib/aarch64-linux-gnu/dri/armsoc_dri.so failed (/usr/lib/aarch64-linux-gnu/dri/armsoc_dri.so: cannot open shared object file: No such file or directory)
[ 80174.089] (EE) AIGLX error: unable to load driver armsoc

Locate finds no armsoc_dri.so anywhere, there's just an armsoc_drv.so in  /usr/lib/xorg/modules/drivers (once I fixed the PREFIX so it went there).  Are there 2 different files or should I symlink one to the other?  There aren't many (EE) errors left in the log.  And by the error it's looking where many of the normal libraries are, not where the xorg drivers are.  The path is probably compiled into armsoc_drv.so but it looks specific to armsoc.

I was poking around on here and discovered there's a script /usr/local/sbin/install_desktop.sh.  But when I tried to install manually some of the stuff it installs they aren't found like they were somewhere else.  xserver-xorg-video-armsoc, libdrm-rockchip1,  libgl4es1 are missing.  I installed what I could, there's still no armsoc_dri.so.


Looking elsewhere having the armsoc_dri.so missing is common (or always).  Fedex just unexpectedly brought me 2 new SD cards yesterday, so I'm going to load up Stretch on one.  The nice thing about having a spinning rust drive in a USB housing is that I can change SD cards and still access it.  It's just storage, I don't boot from it.
Loaded Stretch on a spare SD card, works about the same.  The Ayufan repo is in sources.list.d/ayufan-rock64.list which lists deb http://deb.ayufan.eu/orgs/ayufan-rock64/releases / (no stretch or buster)

Looking at dmesg with dmesg | grep -i mali I see
[   11.521040] I : [File] : drivers/gpu/arm/mali400/mali/linux/mali_kernel_linux.c; [Line] : 417; [Func] : mali_module_init(); svn_rev_string_from_arm of this mali_ko is '', rk_ko_ver is '5', built at '08:53:19', on 'Aug 28 2019'.
[   11.539269] mali-utgard ff300000.gpu: mali_platform_device->num_resources = 9
[   11.546753] mali-utgard ff300000.gpu: resource[0].start = 0x0x00000000ff300000
[   11.554020] mali-utgard ff300000.gpu: resource[1].start = 0x0x00000000ff300000
[   11.561092] mali-utgard ff300000.gpu: resource[2].start = 0x0x0000000000000014
[   11.568217] mali-utgard ff300000.gpu: resource[3].start = 0x0x0000000000000015
[   11.575145] mali-utgard ff300000.gpu: resource[4].start = 0x0x0000000000000016
[   11.582000] mali-utgard ff300000.gpu: resource[5].start = 0x0x0000000000000017
[   11.588577] mali-utgard ff300000.gpu: resource[6].start = 0x0x0000000000000018
[   11.595113] mali-utgard ff300000.gpu: resource[7].start = 0x0x0000000000000019
[   11.601474] mali-utgard ff300000.gpu: resource[8].start = 0x0x000000000000001a
[   11.607880] D : [File] : drivers/gpu/arm/mali400/mali/platform/rk/rk.c; [Line] : 623; [Func] : mali_platform_device_init(); to add platform_specific_data to platform_device_of_mali.
[   11.622762] mali-utgard ff300000.gpu: Looking up mali-supply from device tree
[   11.622932] mali-utgard ff300000.gpu: leakage=9
[   11.635382] mali-utgard ff300000.gpu: leakage-volt-sel=0
[   11.644804] mali-utgard ff300000.gpu: Looking up mali-supply from device tree
[   11.644926] mali-utgard ff300000.gpu: Failed to get pvtm
[   11.673792] Mali: Mali device driver loaded

So there's slightly more in Buster than Stretch.  Couldn't find armsoc in Stretch either.  I had ordered a couple 128 GB SD cards, one for this, one for my Pinebook Pro when it comes.  I'll just clone this 64 GB onto one but having extras around was handy.

es2gears (default size) runs 220-240 FPS
Turns out to be harder to clone and resize a GPT partition than an MBR one, so I had to start from scratch on my 128 GB SD.  The practice was beneficial, it came together very quickly and nicely.  My USB hub has a 1 TB hard drive plugged into it and I could mount the previous SD to copy from, mainly the wifi firmware.

I want to learn to write OpenGL ES but I'm leery of getting software emulation junk mixed in.  Es2gears is running at 200+ FPS but top shows it's using 120 - 150% CPU, that's not right.

Possibly Related Threads…
Thread Author Replies Views Last Post
  Are you guys still using Ayufan's OMV on your Rock64? AkiraSensei 0 681 11-26-2021, 07:01 PM
Last Post: AkiraSensei
  How to compile ayufan repo step by step? hisstone 0 1,282 03-12-2019, 03:09 AM
Last Post: hisstone
Wink SDR104 on ayufan 0.7.7+ XFer 0 1,136 10-25-2018, 06:30 AM
Last Post: XFer
  Reboot Issue with ROCK64 Linux version 4.4.77-rockchip-ayufan-141 techyjtmb 9 6,492 06-23-2018, 09:52 AM
Last Post: NablaMetal
  AOSP Build Steps Using github.com/ayufan-rock64/android-7.1 birender.s 15 14,336 05-09-2018, 01:20 AM
Last Post: burram
  Some questions about r64 and ayufan android tv Synthetikz 1 1,953 03-13-2018, 03:28 PM
Last Post: Luke

Forum Jump:

Users browsing this thread: 1 Guest(s)