RockPro64 getting started - non-booting images [solved]
#3
(11-21-2019, 01:09 AM)new-rockpro-user Wrote: Well, even with all that, it continues to be a little hit or miss.

Manjaro booted exactly once from eMMC. And reflashing the eMMC appears to make no difference.
It does seem to boot more reliably from SD though. So there's that.

Any extra ideas or pointers about booting non-ayufan images from eMMC would be welcome!

I've flashed U-Boot on my RockPro64 using your procedure but I don't see U-Boot starting from SPI memory when I power system on.

On eMMC I have installed Libreelec which boots fine (without jumper).
Microsd with Debian I can only boot when I plug-in jumper (=disable eMMC)

Knowing that SPI is flashed properly (as on output linked above), how could I boot from microsd without necessity inserting jumper.

According to https://github.com/ayufan-rock64/linux-b...ash-spi.md I should have possibility booting with order:

  1. SPI flash
  2. eMMC (disable with jumper)
  3. microSD
  4. USB drive
  5. PXE


Messages In This Thread
RE: RockPro64 getting started - non-booting images [solved] - by grukrz2 - 03-05-2020, 03:58 PM

Possibly Related Threads…
Thread Author Replies Views Last Post
  New OS for RockPro64 is here, TwisterOS Armbian jtremblant 83 16,962 Yesterday, 09:51 PM
Last Post: jtremblant
  slarm64 (unofficial slackware) ROCKPro64 RK3399 (aarch64) mara 44 24,092 06-20-2021, 06:09 AM
Last Post: mara
Brick Maintained Linux booting from eMMC ootoovak 1 104 06-20-2021, 03:53 AM
Last Post: LMM
  RockPro64 CRUX-ARM (aarch64) mara 0 128 06-05-2021, 11:29 AM
Last Post: mara
  Power supply underpowered for Rockpro64, deficient PCIe SATA card, or something else? daffy 8 467 05-20-2021, 10:04 PM
Last Post: t4_4t
  Booting from NVME ilovegentoo 11 3,693 05-10-2021, 02:06 PM
Last Post: rrowles2000
  Armbian images available Luke 52 31,764 04-26-2021, 03:16 AM
Last Post: Wizzard
Question Booting official Debian on RP64 arteeh 4 722 03-31-2021, 10:01 AM
Last Post: kuleszdl
  Booting Linux/Debian from the eMMC linuxha 4 709 03-02-2021, 07:01 PM
Last Post: linuxha
Question My Rockpro64 stopped booting with these error messages please help seaurchin 4 698 02-18-2021, 04:27 PM
Last Post: TRS-80

Forum Jump:


Users browsing this thread: 1 Guest(s)