Ethernet on Bionic-Mate?
#1
I have a possibly stupid question Blush 

I can't seem to get the Bionic-Mate build (run off SD) to connect to the internet with an Ethernet to USB adapter.  When I was testing internet speeds with Debian, I just plugged it in and it worked with either USB port.  Now I can't seem to get the same adapter to work Bionic-Mate.  I've tried a bunch of settings.  WiFi still works though.  What am I doing wrong?
#2
Is the kernel config missing the driver for your dongle? What driver is it using on Debian?
Come have a chat in the Pine IRC channel >>
#3
(11-16-2019, 05:54 PM)xalius Wrote: Is the kernel config missing the driver for your dongle? What driver is it using on Debian?

Sorry, no idea.  Although I tried two different adapters, a Moshi USB 3 and the Pine64 USB 2, and they both worked on the stock Debian build.
#4
I had the same issue but manually running sudo dhclient made it work.
#5
(11-17-2019, 04:47 AM)jpakkane Wrote: I had the same issue but manually running sudo dhclient made it work.

I tried that, but it didn't work.

"Cannot find device eth0"
#6
(11-22-2019, 02:40 PM)zaius Wrote:
(11-17-2019, 04:47 AM)jpakkane Wrote: I had the same issue but manually running sudo dhclient made it work.

I tried that, but it didn't work.

"Cannot find device eth0"

I got mine to work by making the following change to /lib/udev/rules.d/73-usb-net-by-mac.rules :

from:
    
     IMPORT{builtin}="net_id", NAME="$env{ID_NET_NAME_MAC}"

to:

    IMPORT{builtin}="net_id", NAME="eth0

After making the change I rebooted the pinebook pro and the usb ethernet connection now work properly.

I found the above solution in the following link:
https://superuser.com/questions/1000570/...er-upgrade

 
In my case I also need the "r8152" kernel module because I have a Realtek 8152 USB ethernet adapter so I added r8152 to /etc/modules.

Hope this helps.
#7
(03-06-2020, 10:32 AM)ndp Wrote: I got mine to work by making the following change to /lib/udev/rules.d/73-usb-net-by-mac.rules :

from:
    
     IMPORT{builtin}="net_id", NAME="$env{ID_NET_NAME_MAC}"

to:

    IMPORT{builtin}="net_id", NAME="eth0"

After making the change I rebooted the pinebook pro and the usb ethernet connection now work properly.

I found the above solution in the following link:
https://superuser.com/questions/1000570/...er-upgrade

 
In my case I also need the "r8152" kernel module because I have a Realtek 8152 USB ethernet adapter so I added r8152 to /etc/modules.

Hope this helps.

Thanks, I'll try that when I get chance.  There has been quite a bit of OS development since the last time I used my PBP.  I'm still leaning towards Ubuntu when things get settled, and there is an SPI boot, working SSD adapter, etc.  Ubuntu is what I used the day my MBP was getting its battery replaced, and it seems to have the most software packaged.
#8
@zaius, you can use "lsusb" to see what USB driver is needed. In my case;
Code:
# lsusb -s 004:004 -v
Bus 004 Device 004: ID 0b95:1790 ASIX Electronics Corp. AX88179 Gigabit Ethernet
...
# grep -i 179 /usr/src/linux/.config
CONFIG_USB_NET_AX88179_178A=m
...
# modprobe ax88179_178a
# ifconfig -a
...
enp56s0f4u1u1: flags=4098<BROADCAST,MULTICAST>  mtu 1500
       ether 00:0a:cd:26:45:3c  txqueuelen 1000  (Ethernet)
       RX packets 0  bytes 0 (0.0 B)
       RX errors 0  dropped 0  overruns 0  frame 0
       TX packets 0  bytes 0 (0.0 B)
       TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
...
Note I am not using that interface. I have a builtin Ethernet on the computer I am using now.

Edit: Forgot to mention that I simplified the USB & kernel module command sequence. Meaning I ran commands to find what I needed, like the kernel module name.
--
Arwen Evenstar
Princess of Rivendale


Possibly Related Threads…
Thread Author Replies Views Last Post
  After update in Ubuntu bionic mate system crashed Wawe 2 588 04-18-2021, 04:52 AM
Last Post: Wawe
  Ubuntu MATE 18.04 Can't boot after update hankg 2 861 12-15-2020, 01:53 AM
Last Post: BryanF
  Manjaro 20.09: USB ethernet dongle keeps hanging Dendrocalamus64 1 1,166 09-13-2020, 07:31 AM
Last Post: acceptabledecision
  ayufan Ubuntu Mate 0.9.14 black screen boot on new Pinebook Pro EricL 3 2,301 06-22-2020, 09:45 PM
Last Post: trinapicot
  Better (than default Debian/MATE) Linux distro? mspohr 34 15,832 06-11-2020, 01:34 PM
Last Post: s3rvant
  Focal on Bionic Using Chroot - Chromium / Snapd Issues charlespine 0 814 06-03-2020, 06:47 PM
Last Post: charlespine
  Ubuntu mate boot failure hdk 3 2,036 05-14-2020, 06:11 AM
Last Post: ndp
  How to change language in Bionic LXDE? mlentink 4 1,820 04-25-2020, 02:42 AM
Last Post: mlentink
  0.9.14 Release: Ubuntu 18.04 with Mate & LXDE Desktop Luke 86 45,081 04-09-2020, 09:33 AM
Last Post: mmt
  Compiling WireGuard (and other things requiring linux-headers) on Debian+Mate Dendrocalamus64 1 1,471 04-02-2020, 07:07 PM
Last Post: Dendrocalamus64

Forum Jump:


Users browsing this thread: 1 Guest(s)