Manjaro Arm on the pineH64
#31
I build a image form manjaro-arm testing and it results in a booting image.

What works:
- Wifi
- bluetooth
- hdmi-sound
- usb3

What doesn't work:
- Certain emmc cards doesn't seem to work

You can get emmc working on this image with the dtb on my sourceforge page, I also put a kernel there for people who already have manjaro-arm running with my previous dtb. Don't forget if you upgrade your kernel you should copy this dtb every time to /boot/dtbs/allwinner until this is fixed.
The reason I do it like this is because sd-cards don't seem to boot with the emmc fix and also because more emmc stuff is broken so you don't get more read/write speed with emmc in comparison with booting from sd-card.

More fixable errors:
- It's possible you notice there is no network. Normally restarting NetworkManager.service should fix this, in a terminal -> sudo systemctl restart NetworkManager.service
- It's also possible bluetooth doesn't work. Also restarting bluetooth.service should fix this, in a terminal -> sudo systemctl restart bluetooth.service
If bleutooth doesn't work after this, install the bluez-utils with pacman and thenfollow the guide on the archlinux wiki as described under troubleshooting -sudo systemctl restartsudo systemctl restartsudo systemctl restartsudo systemctl restartsudo systemctl restartsudo systemctl restartsudo systemctl restartsudo systemctl restart sudo systemctl restartbluetooth usb dongle -> https://wiki.archlinux.org/index.php/Blu...USB_Dongle
  Reply
#32
(01-10-2021, 01:09 PM)roel Wrote: I build a image form manjaro-arm testing and it results in a booting image.

What works:
- Wifi
- bluetooth
- hdmi-sound
- usb3

What doesn't work:
- Certain emmc cards doesn't seem to work

You can get emmc working on this image with the dtb on my sourceforge page, I also put a kernel there for people who already have manjaro-arm running with my previous dtb.  Don't forget if you upgrade your kernel you should copy this dtb every time to /boot/dtbs/allwinner until this is fixed.
The reason I do it like this is because sd-cards don't seem to boot with the emmc fix and also because more emmc stuff is broken so you don't get more read/write speed with emmc in comparison with booting from sd-card.

More fixable errors:
- It's possible you notice there is no network.  Normally restarting NetworkManager.service should fix this, in a terminal ->  sudo systemctl restart NetworkManager.service
- It's also possible bluetooth doesn't work. Also restarting bluetooth.service should fix this, in a terminal ->  sudo systemctl restart bluetooth.service
If bleutooth doesn't work after this, install the bluez-utils with pacman and thenfollow the guide on the archlinux wiki as described under troubleshooting -sudo systemctl restartsudo systemctl restartsudo systemctl restartsudo systemctl restartsudo systemctl restartsudo systemctl restartsudo systemctl restartsudo systemctl restart sudo systemctl restartbluetooth usb dongle -> https://wiki.archlinux.org/index.php/Blu...USB_Dongle

Haha, yes, Wifi and HDMI sound work for me!

Bluetooth still doesn't work ... I haven't been able to mess around with it too much, but when I try to load the module I get an interesting error saying: "libkmod: kmod_config_parse: /etc/modprobe.d/8723cs.conf line 2: ignoring bad line starting with ':46:c1:3a:21:b1'   ". I will keep messing with it though, this very well could be on my end.

Interestingly enough, my USB 3.0 port doesn't work at all. It doesn't show up when I run "lsusb", but the USB2.0 ports do. Not sure what is going on there. I don't think it has anything to do with power draw, not even a little wireless mouse USB dongle works.
  Reply
#33
@bapound

I will see if I can build a new image this week and will test the image. Did you build a manjaro arm image yourself, or did you use my image?
  Reply
#34
I built the image myself from Manjaro arm testing like you mentioned a few posts ago. Maybe I am having problems because I updated the kernel and didn't transfer the dtb? I assumed that was only necessary if booting from the eMMC, and I boot from the microSD.
  Reply
#35
No, it's probably because manjaro-arm went to a newer kernel and the patches have to be modified. I will see if I can modify the patches and resubmit them.
  Reply
#36
Looks like I've made a mistake buying a few of these to use for media center boards in Manjaro. USB3 is dead and no audio. inxi shows audio device and driver, but nothing in aplay or pactl. UI only has a "Dummy Audio" device.

Anyone have any luck recently getting these to work? Might have to give them away and get something with more support.
  Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)