PIneBook Pro - Boot from SD
#1
I have a new PineBook Pro, and simply want to boot from an SD image.   I've carefully followed the instructions to create a Bionic LXDE Community Build using Etcher on my Mac.  From what I have been able to understand, all I need to do is insert the formatted card into the PineBook and power on in order to boot to the SD, but it won't.  Instead, the PineBook always boots to the default OS that was delivered with the device.  

I am totally stuck.  I've looked through the forums and tried various images with the same result.

I've reviewed the common issues posted by 'Ghost' and none apply to my environment.  

Is there some kind of boot sequence key combination that I need to press to boot using the image on the SD card? 

Any guidance is appreciated.  Thank you!  

  Reply
#2
Have you fully updated the default OS, yet?
  Reply
#3
(11-10-2019, 06:23 PM)tophneal Wrote: Have you fully updated the default OS, yet?

Nope. I’ll look into it and try. Thank you!
  Reply
#4
To be more explicit -- there's an update button in the tray next to the clock on the default debian desktop. Click/run that, it calls a separate script that'll pull down updates not included in packages.
  Reply
#5
Thanks for the tips.  I updated via the command line because I don't have an 'update' icon in my tray.  (sudo apt update; sudo apt upgrade).  Still not booting from MicroSD.  The SD card is mounting with  "boot" and "linux-root" drives, so I know the card is seen and recognized.  It just doesn't seem to be selected as the boot source.  I am out of ideas on how to resolve this.

Again, thank you for your replies!
  Reply
#6
(11-12-2019, 09:07 AM)mcdomx Wrote: Thanks for the tips.  I updated via the command line because I don't have an 'update' icon in my tray.  (sudo apt update; sudo apt upgrade).  Still not booting from MicroSD.  The SD card is mounting with  "boot" and "linux-root" drives, so I know the card is seen and recognized.  It just doesn't seem to be selected as the boot source.  I am out of ideas on how to resolve this.

Again, thank you for your replies!

You might need to manually update your uboot. I'll see if I can dig up on of the links/posts already up.

Per Wizzard:


Quote:If we need also to boot other operating systems, we need to apply uboot fix. So download all the files from here https://github.com/mrfixit2001/updates_r...filesystem and run the mrfixit_update.sh script while running from eMMC.
  Reply
#7
Hello,

I had this boot issue last weekend as well. PBP was always booting from the eMMC.
This changed with running the fixit script from /usr/bin/. Please try this at first.

Next problem was that I didn't know, how to write a new image to eMMC. From the
Pinebook I know hat there were special sd card images which do this when booting from sd card.
Finally I booted from sd card and wrote the new image via dd to eMMC. This works fine for me.

Regards, Ansgar
  Reply
#8
Thank you all for your input! Using the MrFix it script worked! I am up-and-running! For anyone stumbling on this post with the same issue, the solution is to update the image you're received. I did this by cloning the git repo:

https://github.com/mrfixit2001/updates_repo/tree/v1.1

and running the "mrfixit_update.sh" script.

After that, everything worked as I expected and I was able to boot from the sdcard.
  Reply


Possibly Related Threads...
Thread Author Replies Views Last Post
  Pinebook Pro 'xtreme' bcnaz 31 1,399 Yesterday, 12:33 PM
Last Post: brent.thierens
  New Pinebook Pro for sale richfm 0 114 Yesterday, 09:27 AM
Last Post: richfm
  The Pinebook Pro Preorder System! fire219 366 28,757 Yesterday, 07:35 AM
Last Post: tophneal
Thumbs Up Pinebook Pro Fingerprint Magnet neilman 28 1,287 12-04-2019, 10:13 PM
Last Post: Jeremiah Cornelius
  Pinebook Pro ANSI keyboard - feedback please! Luke 39 4,743 12-04-2019, 06:01 PM
Last Post: ioo
  U-Boot with direct NVMe boot support for eMMC/SPI Flash pcm720 28 1,335 12-04-2019, 04:26 PM
Last Post: pcm720
  Pinebook Pro Initial Impressions kunger 237 34,685 12-04-2019, 11:10 AM
Last Post: Kochise
  U-Boot on SPI flash - discussion Arwen 16 518 12-03-2019, 06:25 AM
Last Post: Wizzard
Video Stardew Valley on PineBook Pro colemancda 3 336 12-02-2019, 07:11 PM
Last Post: Zaf9670
Question High Pitch Noise Coming From Pinebook Pro Feakster 15 893 12-02-2019, 01:16 PM
Last Post: tuxor

Forum Jump:


Users browsing this thread: 1 Guest(s)