Help me understand the boot up process
I'm obviously missing something fundamental here.

I built an image with buildroot which creates a u-boot-tpl-spl.img, a u-boot.itb file and a root partition

        image = "u-boot-tpl-spl.img"
        offset = 32768 # 512 * 0x40 from start of sd card

        image = "u-boot.itb"
        offset = 262144 # 512 * 0x200 from start of sd card

        bootable = "yes"
        image = "rootfs.ext2"

In the rootfs partition there's a file called /boot/extlinux.conf which has the following

label rock64-buildroot
  kernel /boot/Image
  devicetree /boot/rk3328-rock64.dtb
  append console=ttyS2,1500000n8 root=/dev/mmcblk0p1 ro rootwait

This boots up and all is good.  However, I'm wondering why I can't just replace /boot/Image and /boot/rk3328-rock64.dtb (and /lib/modules/*) with the one from slack (for example) and have that boot up.

When I tried, it didn't find /boot/Image and tried to boot off the network.

What am I missing here?

Possibly Related Threads…
Thread Author Replies Views Last Post
  Rock64 won't boot dstallmo 0 470 12-27-2023, 10:34 AM
Last Post: dstallmo
  arch rock64 does not boot nemnob 0 722 07-09-2023, 03:28 AM
Last Post: nemnob
  Disabling last mount time check on boot acwest 0 734 03-03-2023, 09:24 PM
Last Post: acwest
  Rock64 Rev3 doesn't boot and leds blinking fast dishins 6 8,216 06-30-2022, 06:28 PM
Last Post: rookie_267
  my rock64 can't boot rookie_267 0 1,148 06-27-2022, 06:52 PM
Last Post: rookie_267
  Setting a MAC on Rock64 U-Boot kiriakos 2 3,775 03-23-2021, 04:51 AM
Last Post: kiriakos
  Boot from USB 3.0 with hub Turbo 0 2,207 12-20-2020, 02:24 PM
Last Post: Turbo
  Unable to boot armbian fchazal 2 4,081 05-19-2020, 06:43 PM
Last Post: Rocklobster
  Rock64s will not boot any OS camosoul 2 3,637 05-19-2020, 06:38 PM
Last Post: Rocklobster
Brick Rock64 stuck in boot, please help! Malmgren 7 9,163 11-05-2019, 07:02 AM
Last Post: Malmgren

Forum Jump:

Users browsing this thread: 1 Guest(s)