reboot / crash
#31
(01-02-2020, 02:30 AM)Twix166 Wrote:
Quote:First thing, update the kernel via /usr/bin/mrfixit_update.sh and reboot. That has not helped me, though.

Thank you, I have done this now. 'wl_run_escan' doesn't appear to be happening any longer.
That's because mrfixit commented out the corresponding printk. The root-cause for the printks is still there. I doubt that's a issue. Strictly speaking, I don't know, though.
#32
(11-24-2019, 10:51 AM)Der Geist der Maschine Wrote: I used to get crashes every 24 hours. Now with MrFixIt's epic v 1.5 update, I get crashes every 1 to 2 hours basically rendering the laptop unusable. 121 postings. That was it. Bye.

I keep monitoring this thread https://forum.pine64.org/showthread.php?tid=8207 to see if someone gets the 5.4 kernel running on Debian and give that a try.

Did you ever solve crashes? 4 times for me today. No crashes the previous two days. Only change today was to install the touchpad and ANSI keyboard updates as per wiki instructions.
#33
for reference: zero crashes for me on debian sid arm64 with tsys kernel. ever.
#34
inplace upgrade? or clean install? maybe we can just upgrade kernel only. thanks for sharing eh.
#35
(01-23-2020, 03:12 PM)james64 Wrote:
(11-24-2019, 10:51 AM)Der Geist der Maschine Wrote: I used to get crashes every 24 hours. Now with MrFixIt's epic v 1.5 update, I get crashes every 1 to 2 hours basically rendering the laptop unusable. 121 postings. That was it. Bye.

I keep monitoring this thread https://forum.pine64.org/showthread.php?tid=8207 to see if someone gets the 5.4 kernel running on Debian and give that a try.

Did you ever solve crashes? 4 times for me today. No crashes the previous two days. Only change today was to install the touchpad and ANSI keyboard updates as per wiki instructions.

We can't be sure that your crashes have the same root-cause as my crashes.

Manjaro's 5.4 kernel does not crash on my system. I was initially running Manjaro from an SD card without any crashes. In the meantime, I installed Debian 10 + Manjaro's kernel on emmc. There are also no crashes.

Info about Manjaro is here https://forum.pine64.org/showthread.php?tid=8248

Nobody succeeded installing Manjaro's kernel on the default Debian. People here are installing a fresh Debian with debootstrap + Manjaro's kernel. If you are not familiar with this process, it's recommended to use Daniel's installer from this thread https://forum.pine64.org/showthread.php?tid=8487
#36
I don't think anyone attempted tsys kernel with Debian 9, and I don't see why you would do that.

if anything, 4.4 kernel and Debian 10+ makes more sense to attempt proper resume/suspend.
#37
Just adding myself to the stack of users experiencing this issue.

Got my PBP ANSI and booted it for the first time Saturday. Had it hard reboot itself while chatting on Discord with the default (included) Debian OS. So I downloaded the latest release of the Debian Desktop Community Build from @Mrfixit2001's GitHub repository (it is a bit newer than the one listed on the Pinebook Pro wiki) and booted from microSD, and just had it hard reboot itself again after running for about 2.5 hours. This time, all I was doing was running the WiDivine update, which sadly was almost finished after a 1.5 hour download - haha! I had nothing else open or running. Just that single terminal window.

Are there any pointers as to why this seems to be happening? I'd love to be running Debian, and just want to know if there is anything I can do to fix this.

Very happy / excited about the PBP otherwise. Beautiful device! Hopefully this is just a hiccup that can be solved since it could lead to data loss if I was working on something important.

[Update] a couple hours later, it just hard booted itself again. Same thing running: just the WiDivine update, and was almost complete.

Thanks, all.
Robbie Ferguson // Bald Nerd
NEMS Linux: https://nemslinux.com/ | My TV Show: https://category5.tv/ | My Blog: https://baldnerd.com
#38
sounds like a kernel issue to me.

anything useful in syslog regarding the lockups?
#39
Really hard to tell @xmixahlx - the syslog is heavily bloated (!!) though I could search through if I knew specifically what to look for. Unfortunately looking at the log also points to the fact that my system locale was set incorrectly and therefore the log timestamps are invalid. I have fixed my system time and should it happen again, it'll be much easier to find the correct spot in the log.

In the meantime, I tried something: as I mentioned, I had it hard reboot 3 times, the most recent 2 were when running the WiDivine update. So, this final time, I set the CPU frequency to 1.01 GHz static set, to prevent the CPU frequency from changing on the fly as is the default. Having set the CPU frequency, the WiDevine upgrade completed successfully, and the PBP remained stable after the update had completed, with no hard reboot.

I can't confirm in my initial tests that this was the cause & solution, but I know that 2x in a row, the upgrade caused the PBP to reboot, then, having set the CPU frequency manually to a static value, the same update completed without issue. So it could be related.

I will continue to monitor things. Fingers crossed that's all it is, as I'm happy to turn off CPU frequency scaling...
Robbie Ferguson // Bald Nerd
NEMS Linux: https://nemslinux.com/ | My TV Show: https://category5.tv/ | My Blog: https://baldnerd.com
#40
I reinstalled Debian 9 and for the past 3 days no issues with crash/reboot.

Both yesterday I used PBP for 5+ hours at a time on and off battery. No issues at all.


Possibly Related Threads…
Thread Author Replies Views Last Post
  Video Flashing/adjusting on boot and reboot jbradley419 0 476 01-16-2024, 09:17 AM
Last Post: jbradley419
  Vertical Grey Bars on PBP Reboot MickTheGeek 5 5,153 06-04-2021, 02:43 AM
Last Post: dsimic
  Gimp makes stock Manjaro KDE/X11 crash stozi 3 4,557 04-21-2021, 08:15 AM
Last Post: stozi
  Keyboard settings not saved on reboot motezart 6 7,730 11-26-2020, 12:11 PM
Last Post: creaverse
  Vertical Grey Bars on PBP Reboot MickTheGeek 2 3,527 10-05-2020, 07:29 AM
Last Post: MickTheGeek
  Connection to specific AP fails after first reboot. DroneOn 2 3,491 07-13-2020, 06:15 PM
Last Post: DroneOn
  vertical bars reboot only mamboman777 2 3,860 07-09-2020, 12:51 PM
Last Post: mamboman777
Bug How about a hard power switch? + crash report Dendrocalamus64 7 10,380 05-24-2020, 04:03 PM
Last Post: Der Geist der Maschine
  Pinebook pro random reboot default Debian tso4ev 3 4,950 02-04-2020, 06:30 PM
Last Post: Baldnerd
  Blank Screen after reboot Sats 12 13,157 01-27-2020, 02:23 PM
Last Post: Sats

Forum Jump:


Users browsing this thread: 1 Guest(s)