Pinebook Pro won't turn on
#51
Err, try "/dev/mmcblk1" -- no quotes
uname <space> -r
cd Downloads
ls<space> -l mmc*
you may wish to
rm mmc*
(this forum supresses 'extra' spaces, and condenses the single space that it shows)
--edit--
dev/mmcblk1 would work if you were in the / directory (but you are not),
otherwise have to be specific,, ie,,, of=/dev/mmcblk1
re wifi,, the mrfixit update may improve, update firmware for wifi,, not sure
  Reply
#52
OK, I've done that:

dd: failed to open '/dev/mmcblk1' : Permission denied.
  Reply
#53
You start the whole thing with "su" OR, if you prefer use sudo
dd, to write to /dev, needs root privledges
So,, ......| sudo dd of=...........
  Reply
#54
Ah! silly me.

Everything worked like a charm, except I'm back to the red light and black screen when I turn off the laptop, remove SD card and boot back up. Oh well...

As for no internet on mrfixit SD card, I tried two different SD card OS on two different PineBkPros. It's the laptop itself - must be a loose connection. I'll stick it back in when I have a small screwdriver to hand. It is strange that the OS does not turn off properly. Maybe its because I flashed the image to the SD card using Etcher instead of using dd.
  Reply
#55
Etcher is just a sophisticated version of dd
(graphical + a read check)
Does the "good" PBP turn off?
With the "bad" PBP, when you mount,, say boot (p1 on emmc) does it "look" the same?
md5sum of both tells for sure
as so
md5sum /boot/*
cd emmc/boot
md5sum *
(wherever emmc is mounted,, emmc/boot)
  Reply
#56
wdt asked:
"Does the "good" PBP turn off?

My answer:
Neither PBP turns off from Debian on SD card.

wdt asked:
With the "bad" PBP, when you mount,, say boot (p1 on emmc) does it "look" the same?"

My answer: When I mount/boot the emmc on bad computer, it looks the same as before.

Here are the md5sums:

rock@Debian-Desktop:~$ md5sum /boot/*
218a8f550fc4843c9451fea33fe4ec58 /boot/Image
md5sum: /boot/extlinux: Is a directory
5ef36aebecd3db71f4235c117d3445f1 /boot/rk3399-pinebookpro.dtb
rock@Debian-Desktop:~$ cd emmc/boot
bash: cd: emmc/boot: No such file or directory
rock@Debian-Desktop:~$

If I've understood correctly, neither md5sum matches the one given on the mrfixit download link, and the emmc can not be mounted. Right?
  Reply
#57
>cd emmc/boot
I don't know where the emmc will be mounted, replace "emmc" as appropriate
the last line from "mount" should be it, after you have mounted it, of course
Use whatever file manager you use to mount it (whichever partition of emmc)
The md5sum on the download link is for the whole gz, everything
These md5sums are for individual parts
>the emmc can not be mounted.
Not the whole block device, no, but the individual partitions should be able to be (mounted)
--edit-- this from PBP, booted manjaro, looking at emmc, mrfixit, updated (emmc at /run/media/d/BOOT, that partition labeled "BOOT")

[d@manjaroPBP ~]$ cd /run/media/d/BOOT
[d@manjaroPBP BOOT]$ ls
Image Image.bak extlinux rk3399-pinebookpro.dtb rk3399-pinebookpro.dtb.bak
[d@manjaroPBP BOOT]$ md5sum *
43a734728d180282b8aebf7a22195598 Image
68e39a37013fc5f9d971c25741b8f96c Image.bak
md5sum: extlinux: Is a directory
a7ee4e96893a3cf0614022a56f1cc083 rk3399-pinebookpro.dtb
50289ceddc88656f8cf9d4462ac3f1bd rk3399-pinebookpro.dtb.bak
[d@manjaroPBP BOOT]$ pwd
/run/media/d/BOOT
[d@manjaroPBP BOOT]$ mount |grep /run/media/d/BOOT
/dev/mmcblk2p1 on /run/media/d/BOOT type vfat (rw,nosuid,nodev,relatime,uid=1000,gid=1000,fmask=0022,dmask=0022,codepage=437,iocharset=ascii,shortname=mixed,showexec,utf8,flush,errors=remount-ro,uhelper=udisks2)
[d@manjaroPBP BOOT]$ lsblk
NAME MAJ:MIN RM SIZE RO TYPE MOUNTPOINT
mmcblk2 179:0 0 58.2G 0 disk
|-mmcblk2p1 179:1 0 96M 0 part /run/media/d/BOOT
`-mmcblk2p2 179:2 0 58.1G 0 part /mnt/emmc-root
mmcblk2boot0 179:32 0 4M 1 disk
mmcblk2boot1 179:64 0 4M 1 disk
mmcblk1 179:96 0 59.6G 0 disk
`-mmcblk1p1 179:97 0 59.6G 0 part /
I don't know why your md5 numbers don't match

NOTE there is no standard for block numbers, mrfixit differs from manjaro, look at lsblk, / will be SD card (when booted SD)
  Reply
#58
(01-26-2020, 12:57 AM)S265 Wrote:
(11-02-2019, 05:34 PM)bebop_man Wrote:
(11-02-2019, 12:53 PM)TAAPAye Wrote:
(11-01-2019, 11:12 PM)hsm89cheu Wrote: Received my PBP today and I have the same problem to boot up. I removed the back panel and pressed the reset button but still not working. Does anyone have a solution?

I flipped the eMMC switch (24 on https://wiki.pine64.org/index.php/Pinebook_Pro_Main_Page#Accessing_the_Internals_-_Disassembly_and_Reassembly)
and my computer now boots.

Which direction is the switch supposed to be ?

EDIT:  Success!  I flipped the emmc switch to up (towards the hinge) pressed reset, and then power, the system powered on finally!

This worked for me as well after encountering a problem where the system would not boot.
Many thanks!

Yes! This is the only fix that I found that allowed my machine to boot - my eMMC switch was disabled from the factory.

Since I had a bit of trouble locating where the eMMC switch was at first, I created a YouTube video showing how to fix this: https://www.youtube.com/watch?v=LWbncyt6xfg. Hope it helps!
  Reply


Possibly Related Threads...
Thread Author Replies Views Last Post
  The RTL-SDR and the Pinebook Pro diodelass 0 53 05-27-2020, 07:04 PM
Last Post: diodelass
  Pinebook Pro kit without the rockpro janat08 3 150 05-26-2020, 06:46 AM
Last Post: tophneal
Question No Power to Pinebook Pro jimsurvak 4 89 05-24-2020, 07:46 AM
Last Post: jimsurvak
Question Pinebook Pro Usb-C hub price TDC_PBP 0 152 05-22-2020, 03:55 PM
Last Post: TDC_PBP
  Pinebook Pro - No Audio bebop_man 13 1,627 05-20-2020, 03:16 PM
Last Post: polypode
  Changing Boot Order on the PineBook Pro bb1netusaf2004 1 104 05-17-2020, 02:17 PM
Last Post: Arwen
  Pinebook Pro Revised Keyboard Firmware jackhumbert 55 9,072 05-07-2020, 08:18 PM
Last Post: mil
  Pinebook Pro stuck in suspend charlief0x 4 166 05-05-2020, 08:36 PM
Last Post: wdt
  WiFi 6 for the Pinebook Pro tsys 12 899 04-28-2020, 12:19 AM
Last Post: pfeerick
Shocked New Pinebook Pro won't detect SD cards scottsweb 4 197 03-23-2020, 10:35 AM
Last Post: zaius

Forum Jump:


Users browsing this thread: 1 Guest(s)