Use Audiojack instead of HDMI audio
#51
(10-22-2016, 12:18 AM)victorfence Wrote: Hi, this maybe late, I also tried everything I found here. And heard nothing output through audiojack.

At last, when I try to unmute these channels :
DACL Mixer AIF1DAOL
DACL Mixer AIF1DAOR
(press 'M' to toggle mute in alsamixer)


I heard the sound!!

Thanks, Victorfence! I didn't know about the 'M' toggle either and have long wondered why the 3.5" audio jack on my board wouldn't put out any sound when the posted instructions worked so well for everyone else.
  Reply
#52
The instructions above (with /etc/modules-load.d) did not work for me on latest stable longsleep Ubuntu. Any pointers on how to get this debugged and working?
  Reply
#53
(10-22-2016, 12:18 AM)victorfence Wrote: Hi, this maybe late, I also tried everything I found here. And heard nothing output through audiojack.

At last, when I try to unmute these channels :
DACL Mixer AIF1DAOL
DACL Mixer AIF1DAOR
(press 'M' to toggle mute in alsamixer)


I heard the sound!!

Wish this helps.

BTW, Thanks for longsleep's great work!!

NO not too late at all!!! That was it! Thank you so much! Two months later and finally I can hear sound out my head phone jack!
I do it live!
  Reply
#54
Microphone does not work (audiojack).

Audio jack output works well, but input none at all.
(Has anybody else tested it?)
I use divider/switch jack cable to get input and output together:
https://i.stack.imgur.com/XDfgM.jpg

Things I've done already (as recommended ealier):
# scripts
pine64_update_kernel.sh
pine64_eth0-mackeeper.sh
pine64_fix_whatever.sh
install_mate_desktop.sh <-- this nope, using xubuntu-desktop
reboot now

# software
aptitude install alsa-base alsa-utils pulseaudio gstreamer1.0-alsa mplayer vlc

# config 1
cat <<EOF >/etc/modules-load.d/pine64-audiojack.conf
sunxi_codec
sunxi_i2s
sunxi_sndcodec
EOF

# config 2
wget https://raw.githubusercontent.com/longsl...ound.state
mv asound.state /var/lib/alsa/asound.state

# audio group
usermod -a -G audio ubuntu
usermod -a -G audio root
reboot now

There is silence when I record wav file or preview signal volume in PulseAudio Volume Control.
# ss
http://imgur.com/a/3536I

UPDATE
There is difference in 'List of capture hardware devices' (arecord -l command) when I plug microphone directly (input ONLY).
card 1: audiocodec ... SUNXI-Codec
--> Subdevices goes 0/1
It doesnt make any difference when recording anyway.

Need solution for this, please fix it,
many thanks!
  Reply
#55
My asound.state file has data concerning USB dj controller set so I am reluctant to overwrite it or will the data for the controller get added automatically again?

$ diff asound.state /var/lib/alsa/asound.state
...
1339a1340,1388
> }
> }
> }
> state.Instinct {
> control.1 {
> iface PCM
> name 'Playback Channel Map'
> value.0 3
> value.1 4
> value.2 9
> value.3 10
> comment {
> access read
> type INTEGER
> count 4
> range '0 - 36'
> }
> }
> control.2 {
> iface MIXER
> name 'PCM Playback Switch'
> value.0 true
> value.1 true
> value.2 true
> value.3 true
> comment {
> access 'read write'
> type BOOLEAN
> count 4
> }
> }
> control.3 {
> iface MIXER
> name 'PCM Playback Volume'
> value.0 11264
> value.1 11264
> value.2 11264
> value.3 11264
> comment {
> access 'read write'
> type INTEGER
> count 4
> range '0 - 16384'
> dbmin -6400
> dbmax 0
> dbvalue.0 -2000
> dbvalue.1 -2000
> dbvalue.2 -2000
> dbvalue.3 -2000
  Reply
#56
I installed ubuntu on my pine64, sound worked just fine after following these instructions, but out of a sudden it stopped working.
I reinstalled ubuntu, did the same instructions again - and yet another time it stopped working.
I retried unmuting channels with alsaa-mixer with no help.
PS1 could it be related to the fact I increased the volume above 100% (with pactl)?
PS2: here's my stack trace:


thanks in advance
--
Akiva
  Reply


Possibly Related Threads...
Thread Author Replies Views Last Post
  Pine64 (analog) Audio Jack Output w/ Kernel 4.19 ecolezen 0 241 01-24-2019, 07:00 AM
Last Post: ecolezen
  PINE64 STEREO AUDIO DAC POT jtgiroux 0 268 01-12-2019, 04:56 PM
Last Post: jtgiroux
  Sound quality from audio jack devanl 0 564 10-11-2017, 10:39 PM
Last Post: devanl
  Audio Extractor Ralck 1 428 05-25-2017, 12:25 PM
Last Post: dkryder
  Using the pine64 with AVR - HDMI pass-through Moshe.Vazan 4 894 01-02-2017, 02:58 PM
Last Post: Moshe.Vazan
  HDMI touch screen not detected Radio 2 836 09-29-2016, 06:42 AM
Last Post: Luke

Forum Jump:


Users browsing this thread: 1 Guest(s)