Pinebook Pro Initial Impressions
(11-15-2019, 07:44 PM)Dcjose48 Wrote:
(11-15-2019, 06:07 PM)Nappael Wrote: Hello all,

I noticed today that the bottom cover is not flush with the edge of the case on my Pinebook Pro. In particular, on the left edge near the IO. I had a brief look around and so far it seems pretty difficult to get both sides to go home at the same time. Anyone had something like this? I also noticed that one of the plastic standoffs were broken pretty much as soon as I opened the case.

I noticed the same thing on my pinebook pro as well. I haven't even bothered to open it up because I have read posts on here about how hard it is to take the back panel off and don't want to break any of the clips that snap into place. I guess I'll just make do with it. Besides that I have liked this laptop. I've been able to use firefox and chromium and haven't had any of the crashes people have discussed. I wonder if they would have charged at least $100 more, how much better the build quality could have been. I do wish the speakers could be better but doesn't really bother me.
**
 Yeah,  Mine was perfectly flush when I got it.

  But,  When I went to put it back on I could not get it that perfect again...  The first try it was pretty obvious it was no where near flush.

 I read in another post to "Bow" it slightly while installing it.   So I tried that, and with each try it improved.

 It appears to be just a 'hair' longer than the opening  ?

 I was tempted to try and give it a slight 'Bend' ( ya know more than a 'bow' ? )

 But,  instead I settled for it looking almost flush.

My spacers are undamaged,  and only needed to be re-aligned one time when I opened and closed the bottom cover.

 I do hope they start to offer some of those little parts on the website, it would be easy to lose or break those little spacers.

I would buy some ahead of time for those   "Just in case" senerios,  better to have 'on hand' than have to wait 6 to 8 weeks for parts.UPDATE

-----------------------------

NO SOUND : With some YouTube ads ? Using FireFox Strict settings
Appears there is no check box to turn on 'DRM' ? I am thinking that could be it ?
( Not that I mind it muting the ads) :-)
   LINUX = CHOICES
   **BCnAZ**
          Idea
  Reply
Have been playing with the PBP for a week.  It's so far so good for browsing the Internet and word processing.  The major issue for me is Firefox, but not a show stopper.  It quits when OS wakes up from Sleep, or switching network/VPN (I believe that someone reported on this thread before). 
Sound on Firefox is also unstable for me.  Sometime, it has no sound ... need to restart a couple of times. Still looking for a patteern.  Someone mentioned a fix by switching to alsamixer, but I couldn't find such post for the fix details.  If someone can post the URL here, it will be great.
My attempt to install Spotify failed.  Hope it will work at some points down the road.
Also, hope to have a solution for WireGuard beside the workaround in the Tutorial section of the PBP.
None of the above is major, but would like to see fixes soon.  Looking forward to the trackpad fixes.
All in all, it's great community project.  Congrats!
  Reply
I've been playing with my new PBP for a week now.

The physical look and feel is excellent. The flat black with matte screen is absolutely amazing looking. I did notice though, the bottom cover wasn't seated. The screws didn't seem to be fully tightened

The included software image does need some polish. Most preinstalled images do. I usually employ a "slash and burn" policy, removing a large number of installed packages. In this case I was a little reserved, I just removed haskell, mono, samba and a bunch of orphaned libraries. Good for just under a Gig of free space. (I even left systemd!!. Its not going to cause problems for me this time, I'm sure of it)

The console is not set up so in went the terminus font and console-setup. Set the keyboard to "gb" in /etc/default/keyboard. Set the font to "Terminus" at "10x20" in /etc/default/console-setup
I also had to set the locale with dpkg-reconfigure locales

In the GUI I noticed a bit of tearing and a bit of corruption when initially moving a window over another. Otherwise it is very usable.

Firefox crashed enough to make it unusable. I did notice this was an Ubuntu build, so I downloaded an update manually from ports.ubuntu.com ( version 70.0.1 for unbuntu 16.04.1, armhf). This version has been rock solid

I attempted the same with chrome, while it didn't crash opening settings anymore the video performance was very poor

Ejecting a usb drive caused an error message. Fixed it by installing 'eject'

There is a problem with suspend. I works fine the first time, after that it doesn't work. There is a "device usb5 failed to suspend: error -16" in the logs.

The headphone out has a problem. Sometimes it sounds as thou the channels are mixed up and out of phase, sort of like when the headphone jack is not fully seated. Playing around with alsamixer, turning the volumes up and down, fixes it. It seem like turning the volume up to the max trips it again.

The system hard crashes regularly when switching from the console to the GUI

I was going to investigate this this morning, but I found my PBP off even though I had left it on. Worse it wouldn't start

So I took the bottom cover off to have a look. I noticed a "reset" button, so I pushed it, screwed the cover back on and tried turning it on - no luck. When I went to remove the cover again I noticed one the hinge screws had pulled through. Reviewing the photos I had taken when I first removed the cover I see both hinge spacers were cracked. When I took the cover off a second time the one spacer had broken into many tiny pieces when the screw went through it.


I've got the epoxy out to attempt a fix, or maybe I'll make a steel spacer when I get into the shop later in the week

I manage to turn on the PBP just now so things don't look so bad

This not a laptop for someone who is afraid to roll up their sleeves and do some work on it
  Reply
(11-16-2019, 01:32 PM)bcnaz Wrote:
(11-15-2019, 07:44 PM)Dcjose48 Wrote:
(11-15-2019, 06:07 PM)Nappael Wrote: Hello all,

I noticed today that the bottom cover is not flush with the edge of the case on my Pinebook Pro. In particular, on the left edge near the IO. I had a brief look around and so far it seems pretty difficult to get both sides to go home at the same time. Anyone had something like this? I also noticed that one of the plastic standoffs were broken pretty much as soon as I opened the case.

I noticed the same thing on my pinebook pro as well. I haven't even bothered to open it up because I have read posts on here about how hard it is to take the back panel off and don't want to break any of the clips that snap into place. I guess I'll just make do with it. Besides that I have liked this laptop. I've been able to use firefox and chromium and haven't had any of the crashes people have discussed. I wonder if they would have charged at least $100 more, how much better the build quality could have been. I do wish the speakers could be better but doesn't really bother me.
**
 Yeah,  Mine was perfectly flush when I got it.

  But,  When I went to put it back on I could not get it that perfect again...  The first try it was pretty obvious it was no where near flush.

 I read in another post to "Bow" it slightly while installing it.   So I tried that, and with each try it improved.

 It appears to be just a 'hair' longer than the opening  ?

 I was tempted to try and give it a slight 'Bend' ( ya know more than a 'bow' ? )

 But,  instead I settled for it looking almost flush.

My spacers are undamaged,  and only needed to be re-aligned one time when I opened and closed the bottom cover.

 I do hope they start to offer some of those little parts on the website, it would be easy to lose or break those little spacers.

I would buy some ahead of time for those   "Just in case" senerios,  better to have 'on hand' than have to wait 6 to 8 weeks for parts.

I came back to it this morning, and was able to pretty easily get everything mostly flush by gently bowing the bottom cover. It's not quite there, but it's so much better than it was. Enough for me to be happy with it at least.

Thanks for the suggestion.
  Reply
I'm sorry I didn't read the whole thread.
Just my observations after a couple of days of use.

First of all, the PBP is a steal at this price.
Sure it has some small issues, but I really think this has the potential to be good enough as a daily driver.

Now for the small issues.
My USB-C hub works for power delivery and with the factory image the USB ports also worked on the hub.
After the MrFixit update and apt upgrade the USB ports on the USB-C hub no longer get recognised by the PBP.
After the MrFixit update, it cleared the Windows virus, or I still need to run a separate script for that?

I'm in a hotel now and the PBP can't connect to the Wifi network.
The PBP sees it as a secure Wifi network, while my Windows laptop connects and launches the browser with a page where I can agree to the terms of use of the Wifi network.
Or is there a trick to connect with the PBP?

Sometimes the trackpad seems a bit off. Not sure how to describe it.
It feels as if it has some lag, once in a while.

I still have a lot more testing to do, but so far I'm happy with it.
Can't wait for more updates.
  Reply


Possibly Related Threads...
Thread Author Replies Views Last Post
  Pinebook Pro ANSI keyboard - feedback please! Luke 34 3,884 Yesterday, 02:52 PM
Last Post: ono
Question High Pitch Noise Coming From Pinebook Pro Feakster 2 192 11-17-2019, 06:42 PM
Last Post: linusfargo
  ! ! Pinebook Pro Parts ! ! * IMPORTANT * bcnaz 4 474 11-16-2019, 08:07 PM
Last Post: zaius
Rainbow What did you name your Pinebook Pro? diodelass 14 443 11-16-2019, 04:42 PM
Last Post: Baslow
  Help - PineBook Pro won't boot! ThisGeekTweets 0 106 11-13-2019, 02:20 PM
Last Post: ThisGeekTweets
  Pinebook Pro Default Credentials are not working ricardo1934 4 116 11-13-2019, 11:14 AM
Last Post: ricardo1934
  PIneBook Pro - Boot from SD mcdomx 7 283 11-13-2019, 04:44 AM
Last Post: mcdomx
Thumbs Up Pinebook Pro Fingerprint Magnet neilman 18 717 11-12-2019, 11:15 AM
Last Post: tophneal
  Pinebook Pro Portable Documentation hmuller 0 143 11-11-2019, 05:30 PM
Last Post: hmuller
  Pinebook Pro/NVMe prep ? bcnaz 2 255 11-11-2019, 02:47 PM
Last Post: bcnaz

Forum Jump:


Users browsing this thread: 1 Guest(s)