DLNA and/or Plex problem with RockPro64
#1
Hi everybody!

I may think that I'm in the right place for my question:

I have a big problem that makes me wonder if I should've done the good hardware.
I've bought a Rockpro64 SBC with one WD Red HDD running on last Ayufan OMV version.
I have a synology DS213+ (well an old thing).
I've made copy of my movies from the DS213+ to the Rockpro64. Everything was almost fine but it's not the problem.
I have a Mi Box for watching movies with Kodi.

I tried to watch movies and some work some don't:
- Plex say that my connection it too slow or that an error came with transcoding.
- I tried the Plex DLNA from my TV too. It worked only once. The other times, it frose or I had no movies on my list.
- It doesn't work from Kodi and my TV (DLNA).
- The same movies work well from the DS213+ (DLNA).
- The same movies work well from my MacBook Pro.

So, is my SBC's not made for that or is there something I forgot to do ?
  Reply
#2
Hi,

I think your set up is broken in some way.

I'm using a rockpro64 with ayufan without omv, serving. SMB and NFS traffic to raspberry Pi based kodi just fine.

As of now I use mainly SMB due to my former Synology NAS.

Any more details to your setup?

Martin
  Reply
#3
Hi,

My setup:
Rockpro64 4G with PCIe to SATA bought on the Pine64 store (I've bought everything there)
kernel: 4.18.0-rc8-1060-ayufan-g45828c4db727 #1 SMP PREEMPT Thu Aug 9 19:41:21 UTC 2018 aarch64 GNU/Linux

I'm watching movies from my TV (philips) in DLNA or from my Mi Box 2 with Kodi or Plex.
With Plex, it looks like a cache problem sometimes (your network bandwith seems to be slow) but when I change the language, I have an other error (error with transcoding. I may think that I need to have a SSD drive for transcoding.
With Kodi, it never worked at all (HD, SD: same result : nothing).
In DLNA:
With the Mini DLNA from my TV, some movies work and other don't. The Plex DLNA worked only once and everything that didn't work the other ways worked. Even 4K movies. There were lagging but I worked. Unfortunately, this solution never after this time.
  Reply
#4
Is your kodi running on the rockpro64 or on some other box and sharing the content from the rockpro64?

M

Gesendet von meinem H8216 mit Tapatalk
  Reply
#5
Kodi is run from my Mi Box. It uses the smb RockPro64 shares.
I see the movie list but when I select one, it stays on "loading" then it goes back on the list.
  Reply
#6
Wink 
(09-30-2019, 03:25 PM)aldrick Wrote: Hi everybody!

I may think that I'm in the right place for my question:

I have a big problem that makes me wonder if I should've done the good hardware.
I've bought a Rockpro64 SBC with one WD Red HDD running on last Ayufan OMV version.
I have a synology DS213+ (well an old thing).
I've made copy of my movies from the DS213+ to the Rockpro64. Everything was almost fine but it's not the problem.
I have a Mi Box for watching movies with Kodi.

I tried to watch movies and some work some don't:
- Plex say that my connection it too slow or that an error came with transcoding.
- I tried the Plex DLNA from my TV too. It worked only once. The other times, it frose or I had no movies on my list.
- It doesn't work from Kodi and my TV (DLNA).
- The same movies work well from the DS213+ (DLNA).
- The same movies work well from my MacBook Pro.

So, is my SBC's not made for that or is there something I forgot to do ?

Which bit version of Ayufan's OMV are you using? the 64 version was problematic for me running movies to my kodi center but 32 bit version worked fine.

I just read your other post. Dump the Ayufan's aarch64 version and go with the Ayufan's OMV armhf 32 bit version. It is more stable. I am not a 32 bit person myself but it works  Wink
  Reply
#7
I doubt that it is because of 32 or 64 bit version. My rockpro64 runs on 64bit and my Kodi is on OSMC which is on 32bit.

I can not tell on the box you are using but I would double check the samba setup.

Also you may check with a Intel based Linux client.

M

Gesendet von meinem H8216 mit Tapatalk
  Reply
#8
Hello,
Thank you all for your answers.

My DLNA problem is near to be solved: Plex DLNA works better that the Openmediavault mini dlna plugin.

I think that @mabs is right: I have samba problem:
The movies work on my MacBook Pro (VLC). They don't on my smartphone (OnePlus 6) and Mi Box, via Kodi both.
The 3 devices use the Wi-Fi.
Then I tried with VLC on my phone and the Mi Box: the movies (720p) played but they were lagging (I think it may be a network problem but I'm on a local network...).
  Reply
#9
Hi,

I think I have something but I done know how to test that.
I've installed Emby to see if it's not a Plex problem: I have the same issue with both.
So I'm pretty sure that it comes from my SBC or my network.

Do you know how I can test it?
  Reply
#10
(10-20-2019, 07:25 AM)aldrick Wrote: Hi,

I think I have something but I done know how to test that.
I've installed Emby to see if it's not a Plex problem: I have the same issue with both.
So I'm pretty sure that it comes from my SBC or my network.

Do you know how I can test it?

Well, I tested Emby from my smartphone, my laptop, the video plays few seconds then stops.
I tried to watch the network traffic from the Openmediavault System Information. I see the traffic stoping for no reason.
I may think that it comes from this.

Is there someone using OMV with Plex or Emby that could help me, please ?
  Reply


Possibly Related Threads...
Thread Author Replies Views Last Post
Big Grin RETRO GAMING: UPDATED RECALBOX FOR THE RK3399 ROCKPRO64 Mrfixit2001 38 5,932 03-29-2020, 05:37 AM
Last Post: Crnppscls
  slarm64 (unofficial slackware) ROCKPro64 RK3399 (aarch64) mara 30 5,596 03-21-2020, 10:34 AM
Last Post: mara
  Arch Linux on RockPro64 mmatyas 28 10,424 03-20-2020, 12:27 AM
Last Post: hev
Thumbs Up Batocera for RockPro64 Luke 6 2,483 03-16-2020, 09:04 AM
Last Post: Crnppscls
Question Mainline Debian Buster on RockPro64 ? chrestomanci 2 220 03-08-2020, 01:35 PM
Last Post: chrestomanci
  RockPro64 getting started - non-booting images [solved] new-rockpro-user 3 300 03-06-2020, 06:31 AM
Last Post: new-rockpro-user
  Rockpro64 not stable... crashes now and then. Pineapple 15 1,108 02-14-2020, 02:24 PM
Last Post: hemertje
  Rockpro64 and stock arch linux TaborFife 6 904 01-15-2020, 05:17 PM
Last Post: dragop
  Problem with compiling ayufans linux kernel voegelit 4 315 01-14-2020, 07:38 AM
Last Post: patstew
  Reboot problem on latest ayufan and 4.4 /dev/null 2 404 11-27-2019, 04:23 AM
Last Post: dukla2000

Forum Jump:


Users browsing this thread: 1 Guest(s)