Rock64 Rev3 doesn't boot and leds blinking fast
#1
Hello,

I just purchased a 4gb Rock64 Rev3 model and i'm struggling in getting any image to boot properly, i tried latest Armbian, mrfixit and ayufan's image. Whenever i plug my power supply (5v 4A) the white, red and ethernet led starts blinking very fast while the green blink slowly. If i plug in and out my power supply it will eventualy boot, but never from the first time. Maybe my board is defective? Anyone else has this issue?
  Reply
#2
(08-11-2019, 07:57 PM)dishins Wrote: Hello,

I just purchased a 4gb Rock64 Rev3 model and i'm struggling in getting any image to boot properly, i tried latest Armbian, mrfixit and ayufan's image. Whenever i plug my power supply (5v 4A) the white, red and ethernet led starts blinking very fast while the green blink slowly. If i plug in and out my power supply it will eventualy boot, but never from the first time. Maybe my board is defective? Anyone else has this issue?


Sounds like a power issue, the green LED should be on solid when plugged in regardless if the board is booted or shutdown as it's hardwired to the power socket..
  Reply
#3
(08-11-2019, 11:03 PM)evilbunny Wrote:
(08-11-2019, 07:57 PM)dishins Wrote: Hello,

I just purchased a 4gb Rock64 Rev3 model and i'm struggling in getting any image to boot properly, i tried latest Armbian, mrfixit and ayufan's image. Whenever i plug my power supply (5v 4A) the white, red and ethernet led starts blinking very fast while the green blink slowly. If i plug in and out my power supply it will eventualy boot, but never from the first time. Maybe my board is defective? Anyone else has this issue?


Sounds like a power issue, the green LED should be on solid when plugged in regardless if the board is booted or shutdown as it's hardwired to the power socket..

I'm not sure, my Rock64 1gb Rev1 board boots fine with the same power supply, also, if i plug and replug several times it will eventually boot. Is the Rev3 more power hungry. Actually the green led behaves more like a DIM than blink i should say.
  Reply


Possibly Related Threads...
Thread Author Replies Views Last Post
Question /dev/spidev0,0 on the Rock64 - Does anyone know how to enable it? Kappuchino 14 2,735 12-05-2019, 09:42 PM
Last Post: phuzy
  Remote desktop access Rock64 over Internet hg6806 1 41 12-05-2019, 08:01 AM
Last Post: martinayotte
  CentOS 7 for Rock64 pineadmin 1 476 11-25-2019, 05:11 AM
Last Post: bazooka07
  Did my Rock64 die? ab1jx 7 169 11-19-2019, 12:58 PM
Last Post: ab1jx
  Headless installation of Real VNC server on Rock64 possible? hg6806 3 58 11-18-2019, 04:32 AM
Last Post: evilbunny
Bug mpph264enc output doesn't work on bionic rompelstompel 11 2,105 11-15-2019, 10:00 AM
Last Post: gounthar
  Rock64 lost connection after high I/O traffic Rock68 3 101 11-13-2019, 05:14 AM
Last Post: Rocklobster
  Help me understand the boot up process olivercfc 0 56 11-10-2019, 08:30 AM
Last Post: olivercfc
Brick Rock64 stuck in boot, please help! Malmgren 7 218 11-05-2019, 07:02 AM
Last Post: Malmgren
  slarm64 (unofficial slackware) Rock64 RK3328 (aarch64) mara 61 13,847 11-03-2019, 09:08 AM
Last Post: mara

Forum Jump:


Users browsing this thread: 1 Guest(s)