PineA64+: Audio in 5.0 Kernel
#1
I am running Debian Buster on my A64+ (not LTS) with a 5.0.2 kernel which should, in theory, support audio on this board. However, no mixers are present. Has anyone else experimented with recent kernels with Pine64 mainlined? What am I missing?

Additional information:
Kernel was built from source by tweaking the 5.0-trunk config as such:
Code:
+CONFIG_SND_SUN4I_CODEC=m
+CONFIG_SND_SUN8I_CODEC=m
+CONFIG_SND_SUN8I_CODEC_ANALOG=m
+CONFIG_SND_SUN50I_CODEC_ANALOG=m
+CONFIG_SND_SUN4I_I2S=m
+CONFIG_SND_SUN4I_SPDIF=m
+CONFIG_SND_SUN8I_ADDA_PR_REGMAP=m
+CONFIG_SUN50I_ERRATUM_UNKNOWN1=y

DTB file should enable the audio interface
sun*i* modules are loaded
  Reply
#2
I build manjaro for the pine64+ with kernel 5.2, audio through hdmi doesn't work. Analogue works fine.
With libreelec it's the same, no audio through hdmi for the pine64+ (same on lakka, but in fact it's the same build as libreelec).
I tried the 4.20 kernel on manjaro and there is the sound OK.
According Jernej on the LE forums it's a known problem and they are working on a solution.
  Reply
#3
(08-27-2019, 08:04 AM)roel Wrote: I build manjaro for the pine64+ with kernel 5.2, audio through hdmi doesn't work.  Analogue works fine.
With libreelec it's the same, no audio through hdmi for the pine64+ (same on lakka, but in fact it's the same build as libreelec).
I tried the 4.20 kernel on manjaro and there is the sound OK.
According Jernej on the LE forums it's a known problem and they are working on a solution.

Can you share your kernel config for 5.2?
  Reply
#4
@puzzles,

I'm experimenting with some patches. If I have succes, I will report back. I'm a little busy at the moment so it can take some time.
  Reply
#5
I got hdmi working, altough the sound is crackled.  I have to find out why.

The problem is in the sun50i-a64-pine64.dts the lines to enable i2s2 and sound_hdmi or missing.  If you add those lines, you get the allwinner_hdmi sound card.  But as mentioned before the sound is not OK, it goes constantly on and off.  If somebody has a suggestion what could be the problem...  Maybe this is the reason they dissabeld hdmi sound in the dtb.
  Reply
#6
HDMI sound works in the 5.3.7 kernel with a modified sun50i-a64.dtsi.

You have to patch the kernel with the patch found in the LibreElec github: https://github.com/LibreELEC/LibreELEC.t...udio.patch
  Reply
#7
(10-23-2019, 03:34 AM)roel Wrote: I got hdmi working, altough the sound is crackled.  I have to find out why.

The problem is in the sun50i-a64-pine64.dts the lines to enable i2s2 and sound_hdmi or missing.  If you add those lines, you get the allwinner_hdmi sound card.  But as mentioned before the sound is not OK, it goes constantly on and off.  If somebody has a suggestion what could be the problem...  Maybe this is the reason they dissabeld hdmi sound in the dtb.

I found the problem of the crackled hdmi-sound.  Seems to be the RTL8723BS driver when you enable it to get the wifi add-on board working.  When you want hdmi-sound and wifi working together, you may not build the other RTL8723 stuff in the kernel or as module.  When you compile the kernel with only the RTL8723BS as wifi driver, hdmi_sound and wifi are working nicely together.
  Reply


Possibly Related Threads...
Thread Author Replies Views Last Post
  I2S Audio patches for Pine64+ uploaded to GitHub ramstadt 1 267 01-19-2019, 11:31 AM
Last Post: ramstadt
  Rockpro64 NFS root mount (kernel 4.20) - ethernet help? tenspd137 0 284 12-06-2018, 01:14 AM
Last Post: tenspd137
  NVMe and new kernel bjbb17 0 268 09-25-2018, 03:39 PM
Last Post: bjbb17
  Real-time linux kernel Artyom 45 12,404 09-11-2018, 01:08 AM
Last Post: zzwpine
  DKMS on kernel 3.10.107-pine64 obrienmd 5 733 06-21-2018, 05:45 PM
Last Post: evilbunny
  Kernel for A64 git longsleep 179 59,175 03-25-2018, 03:25 PM
Last Post: Luke
  Gentoo for pine64 - longsleep kernel incoherent 0 855 12-09-2017, 08:14 AM
Last Post: incoherent
  [SOLVED] UEFI + Fedora Mainline Kernel Booting! cztian 0 798 07-13-2017, 08:38 PM
Last Post: cztian
  Mainline kernel [Solved] jeroen79 11 2,989 02-08-2017, 06:19 AM
Last Post: umiddelb
Question Need help : Issue in running compiled kernel with tftp+uboot dinesh.bhoyar 2 827 01-30-2017, 12:44 AM
Last Post: dinesh.bhoyar

Forum Jump:


Users browsing this thread: 1 Guest(s)