RockPro64 alpha software support
#1
Although the RockPro64 has great specs in theory, it is often not usable for real applications because of the current state of software support.

First problem: USB3. No matter which kernel I've tried to use on my RockPro64 (Ayufan's 4.20, 5.0 as well as Armbian's 4.4.174 which is supposed to be directly based on Pine64's patches), there is no way to do any serious usage of USB3 storage. With all the dev. kernels, I end up with massive filesystem corruption after transferring a few Gb of data in/out of USB3. With kernel 4.4, transferring a few Gb of data leads to kernel crash. I can do some benchmarks (with hdparm for example), but not serious usage. My usb storage is a Samsung SSD connected through a JMicron JMS567 bridge (with Hardkernel's latest firmware), so this is very similar to the USB3/sata adapter sold by Pine64. Of course, the whole thing works very well on my laptop (running Debian Buster) where it can transfer 100's of Gb without a sweat. I've tried other USB cables, I've tried a laptop power supply (that can provide up to 6A), nothing can make the RockPro64's USB3 stable.

For mainline kernels (even with a thick layer of additional patches), several other major issues remain: there is no HDMI output (so if you're out of luck, your system is not connecting to the network and you don't have an easy way to check what it is doing on a connected screen). There is no proper handling of the big.little clusters (so the processes get distributed more or less randomly, leading to unsatisfying performance, see this previous post). There is no support for the DDR4 memory, it is handled as ddr3. The eMMC is handled as HS-200 instead of HS-400 (so less speed, see FreeBSD post and it is far from stellar anyway). The SPI memory seems to be half-buggy, half-slow (see lkml). The U-boot is still relying on an older version (from 2017) because of difficulties in making it work with the current mainline (see this post). There are some reports of problems with using the PCIe (see this thread ). Half of the time, the board does not reboot but gets stuck when shutting down.

I am wondering if somebody at Pine64 works with the community to help fix these problems... (this is not supposed to be mean, but a genuine question: is the community left by to fight by itself or is there some support from Pine64).

Mathias
#2
More on the topic of USB3: other boards with RK3399 experience the same issue (see https://forum.armbian.com/topic/8828-rsy...ment=66895)
#3
Luke, tllim, Can someone talk to Rockchip?
#4
What did you format the filesystem as? Can you run a sequential fio write/read mix test and see if that gets it to error? What is the output of dmesg when you start seeing errors? What are the errors you described?

Cheers

Edit: Found discussion @ https://github.com/ayufan-rock64/linux-build/issues/112 that answers most of above
#5
(05-24-2019, 03:57 PM)mknawabi Wrote: What did you format the filesystem as? Can you run a sequential fio write/read mix test and see if that gets it to error? What is the output of dmesg when you start seeing errors? What are the errors you described?

Cheers

Edit: Found discussion @ https://github.com/ayufan-rock64/linux-build/issues/112 that answers most of above

I've had fs either as ext4 or f2fs. I get the errors both when reading or when writing. But if i just run a simple benchmark (hdparm test), everything works. The bug is triggered when reading or writing large amount of data (a few Gb, I managed to trigger it today with ~900Mb). Depending on the kernel version, it ends up in system lockup or filesystem corruption or just that the usb drive is not reachable anymore (and can not be unmounted, so even a reboot is not going to be that much fun).

The discussion on Ayufan's github does not give any proper solution (in my mind, as I was part of this discussion, see https://github.com/ayufan-rock64/linux-b...-480827662 that contains my dmesg output when the usb crashes): the only setup that works involves two usb hubs chained to isolate the drive, this is really a very hacky workaround and not any kind of real solution (it significantly degrades the performances and a board that needs this kind of setup can not advertise being USB3!). [Edit] please keep in mind that several people tried powered usb hubs, I tried a 6A power supply for the board, I blacklisted uas (and checked that it was blacklisted), nothing helped.

As I keep on seeing more and more RK3399 boards where the USB3 is not stable under load, it seems to me that the rk3399 has a bug and is actually not able to handle usb3 properly.

PS: regarding the other issues that are answered in your link, I could not find anything... this thread was only about usb3 (and did not bring up a solution), there is still no improvement to the big.little handling in dev kernels (since it works properly with the stable kernel, there will eventually be a solution), not for the other problems. But so far, the other problems are annoying but will be fixed at some point (it might take years though) while if the rk3399 has a buggy usb3 implementation, this won't be fixable.
#6
Another version of the dmesg: https://pastebin.com/8LhHZ749
#7
Finally!! This definitely has to do with USB suspend (see https://forum.pine64.org/showthread.php?tid=5557&page=2): on a freshly booted system, no problems at all. On a system that has been running for a day (ie the USB had enough time to suspend), the problem is back with tons of error messages... So this explains why pine64 had trouble reproducing this issue!

[edit] The autosuspend is not the culprit... This has to do with some underpower, see this (long) thread. Sorry for the fake news and the disappointment!


Possibly Related Threads…
Thread Author Replies Views Last Post
  New OS for RockPro64 is here, TwisterOS Armbian jtremblant 84 20,956 07-03-2021, 07:09 AM
Last Post: jtremblant
  slarm64 (unofficial slackware) ROCKPro64 RK3399 (aarch64) mara 44 26,089 06-20-2021, 06:09 AM
Last Post: mara
  RockPro64 CRUX-ARM (aarch64) mara 0 253 06-05-2021, 11:29 AM
Last Post: mara
  Power supply underpowered for Rockpro64, deficient PCIe SATA card, or something else? daffy 8 803 05-20-2021, 10:04 PM
Last Post: t4_4t
Question My Rockpro64 stopped booting with these error messages please help seaurchin 4 854 02-18-2021, 04:27 PM
Last Post: TRS-80
  Rockpro64 not stable... crashes now and then. Pineapple 18 7,567 02-16-2021, 02:45 PM
Last Post: TRS-80
Question Mainline Debian Buster on RockPro64 ? chrestomanci 36 15,479 02-14-2021, 02:37 PM
Last Post: foresto
  Alpine on RockPro64 mutemule 0 523 02-05-2021, 10:10 AM
Last Post: mutemule
  OpenSuse for ROCKPro64: testimage hemertje 1 611 02-01-2021, 04:25 AM
Last Post: cryolithic
  Chromium OS for the RockPro64 is now available! Luke 9 6,321 01-09-2021, 12:13 PM
Last Post: Ruben

Forum Jump:


Users browsing this thread: 1 Guest(s)