Video and Guide to install Android to emmc no emmc to usb adapter
First get your hardware:

1)      Usb to type c cable, if you don’t have a usb to type c you can use an adapter
*usb 3 to usb 3 cable should work but I tried with mine and did not work
Cables are not created equal if procedure does not work after following instructions try with another one, I’ve got plenty of cables and procedure only worked with 2, if you can adb to your phone it should also work for this.

2)      A jumper to short out pins, if you do not have one you can use 2 sided female gpio cable to jump pins anything that can short the pins should work just be careful.


1)      Download Android Flash Tool:
2)      Download Drivers:
3)      Download Image for android I recommend this one it’s the one that has worked best for me:
--Unzip to get image you will burn, download comes zipped you need to unzip, remember where you put the image file and the name so you don’t get confused selecting unzipped download… better yet once unzipped just delete the zip file.
While you are at it might as well download Domos platform tools from here:
You can use minimal adb or any already installed adb, but Domo download has a set of packages we will need later to install google store, so might as well use this one.

Would recommend you keep all your downloads in a single separate folder for easier location of files.

Ok let’s Start!

1)      Install drivers from driver download, it’s an exe file that’s called DriverInstall
2)      Go to your downloads and run the exe file called AndroidTool from the file you downloaded
3)      Unplug your rp64 from power source and leave it like that, take out your microsd if you have one, make sure your emmc is plugged in correctly
4)      Short the pins with jumper (pins that need to be shorted are right next to the emmc)
5)      Open your Android Tool (yes this is step 2 repeated) make sure its open
6)      Connect your usb cable to computer and type C to rp64 (flashing only works on type c to my experience if you have found differently please comment bellow)
On Android Tool you should get Found One MASKROM Device
7)      Connect power again, wait for device description on android tool to recognize device
8)      Disconnect jumper, wait for device description on android tool to flicker
9)      Go to Android tool and Go to Upgrade Firmware on the top menu (flash will only work on MASKROM)
10)  Select firmware and select your unzipped image, be sure to have it unzipped and selected the right image burning the wrong image or burning an unzipped image can really be a headache to troubleshoot cause you might not know what went wrong.
If Flash doesn’t start then:
Unplug power, make sure there is no microsd card, put jumper back, make sure emmc is connected, take type c out wait for light to disappear and connect type c again, put power back in wait to see message in android tool flicker,  take of pin once device has been recognized and wait for android tool device flicker, take off jumper pin and try again. If after a few tries still not working try changing your cable.
If your issue is device not found this is most likely a driver issue, go to device manager find what rp64 appears as in device tree and try to add driver manually from the drivers folder you download,  if this doesn’t work just delete the driver, after that device should pop out again, driver issues can be very frustrating it might be reading as and adb device from a previous install or a manufacturer brand you made or as a phone (like sony, huawei piking it up) even then just delete driver from the device on device manager or add correct one, if this doesn’t work there are many videos on the internet explaining how to fix these kinds of issues they can be very particular so maybe post bellow and some can help you.
11)   If flash did not finish or gave an error flash again, its happened to me before eventually it will flash correctly. With any luck you got it right on the first time. Sometimes it even finished and didn’t work in my case, had to reflash.
12)   Finally connect as you normally would, without jumper…
13)   Wait a good 5 minutes and voila, Android at your service.
Once you get the hang of it process to flash should take around 5 to 10 min first time is the hardest because of trouble shooting and forgetfulness but after that it’s a breeze.

For Visual aid you can see video at the link bellow:

If something remains unclear leave a comment to see if I can help you and further explain.

Possibly Related Threads…
Thread Author Replies Views Last Post
Video How to Install Google PlayStore NightCrawler504 2 5,159 04-08-2020, 02:20 PM
Last Post: pino88
  load root on NVMe and /boot on eMMC Vikk42 4 8,394 07-18-2019, 12:42 PM
Last Post: stuartiannaylor
Thumbs Up Tutorial[ Seagate Disks ]: Install Seagate OpenSeaChest Utilities tuxd3v 41 73,277 04-08-2019, 10:10 AM
Last Post: Neo2018
  HOW TO - install linux on emmc without etcher or USB adapter dukla2000 4 10,279 07-31-2018, 12:40 PM
Last Post: dukla2000

Forum Jump:

Users browsing this thread: 1 Guest(s)