RK3328 Media Script
#1
The forum Armbian JMCC published script includes the video acceleration on rk3328.

https://forum.armbian.com/topic/9310-rk3...-renegade/

If anyone tested write a review.
  Reply
#2
I tested it on my 4 GB r64. The script successfully got the X driver installed so that OGLES works accelerated by the Mali driver under Armbian bionic but I was unable to get any of the video players to work properly although thats partly because the developer has failed to mention how to run any of them in the README / 1st post of the forum thread for the script. Thankfully I think I know how mpv and gstreamer should be run but I could be incorrect.

mpv segfaults like this, whether run as root or a normal user:

[email protected]:~/Videos$ mpv --vo=gpu --gpu-context=drm --hwdec=rkmpp VID_20190125_163620.mp4
Playing: VID_20190125_163620.mp4
(+) Video --vid=1 (*) (h264 3840x2160 29.304fps)
(+) Audio --aid=1 --alang=eng (*) (aac 2ch 48000Hz)
[vo/gpu] VT_GETMODE failed: Inappropriate ioctl for device
[vo/gpu/opengl] Failed to set up VT switcher. Terminal switching will be unavailable.
Segmentation fault

gstreamer, when ran like so:

$ gst-play-1.0 --videosink=rkximagesink video.mp4

Came the closest to working of the three but the video was unwatchable as it was very jerky with lots of horizontal green bars.

kodi, as installed with this script, has 3 binaries. The one that comes the nearest to working (kodi-gbm-wrapper or something) only shows the UI for a few seconds before you get kicked out to the VT. I was unable to play a video with kodi so its a big fat 0/3 for all three video players currently. I had more luck with mpv under armbian when I built it myself - I was able to get hw accel video working but only at FullHD output res.

Its not mentioned in the README yet and the script seems to almost run fine as a normal user (it doesn't stop you) but the first time I ran the script I ran it as a normal user and my screen went black (X crashed?) part way through installing the gstreamer stuff. I ran it again with the same options but as root and it completed fine.

I signed up to the armbian forums to give my feedback but I am currently unable to post replies to any threads on the armbian forum nor can I send the dev a DM yet either.
  Reply
#3
There is a readme within the tarball that explains how to run mpv and gstreamer - you have to run mpv-gbm to use the hardware accelerated mpv but its the same as ever in that mpv is limited to 1080/FullHD output and you get very jerky playback with horizontal green bars when trying to play @ 4K.

I have only tried with the armsoc X driver so far so maybe I'll have more luck with glamor?

My access to the armbian forum has been fixed so I have replied to the scripts thread with my feedback now.

I have tried the glamor driver now and its highly unstable on my rock64 4GB. It lasts less than 5 seconds after showing the XFCE desktop before it crashes.
  Reply
#4
It works!

I have 4K videos playing smoothly under armbian with gstreamer now! What tripped me up was armbian/xfce defaulting to running my 4K display at 60 Hz, which caused jerky playback w/ green lines of my 30 fps vids. After using the XFCE display settings to change my display to 4K @ 30 Hz, videos play smoothly.

The rock64 arrives!

Big Grin
  Reply


Possibly Related Threads...
Thread Author Replies Views Last Post
  slarm64 (unofficial slackware) Rock64 RK3328 (aarch64) mara 61 14,247 11-03-2019, 09:08 AM
Last Post: mara
  Video : Media Script for the Rock64/4K video in Linux NicoD 1 682 03-30-2019, 02:17 AM
Last Post: zet_lab
  Error when installing some packages - Installing new rk3328-rock64.dtb. msg thewonderer 0 386 02-07-2018, 05:22 AM
Last Post: thewonderer
  Need .h includes for rk3328 gene83 4 267 10-06-2017, 07:26 PM
Last Post: gene83

Forum Jump:


Users browsing this thread: 1 Guest(s)