OpenBSD on Pinebook 1080p?
#29
OK, logged this
Code:
dd if=miniroot66.fs of=/dev/sdb bs=1M
dd if=idbloader.img of=/dev/sdb bs=1M seek=64
minicom -D /dev/ttyUSB0 -b 1500000 -8

Put the sd card in, plugged in the uart cable, powered up.

I saw this (copied and pasted):

OpenBSD 6.6 (RAMDISK) #257: Sat Oct 12 19:06:25 MDT 2019                        
   deys/arch/arm64/compile/RAMDISK                                            
real mem  = 4058435584 (3870MB)                                                
avail mem = 3858071552 (3679MB)                                                
mainbus0 at root: Rockchip RK3399 Evaluation Board                              
cpu0 at mai 64b/line 4-way L1 D-cache                                          
cpu0: 512KB 64b/line 16-way L2 cache                                            
efi0 at mainbus0: UEFI 2.0.5                                                    
rev 0x0                                                                        
psci0 at mainbus0: PSCI 1.0                                                    
agintc0 at mainbus0 sec shift 3:4 nirq 288 nredist 6: "interrupt-controller"    
agintcmsi0 at agintc0                                                          
syscon0 at mainbus0: "qos"                                                      
syscon1 at mainbus0: "qos"                          
syscon2 syscon4 at mainbus0: "qos"                                              
syscon7 at mainbus0: "qos"                                                      
syscon8 at mainbus0: "qos"                                                      
syscon9syscon10 at mainbus0: "qos"                                              
sys"                                                                            
syscon13 at mainbus0: "qos"                                                    
syscon14 at mainbus0: "qos"                                                    
syssyscon16 at mainbus0: "qos"                                                  
sysos"                                                                          
syscon19 at mainbus0: "qos"                                                    
syscon20 at mainbus0: "qos"                                                    
ssyscon22 at mainbus0: "qos"                                                    
sys"qos"                                                                        
syscon25 at mainbus0: "power-management"      
"power-controllsyscon26 at mainbus0: "syscon"                                  
syscon27 at mainbus0: "syscon"                                                  
syscon28 at mainbus0: "syscon"                                                  
rkclock0 at mainbus0                                                            
rkclock1 at mainbus0                                                            
syscon29 at mainbus0: "syscon"                                                  
"io-domains" at syscon29 not configured                                        
"usb2-phy" at syscon29 t configured                                            
"phy" at syscon29 not configured                                                
rkpinctrl0 at mainbus0: "pinctrl"                                              
rkgpio0 at rkpinctrl0                                                          
rkgpio1 at rkpinctrl0                                                          
rkgpio2 at rkpinctrl0                                                          
rkgpio3 at rkpinctrl0                                                          
r0                                                                              
"display-subsystem" at mainbus0 not configured                                  
"pmu_a53" at mainbus0 not configured                                            
"pmu_a72" at mainbus0 not configured                                            
agtisimplebus0 at mainbus0: "amba"                                              
"dma-controller" at simplebus0 nplebus0 not configured                          
"crypto" at mainbus0 not configured                    
dwm: 50 MHz base clock                                                          
sdmmc0 at dwmmc0: 4-bit, sd high-speed, dma                                    
sdhc0 at mainbus0                                                              
sdhc0: SDHC 3.0, 200 MHz base clock                                            
sdmmc1 at sdhc0: 8-bit, sd : 50 MHz base clock                                  
sdmmc2 at dwmmc1: 4-bit, sd high-speed, mmcehci0 at mainbus0                    
usb0 at ehci0: USB revision 2.0                                                
uhub0 at usb0 configuration 1 interface 0 "Generic EHCI root hub/1.00 addr 1    
ohci0 at mainbus0: version 1.0                                                  
ehci1 at mainbus0                                                              
usb1 at ehci1: USB revision 2.0                                                
uhub1 at usb1 configuration 1 interface 0 "Generic EHCI root hubohci1 at mainbu0
"usb" at mainbus0 not configured                                                
"usb" at mainbus0 not configured                                                
"saradc" at mainbus0 not coniic0 at rkiic0                                      
rkiic1 at mainbus0                                                              
iic1 at rkiic1                                                                  
com0 at mainbus0: ns16550, no working fifo                                      
com0: console                                                                  
"spi" at mainbus0 not"thermal-zones" at mainbus0 not configured                
rkiic2 at mainbus0                                        
iic2 at rkiic2                                                                  
"pwm" at mainbus0 not configured                                                
"pwm" at mainbnot configured                                                    
"efuse" at mainbus0 not configured                                              
"watchdog" arkiic3 at mainbus0                                                  
iic3 at rkiic3                                                                  
rkpmic0 at iic3 addr 0x1b: RK808                                                
"vop" at mainbus0 not configured                                                
"edp" at mainbus0 not configured                                                
"reserved-d                                                                    
"xin32k" at mainbus0 not configured                                            
"dc-12v" at mainbus0 notainbus0 not configured                                  
"vcc-phy-regulator" at mainbus0 not conf not configured                        
"vcc5v0-usb3-host-regulator" at mainbus0 not coinbus0 not configured            
"backlight" at mainbus0 not configured                                          
""vcc3v0-sdio" at mainbus0 not configured                                      
"sdio-pwrseq" at mainbsimplefb0 at mainbus0panic: uvm_mapent_addr_insert: map 0)
                                                                               
The operating system has halted.                                                
Please press any key to reboot

Then it just sat there.  Long-press on the power button did nothing, hopefully the battery just went dead.  Charging now.

But in there is
Quote:"display-subsystem" at mainbus0 not configured
When I was building OpenBSD kernels years ago that meant you didn't have a driver, maybe you left it out of your kernel config file.  Quite likely there isn't any OpenBSD video driver.  But that's probably why there's nothing on the laptop's display.

I'm not sure why it went through the above and then exited, there's probably stuff missing other than just a display driver.  Many of OpenBSD's drivers seem to have come from NetBSD by the copyrights so if NetBSD has a driver for this it can probably be adapted.  But building it into the miniroot plus everything else missing would mean rebuilding the miniroot from source AFAIK which I'm not crazy about.  OpenBSD custom kernel building is officially unsupported, that's one of the reasons I stopped using it.  I was doing it for years until they told me I shouldn't.

The laptop still boots into Linux after a charge.  Maybe I'll leave some space for an OpenBSD partition on my new SSD, or maybe it'll get used for NetBSD or FreeBSD.  All the "not configured" devices above can't do anything.
  Reply


Messages In This Thread
OpenBSD on Pinebook 1080p? - by binholz - 01-17-2019, 10:10 AM
RE: OpenBSD on Pinebook 1080p? - by heywire - 01-17-2019, 02:57 PM
RE: OpenBSD on Pinebook 1080p? - by cambridgei - 05-24-2019, 07:45 AM
RE: OpenBSD on Pinebook 1080p? - by ninefathom - 05-30-2019, 06:01 PM
RE: OpenBSD on Pinebook 1080p? - by michaelj - 10-07-2019, 03:00 PM
RE: OpenBSD on Pinebook 1080p? - by elewarr - 10-20-2019, 01:05 PM
RE: OpenBSD on Pinebook 1080p? - by joancatala - 10-21-2019, 11:55 AM
RE: OpenBSD on Pinebook 1080p? - by elewarr - 11-04-2019, 06:17 PM
RE: OpenBSD on Pinebook 1080p? - by rogerroger - 12-20-2019, 06:19 AM
RE: OpenBSD on Pinebook 1080p? - by rogerroger - 12-20-2019, 07:51 AM
RE: OpenBSD on Pinebook 1080p? - by ab1jx - 02-18-2020, 11:45 AM
RE: OpenBSD on Pinebook 1080p? - by rogerroger - 02-18-2020, 02:20 PM
RE: OpenBSD on Pinebook 1080p? - by ab1jx - 02-18-2020, 05:53 PM
RE: OpenBSD on Pinebook 1080p? - by rogerroger - 02-18-2020, 09:18 PM
RE: OpenBSD on Pinebook 1080p? - by ab1jx - 02-18-2020, 09:00 PM
RE: OpenBSD on Pinebook 1080p? - by ab1jx - 02-18-2020, 09:47 PM
RE: OpenBSD on Pinebook 1080p? - by rogerroger - 02-18-2020, 10:01 PM
RE: OpenBSD on Pinebook 1080p? - by rogerroger - 02-19-2020, 12:18 AM
RE: OpenBSD on Pinebook 1080p? - by rogerroger - 02-19-2020, 01:34 AM
RE: OpenBSD on Pinebook 1080p? - by ab1jx - 02-19-2020, 09:50 AM
RE: OpenBSD on Pinebook 1080p? - by rogerroger - 02-20-2020, 10:02 AM
RE: OpenBSD on Pinebook 1080p? - by ab1jx - 02-22-2020, 05:54 PM
RE: OpenBSD on Pinebook 1080p? - by rogerroger - 02-22-2020, 08:06 PM
RE: OpenBSD on Pinebook 1080p? - by ab1jx - 02-22-2020, 09:25 PM
RE: OpenBSD on Pinebook 1080p? - by ab1jx - 03-15-2020, 05:16 PM
RE: OpenBSD on Pinebook 1080p? - by rogerroger - 03-16-2020, 12:59 AM
RE: OpenBSD on Pinebook 1080p? - by ab1jx - 03-16-2020, 11:54 AM
RE: OpenBSD on Pinebook 1080p? - by ab1jx - 03-16-2020, 10:01 PM
RE: OpenBSD on Pinebook 1080p? - by ab1jx - 03-17-2020, 07:59 AM
RE: OpenBSD on Pinebook 1080p? - by ab1jx - 03-18-2020, 06:42 AM

Possibly Related Threads...
Thread Author Replies Views Last Post
Question OpenBSD 6.7 on Pinebook 1080p SKG 4 126 05-25-2020, 08:15 AM
Last Post: SKG
  OpenBSD on Pinebook - improving user experience elewarr 15 2,026 12-20-2019, 06:57 PM
Last Post: rogerroger
Thumbs Up NetBSD for Pinebook Luke 17 7,010 07-09-2019, 08:11 PM
Last Post: Der Geist der Maschine
  FreeBSD for Pinebook e-minguez 3 2,115 12-19-2018, 01:04 AM
Last Post: k_mp

Forum Jump:


Users browsing this thread: 1 Guest(s)