Cannot get RockPro64 to boot
(01-05-2019, 11:02 PM)randyc Wrote: I just got a brand new RockPro64 yesterday and I have not been able to get it to boot. I've tried several different OS images (OMV, Ubuntu, Debian, and Armbian). I've tried 2 different microSD cards. I've tried prepping the microSD cards using Ubuntu and MacOS, using built in tools and Etcher.

I get the same results no matter what I do:
  • The green power LED turns on
  • Ethernet lights turn on, and blink as if there is activity but never appears on my network.
  • If I hold down the power button the ethernet lights turn off
I am definitely using RockPro64 OS images.

Am I doing something wrong or did I get a bad board?

My waters say your board is OK. It could be the SDcard slot is non-functional, or your SDcard writing is duff (yeaf I hear you have maultiple/many tries!)
Green LED means your PSU works as far as the socket on the RPro64
Flashing Ethernet lights mean the board is trying to boot BUT
NO white LED means no bootable image found.

As per Bullet64 tracing with a UART adapter would be ideal. But - my 6p is
1) Stick to the Ubuntu minimal image here.
2) Check this thread.
  • ROCKPro64 v2.1 2GB, 16Gb eMMC for rootfs, SX8200Pro 512GB NVMe for /home, HDMI video & sound, Bluetooth keyboard & mouse. Arch (5.19 kernel, Openbox desktop) for general purpose daily PC.
  • PinePhone Pro Explorer Edition daily driver, Tow-boot on SPI, Arch/phosh on eMMC
  • PinePhone BraveHeart now v1.2b 3/32Gb, Tow-boot with Arch/Phosh on eMMC

Messages In This Thread
Cannot get RockPro64 to boot - by randyc - 01-05-2019, 11:02 PM
RE: Cannot get RockPro64 to boot - by Bullet64 - 01-06-2019, 01:09 AM
RE: Cannot get RockPro64 to boot - by dukla2000 - 01-06-2019, 10:35 AM
RE: Cannot get RockPro64 to boot - by randyc - 01-06-2019, 06:14 PM
RE: Cannot get RockPro64 to boot - by dukla2000 - 01-07-2019, 06:02 AM
RE: Cannot get RockPro64 to boot - by randyc - 01-07-2019, 07:58 PM
RE: Cannot get RockPro64 to boot - by andyburn - 01-18-2019, 12:14 AM
RE: Cannot get RockPro64 to boot - by 40four - 01-24-2019, 09:11 PM

Possibly Related Threads…
Thread Author Replies Views Last Post
  u-boot locked on pine64pro ljones 1 110 09-06-2022, 10:32 AM
Last Post: ljones
  Cannot get my board to boot deutschlmao 11 2,521 09-05-2022, 04:23 PM
Last Post: ljones
  RockPro64 ddr clock speed causing system instability CypherShrugged 1 207 08-15-2022, 02:32 PM
Last Post: CypherShrugged
  OPNsense for RockPro64 one8three 2 577 08-08-2022, 09:43 PM
Last Post: XaveT
  NAS Optimizations for RockPro64 MNtinkerer 25 3,058 08-03-2022, 01:57 PM
Last Post: MNtinkerer
  U-BOOT Tutorial hazz 0 195 07-19-2022, 10:48 PM
Last Post: hazz
  Installation Debian on emmc: which U-Boot and where? vongillus 3 519 07-02-2022, 09:24 AM
Last Post: dkebler
  How to run Raspberry Pi software on RockPro64? pk245 0 329 06-24-2022, 08:20 AM
Last Post: pk245
  enble boot after power loss/restore dkebler 11 2,021 06-22-2022, 09:39 PM
Last Post: dkebler
  ROCKPRO64 PCI SSD SD-boot Install pspgarret 0 287 06-09-2022, 10:56 AM
Last Post: pspgarret

Forum Jump:

Users browsing this thread: 1 Guest(s)