[Feb 26] Recalbox beta v3.1- Rock64 |[Feb 26] Recalbox 190222- RockPro64 / Minimal Debian by mrfixit2001 - 190222 - RockPro64 |[Feb 26] Q4OS 2.7-r2 - Pinebook 1080P / Pinebook |[Feb 22] Batocera Linux 5.20-20190121- RockPro64 | [Feb 19] Manjaro KDE 19.02 / Manjaro LXQT 19.02 - Pinebook1080P / Pinebook | [Feb 19] Slackware Aarch64 Miniroot and XFCE 20190201 - RockPro | [Feb 19] Slackware Aarch64 Miniroot and XFCE 20190201 - Rock64

Project Inspiration | Get Started | IRC Logs | Forum Rules/Policy

Rockpro64 NFS root mount (kernel 4.20) - ethernet help?
Hi all

Does anyone have any hints on how to get an NFS mount working?  I am using kernel 4.20 since it recently had rockpro64 support added.  My kernel parameters look like the following:

console=ttyS2,1500000 earlycon=uart8250,mmio32,0xff1a0000 root=/dev/nfs rw nfsroot=,proto=tcp,vers=3 ip= raid=noautodetect nfsrootdebug

and I am loading my kernel and kicking it off from u-boot with:

tftpboot 0x2000000 <kernel Image>
tftpboot 0x20000000 rk3399-rockpro64.dtb
booti 0x2000000 - 0x20000000

The NFS debug spits out:
NFS: nfs mount opts='vers=2,udp,rsize=4096,wsize=4096,proto=tcp,vers=3,nolock,addr='
NFS:   parsing nfs mount option 'vers=2'
NFS:   parsing nfs mount option 'udp'
NFS:   parsing nfs mount option 'rsize=4096'
NFS:   parsing nfs mount option 'wsize=4096'
NFS:   parsing nfs mount option 'proto=tcp'
NFS:   parsing nfs mount option 'vers=3'
NFS:   parsing nfs mount option 'nolock'
NFS:   parsing nfs mount option 'addr='
NFS: MNTPATH: '/export/sysroot'
NFS: sending MNT request for
NFS: failed to create MNT RPC client, status=-101
NFS: unable to mount server, error -101

I am not convinced that the network interface is coming up.  For starters, I never see anything like the following on the console:

IP-Config: Complete:
      device=eth0, addr=, mask=, gw=,
    host=myboard, domain=, nis-domain=(none),
    bootserver=, rootserver=, rootpath= 

which is what I thought using the ip= parameter was supposed to do and when I turn on:
rpcdebug -m nsfd all
rpcdebug -m rpc all

and watch /var/log/messages on my server, nothing happens - it looks like my devices aren't talking.

I assumed that the in kernel realtek drivers would be sufficient, but I noticed that in the 4.4 kernel, there is an actual rockchip ethernet driver - does that need to be used in the 4.20 kernel?  I tried copying it and adding it to my config, but some of the timer interfaces changed, so it does not compile.

Any hints would be helpful.


Possibly Related Threads...
Thread Author Replies Views Last Post
  NVMe and new kernel bjbb17 0 164 09-25-2018, 03:39 PM
Last Post: bjbb17
  Real-time linux kernel Artyom 45 10,658 09-11-2018, 01:08 AM
Last Post: zzwpine
  DKMS on kernel 3.10.107-pine64 obrienmd 5 425 06-21-2018, 05:45 PM
Last Post: evilbunny
  Kernel for A64 git longsleep 179 53,354 03-25-2018, 03:25 PM
Last Post: Luke
  Gentoo for pine64 - longsleep kernel incoherent 0 663 12-09-2017, 08:14 AM
Last Post: incoherent
  [SOLVED] UEFI + Fedora Mainline Kernel Booting! cztian 0 628 07-13-2017, 08:38 PM
Last Post: cztian
  Mainline kernel [Solved] jeroen79 11 2,592 02-08-2017, 06:19 AM
Last Post: umiddelb
Question Need help : Issue in running compiled kernel with tftp+uboot dinesh.bhoyar 2 634 01-30-2017, 12:44 AM
Last Post: dinesh.bhoyar
Question No more ethernet with linux... Android connection is fine?!?! cr2016 9 1,467 11-12-2016, 07:29 PM
Last Post: cr2016
  Jackd triggers kernel warning cztian 0 912 09-03-2016, 08:16 AM
Last Post: cztian

Forum Jump:

Users browsing this thread: 1 Guest(s)