rust package not avalaible for aarch64
#1
I tried to compile firefox via pkgsrc and I can’t because rust isn’t avalaible on aarch64 arch.

Any suggestion to fix it? I’ll keep doing some research... Looking for rust compile instructions...

arm64# pwd
/usr/pkgsrc/lang/rust
arm64# cd ..
arm64# ls rust*
CVS           DESCR         Makefile      buildlink3.mk cargo.mk      distinfo      files         patches
arm64# ls ru
ruby/                      ruby-gherkin/              ruby23-base/               runawk/
arm64# pwd
/usr/pkgsrc/lang/rust
arm64# make install
=> Bootstrap dependency digest>=20010302: found digest-20180917
ERROR: This package is not available for these platforms: NetBSD-8.99.26-aarch64.
ERROR: This package has set PKG_SKIP_REASON:
ERROR: rust-1.30.1nb1 is not available for NetBSD-8.99.26-aarch64
*** Error code 1

Stop.
make: stopped in /usr/pkgsrc/lang/rust
arm64# 
  Reply
#2
I think this should be posted in the netbsd-arm mailing list or pkgsrc support list as it is not pinebook related but a generic issue, right?

Enviado desde mi ONEPLUS A5010 mediante Tapatalk
  Reply
#3
Yep, i’m on holidays until next Monday. I’ll do it.

It’s a netbsd problem not a pinebook or pine64 problem.

I put here if any user find same problem...
  Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)