Armbian images available
#41
Question, is there a Kernel version that implements fan support, is there a way to add fan support? tryed tux3d fanctl but wasnt able to make it work, since im asking will 5.3 kernel be rolling on this board/ship, how is panfrost testing going?
  Reply
#42
(01-01-2020, 02:28 PM)NightCrawler504 Wrote: ... since im asking will 5.3 kernel be rolling on this board/ship ...

Dunnoh Armbian roadmap, but Ayufan images can be updated to try test versions of 5.3 kernels, and both Ayufan and Manjaro have 5.4 kernels available.
  • ROCKPro64 v2.1 2GB, 16Gb eMMC for rootfs, SX8200Pro 512GB NVMe for /home, HDMI video & sound, Bluetooth keyboard & mouse. Arch (5.13 kernel, Openbox desktop) for general purpose daily PC.
  • PinePhone BraveHeart now v1.2b 3/32Gb daily driver, dual boot via p-boot with Mobian/f2fs/Phosh on eMMC, Arch/ext4/Phosh on SDcard
  • PinePhone v1.2a 2G/16Gb that needs USB board replaced
  Reply
#43
So ive recently wanted to try all images again and for some reason i just cant get armbian to boot, are all images made for emmc, ive tried rufus and pine installer, tried flashing direct donwload and unzipped, ive tried different sd cards that i already know work on other os but armbian just soesnt want to play, do i have to use dd method? is that the only way, can you just not flash to a microsd? and avoid using emmc?
  Reply
#44
I tried the latest versions and they work on eMMC and also on SD card.

I am just trying to get SDL2 working in Stella without Window manager, no luck till now, but the desktop including KDE woks fine, like on Pinebook Pro.

I am still not sure if provided driver supports SDL2 or I have to install some another driver.
  Reply
#45
I ended up downloading the other recommended software in the page since main links didn't work 4 me.

Also some pretty inspiring news is going on in the Armbian development for rk3399 and hopefully it will translate to rp64, also debían bullseye is going to maintain pine book so maybe again we might profit from it, seems that even 4k is posible, boards like the nano m4b also did a gr8 job in their Android release so if interested development of the graphics in armbian for the board is here:

https://forum.armbian.com/topic/16516-rk...framework/
  Reply
#46
Ive been using armbian as default just because I have high hopes on the jmcc progress on media and is actually the only os that has consistently worked on bettering image.

As of lately, like 2 weeks ago, ram just started to fade away, running the same programs Ive been running for a while now. Checked issue and xfce (xfdesktop) was the culprit for some reason it keeps bloating on ram till there is no more left.

My rp64 is the 2 gb model and on system alone xfce used anywhere between 1.2 to 1.4gb of ram of 1.8 available, i constantly update/upgrade machine at first this was not an issue until like 2 weeks ago, i start the program i leave always on and it would start with a 150mega ram space available to the point where it would choke without any ram available.

Decided to try out kde and installed from synaptic manager since i did a quick apt search and there where too many packages hoped it would take care of dependencies, it installed without kwin so added it manually (cause windows didn't work), since it worked i did the tasksel install and it installed missing dependencies.

Atm kde plasma is using anywhere between 600 to 800 megas of ram that's at least 400 megas difference on the worst case scenario, I can now open my program see a video (at 720p) and still have available ram, its a huge difference. Never would i have even dare try to to open a third window on xfce, on kde its possible and still have room for more.

kde takes a little more time opening apps but once they are open they work so much better since there is no ram choking issue. I'm guessing these are tweaks on the updates so not complaining, but if you are having ram scarcity issues like me id really urge you to try kde-plasma. 1.4megas out of 1.8 just for system really is too much load for my already cut short ram im glad i found an option.

Another thing that was annoying me on xfce is that after display turned off to save energy it kept changing my screen resolution, kde doesn't do that.

Ive yet to tweak kde, take away transparency and some other animations to make it snappier. but since armbian is tailored for xfce not kde im following the dont repair if its not broken approach since its very likely ill break it if i tweak too much.

Thank you armbian development team for keeping our board alive.

BTW Konkeror browser is super light and fast, as long as you dont open many tabs/windows its just a breeze, looks so much better and get 600mb of use both with desktop and browser.

Also for those of you having low sound issue on 3.5mm audio port just edit volume on alsamixer that solves the problem

just type "alsamixer" on terminal
  Reply
#47
is this project still around? I've tried several armbian versions and can't get mine to boot from any of them. I can boot ayufan minimal images. I'm hoping to set up this box to run an application that requires ubuntu...I also want to move the root to the NVME on the PCIE riser board. I have had this working briefly,but, it just sometimes refuses to boot ... even with no devices attached.
  Reply
#48
(03-23-2021, 06:02 PM)bg002h Wrote: is this project still around? I've tried several armbian versions and can't get mine to boot from any of them. I can boot ayufan minimal images. I'm hoping to set up this box to run an application that requires ubuntu...I also want to move the root to the NVME on the PCIE riser board. I have had this working briefly,but, it just sometimes refuses to boot ... even with no devices attached.

ROCKPro64 is a Supported device on Armbian.  Therefore it should "just work."

I installed it just the other day in fact and everything went flawless.

Maybe begin with basic troubleshooting like SD card, power, etc.
  Reply
#49
(03-23-2021, 09:45 PM)TRS-80 Wrote:
(03-23-2021, 06:02 PM)bg002h Wrote: is this project still around? I've tried several armbian versions and can't get mine to boot from any of them. I can boot ayufan minimal images. I'm hoping to set up this box to run an application that requires ubuntu...I also want to move the root to the NVME on the PCIE riser board. I have had this working briefly,but, it just sometimes refuses to boot ... even with no devices attached.

ROCKPro64 is a Supported device on Armbian.  Therefore it should "just work."

I installed it just the other day in fact and everything went flawless.

Maybe begin with basic troubleshooting like SD card, power, etc.


I finally got it to work. I was trying to use ayufan’s lastest stable release…but that wouldn’t work…apparently I skipped some step about SPI flash, or perhaps somehow corrupted the SPI flash…I dunno. Armbian would not work in whatever state I managed to get my machine into. But after flashing SPI all the boot programs (God bless whoever wrote all that!) to SPI, ayufan disk image booted fine (even from NVME!). I can’t leave the keyboard plugged in and reboot…and sometimes it won’t boot without disconnecting power or pressing reset, but it eventually always reboots. System sometimes hangs when I play with cpu frequency widget on the desktop. 

Balena etcher is a fantastic program. I have a 5a brick style power supply from pine64 (I think I now own two of everything they make, or just about, minus the camera stuff and touch display!  Big Grin ) and some “industrial” fast sd cards (gets consistently over 30 MB/s on balena during imaging).
  Reply
#50
(03-23-2021, 09:45 PM)TRS-80 Wrote:
(03-23-2021, 06:02 PM)bg002h Wrote: is this project still around? I've tried several armbian versions and can't get mine to boot from any of them. I can boot ayufan minimal images. I'm hoping to set up this box to run an application that requires ubuntu...I also want to move the root to the NVME on the PCIE riser board. I have had this working briefly,but, it just sometimes refuses to boot ... even with no devices attached.

ROCKPro64 is a Supported device on Armbian.  Therefore it should "just work."

I installed it just the other day in fact and everything went flawless.

Maybe begin with basic troubleshooting like SD card, power, etc.
Thank you again for your reply! I followed current instructions properly and install of armbian was a breeze.
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  New OS for RockPro64 is here, TwisterOS Armbian jtremblant 84 20,926 07-03-2021, 07:09 AM
Last Post: jtremblant
  with armbian. my boad seems alive LMM 0 359 02-11-2021, 03:24 PM
Last Post: LMM
  Accessing UART4 on RockPro64 (Armbian) antonlyap 1 1,219 10-04-2020, 12:51 PM
Last Post: antonlyap
  RockPro64 getting started - non-booting images [solved] new-rockpro-user 3 2,236 03-06-2020, 06:31 AM
Last Post: new-rockpro-user
  new rockpro64: images won't boot [solved] new-rockpro-user 0 1,192 11-20-2019, 12:42 PM
Last Post: new-rockpro-user
  RockPro64 - Armbian no sound from jack Pineapple 0 874 09-16-2019, 08:27 AM
Last Post: Pineapple
  Anyone tried the new mainline images (Panfrost)? stuartiannaylor 0 1,196 08-13-2019, 07:04 AM
Last Post: stuartiannaylor
  armbian buster/5.2 preempt-rt kernel rocksa 1 1,492 08-01-2019, 05:51 PM
Last Post: dukla2000
Information [archived] 0.8.X images from ayufan; Mate DE + video / 3d acceleration Luke 28 15,728 05-18-2019, 02:03 PM
Last Post: rickard
  Unable to boot ayufan images vman 0 842 03-27-2019, 02:06 AM
Last Post: vman

Forum Jump:


Users browsing this thread: 1 Guest(s)