How to enable touchpad natural scrolling?
#1
Two-fingered scrolling is working fine, but is there a way that I can reverse the direction (natural scrolling) in KDE Neon?
I found some options in Settings but doesn't work.
And it seems KDE neon doesn't recognised touchpad too.
  Reply
#2
xinput set-prop 8 "Evdev Scrolling Distance" -1 1 1

How to discover that:
xinput list
xinput list-props 8

Edit: FWIW, the trackpad does not present its self as a trackpad to the pinebook. It presents its self as a USB mouse and keyboard (pinch zoom is actually a control key press + scroll wheel movement).
  Reply
#3
Super tip.

I am using Manjaro (Archlinux).

Property device 8 was not the mouse and I could not find property Evdev Scrolling Distance.

However, after exploring the device as described above for me this worked to reverse the mouse scrolling direction.

Quote:xinput set-prop 7 "libinput Natural Scrolling Enabled" 1
  Reply
#4
The following worked for me:




System Settings -> Input Devices -> Touchpad -> Scrolling -> Reverse scrolling: Vertical



---

Operating System: Manjaro-ARM
KDE Plasma Version: 5.19.3
KDE Frameworks Version: 5.71.0
Qt Version: 5.15.0
Kernel Version: 5.7.0-3-MANJARO-ARM
OS Type: 64-bit
Processors: 6 ×
Memory: 3.7 GiB of RAM

Graphics Processor: Mali T860


Attached Files
.png   Touchpad_natural_scrolling.png (Size: 38.89 KB / Downloads: 36)
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  Disable touchpad tap to click? colin.faulkingham 25 6,472 04-27-2020, 07:31 PM
Last Post: ab1jx
  Proof of concept script to disable the touchpad while typing daid 21 5,197 02-25-2018, 06:47 PM
Last Post: pfeerick
Sad touchpad edges scrolling kurai021 11 2,357 07-09-2017, 05:56 PM
Last Post: Luke

Forum Jump:


Users browsing this thread: 1 Guest(s)