Set Static IP
#11
(05-05-2016, 08:44 AM)tkaiser Wrote:
(04-19-2016, 07:58 AM)JCMPine64 Wrote: Anyone have an idea on what I am doing wrong?

You're using crappy/manipulated OS images. The simple reason is outlined here: http://forum.pine64.org/showthread.php?t...99#pid8199

And in case you're using Xubuntu or any of the other 'extended' featured OS images found in the wiki be prepared that Pine64 used as server will waste energy since moronically a screensaver will eat up all CPU resources and will lead even to throttling since the SoC starts overheating.

I was wondering about that.  I posted a question on how to turn off the gui, since I'm building a headless server:
http://forum.pine64.org/showthread.php?tid=692
  Reply
#12
(05-05-2016, 09:06 AM)JCMPine64 Wrote: I posted a question on how to turn off the gui, since I'm building a headless server:

Why turning the GUI off? There exist ONLY 2 real OS images, all the others (these are the featured ones on wiki.pine64.org) are manipulated/crappy ones that contain more bugs.

1) Longsleep's original Ubuntu Xenial: http://forum.pine64.org/showthread.php?tid=376

2) Longsleep's original Arch Linux image: http://forum.pine64.org/showthread.php?tid=343 (WTF! A mod moved the thread somewhere around -- it's close to unbelievable how shitty this forum is administrated)

Both are headless and the former already contains all fixes. For the latter it's necessary to execute the basic updates.

Code:
bash <(curl -s https://raw.githubusercontent.com/longsleep/build-pine64-image/master/simpleimage/platform-scripts/pine64_update_uboot.sh)
bash <(curl -s https://raw.githubusercontent.com/longsleep/build-pine64-image/master/simpleimage/platform-scripts/pine64_update_kernel.sh)
bash <(curl -s https://raw.githubusercontent.com/longsleep/build-pine64-image/master/simpleimage/platform-scripts/pine64_fix_whatever.sh)

The 'featured' OS images in the wiki suffer from wrong settings (both containing stuff in /etc/network/interfaces as well as adding a network-manager -- those get in conflict and that's the reason you run in the problem this thread is about) and lack documentation.

A while ago the Pine64 people provided also that much outdated OS images there that absolutely useless threads like this popped up. A whole thread about an issue that has been fixed by the only active developer weeks ago. And it's only the Pine64 people's fault since they did not update the stuff in the Wiki. Now they do it wrong again, take others' OS images, update/add this or that and provide it without proper versioning information.

When today anyone reports a software related bug it's close to impossible to deal with that since we devs would have to download bloated OS images from the Wiki first to check what has been probably messed up. This is just an insane waste of time and efforts.

Use longsleep's 160 MB original Xenial image, update it using the aforementioned scripts from time to time and stay away from the bloated/crappy featured stuff from the Wiki!

This is how your headless server behaves when you use the featured 'Xubuntu' image. SoC temperature up to 90°C and full CPU utilisation since ressource intensive screensavers are running (you NEVER activate these screensavers on a small ARM based development board unless you have GPU drivers ready so that this graphical intensive stuff can run on the GPU cores with minimal load. And that's just one of the many flaws the featured OS images show):

[Image: Bildschirmfoto%202016-05-03%20um%2017.44.12.png]
  Reply
#13
I'm currently using the 20160403-1 version of longsleep's xenial os. I tried using the latest version, but I none of the samba restart commands would work, so I reverted and everything worked fine.  I'm loading the latest version again and will see if I just did something wrong.
  Reply
#14
I must be brain damaged in some way.  I loaded the 20160403-1 version of longsleep's xenial os and have spend 3 hours trying to set the static IP.  Every thing I've tried has bricked the board, requiring me to re-load the base os.

I've tried editing /etc/network/interfaces.

The default file looks like this:
Code:
# interfaces(5) file used by ifup(8) and ifdown(8)
# Include files from /etc/network/interfaces.d:
source-directory /etc/network/interfaces.d

# Disable wlan1 by default (8723bs has two intefaces)
iface wlan1 inet manual

I've added a static block to the end of the file:
Code:
# interfaces(5) file used by ifup(8) and ifdown(8)
# Include files from /etc/network/interfaces.d:
source-directory /etc/network/interfaces.d

# Disable wlan1 by default (8723bs has two intefaces)
iface wlan1 inet manual

Auto eth0
iface eth0 inet static
address 192.168.1.206
netmask 255.255.255.0
network 192.168.1.0
broadcast 192.168.1.255
gateway 192.168.1.1
dns-nameservers 4.2.2.1 4.2.2.2 8.8.8.8

I've removed the contents of the file and just tried this:
Code:
Auto eth0
iface eth0 inet static
address 192.168.1.206
netmask 255.255.255.0
network 192.168.1.0
broadcast 192.168.1.255
gateway 192.168.1.1
dns-nameservers 4.2.2.1 4.2.2.2 8.8.8.8

I've also left the interfaces file alone and gone into  /etc/network/interfaces.d/eth0 and changed it to read:
Code:
Auto eth0
iface eth0 inet static
address 192.168.1.206
netmask 255.255.255.0
network 192.168.1.0
broadcast 192.168.1.255
gateway 192.168.1.1
dns-nameservers 4.2.2.1 4.2.2.2 8.8.8.8

Nothing works, and everything bricks the Pine64.

I've also used nmtui to set the static IP, and it works for a bit, but then seeming-randomly it reverts back to dhcp mode.

What do I continue to do wrong?  I was able to make it work in the previous version of longsleep's xenial, but nothing seems to work in the latest version. 

Also, is there a non-destructive way to test setting the static IP, one where I don't have to reload the os everytime something doesn't work?

Thanks
  Reply
#15
(05-06-2016, 07:50 AM)JCMPine64 Wrote: I must be brain damaged in some way.  I loaded the 20160403-1 version of longsleep's xenial os and have spend 3 hours trying to set the static IP.  Every thing I've tried has bricked the board, requiring me to re-load the base os.

I fear I don't understand what you're doing. Are you trying this whole stuff only connected through SSH or do you use keyboard/display or serial console?

When changing network configuration over SSH chances are pretty high to lock yourself out. Also I would check whether the interface file's contents are case sensitive (Auto vs auto). And to be honest: Fiddling around with static text files in 2016 is a bit strange. Why not set the static IP address on the router instead (based on the MAC address) or use Bonjour (only an option if the Pine64 should be accessible from LAN only)?
  Reply
#16
I also tried not including the first Auto line, and I still lock up.

Unfortunately, I have an Actiontec Fios router, and I haven't been able to figure out how to assign a specific address to a specific MAC id.

The thing that gets me on this is that I've set static IP addresses dozens of times on Raspberry Pis, CHIPS and even the Pine64, on an earlier version of longsleep's xenial image.
  Reply
#17
Are you using SSH?
  Reply
#18
(05-06-2016, 09:53 AM)Leoncito81 Wrote: Are you using SSH?

Yes
  Reply
#19
(05-06-2016, 10:05 AM)JCMPine64 Wrote:
(05-06-2016, 09:53 AM)Leoncito81 Wrote: Are you using SSH?

Yes

Then most probably nothing is 'bricked' but you lock yourself out. I still don't get which OS images you're using (since you said you want to deinstall the GUI and the original longsleep images are headless) but in case you've also the WiFi/BT module I would check with 'netstat -rn' how routes look like, disconnect the WiFi module if present and switch to non SSH mode (using keyboard/display or serial console).

The whole stuff is 'plain Debian' when you use longsleep's original Xenial image and it should be enough to change /etc/network/interfaces.d/eth0 the way you want.
  Reply
#20
(05-06-2016, 08:02 AM)tkaiser Wrote:
(05-06-2016, 07:50 AM)JCMPine64 Wrote: I must be brain damaged in some way.  I loaded the 20160403-1 version of longsleep's xenial os and have spend 3 hours trying to set the static IP.  Every thing I've tried has bricked the board, requiring me to re-load the base os.

I fear I don't understand what you're doing. Are you trying this whole stuff only connected through SSH or do you use keyboard/display or serial console?

When changing network configuration over SSH chances are pretty high to lock yourself out. Also I would check whether the interface file's contents are case sensitive (Auto vs auto). And to be honest: Fiddling around with static text files in 2016 is a bit strange. Why not set the static IP address on the router instead (based on the MAC address) or use Bonjour (only an option if the Pine64 should be accessible from LAN only)?

(05-06-2016, 10:14 AM)tkaiser Wrote:
(05-06-2016, 10:05 AM)JCMPine64 Wrote:
(05-06-2016, 09:53 AM)Leoncito81 Wrote: Are you using SSH?

Yes

Then most probably nothing is 'bricked' but you lock yourself out. I still don't get which OS images you're using (since you said you want to deinstall the GUI and the original longsleep images are headless) but in case you've also the WiFi/BT module I would check with 'netstat -rn' how routes look like, disconnect the WiFi module if present and switch to non SSH mode (using keyboard/display or serial console).

The whole stuff is 'plain Debian' when you use longsleep's original Xenial image and it should be enough to change /etc/network/interfaces.d/eth0 the way you want.

Thanks everyone.  tkaiser figured it out:
"Also I would check whether the interface file's contents are case sensitive (Auto vs auto)."

That was the problem.
  Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)