[Feb 26] Recalbox beta v3.1- Rock64 |[Feb 26] Recalbox 190222- RockPro64 / Minimal Debian by mrfixit2001 - 190222 - RockPro64 |[Feb 26] Q4OS 2.7-r2 - Pinebook 1080P / Pinebook |[Feb 22] Batocera Linux 5.20-20190121- RockPro64 | [Feb 19] Manjaro KDE 19.02 / Manjaro LXQT 19.02 - Pinebook1080P / Pinebook | [Feb 19] Slackware Aarch64 Miniroot and XFCE 20190201 - RockPro | [Feb 19] Slackware Aarch64 Miniroot and XFCE 20190201 - Rock64

Project Inspiration | Get Started | IRC Logs | Forum Rules/Policy


RTL8812AU driver and connection issues
#1
Hi All,

I managed to get the RTL8812AU driver working with the help of evilbunny. However, I am having connection issues, and power saving issues.

Power save issues seem to occur when the driver is not connecting to wifi. Fair enough, but when I use nmtui to connect to the wifi, my gui gets spammed with the "nolinked power save leave/enter" messages. It would be nice if there was a way to disable this either in startup or the driver itself.

Additionally, is there a process which works better than others for connections? I am unable to connect to networks 95% of the time with nmtui. Would anyone advocate for using wpa_supplicant or something else entirely for stable connections?

Thanks for your time
pane
Reply
#2
(12-02-2018, 05:31 PM)pane Wrote: Hi All,

I managed to get the RTL8812AU driver working with the help of evilbunny. However, I am having connection issues, and power saving issues.

Power save issues seem to occur when the driver is not connecting to wifi. Fair enough, but when I use nmtui to connect to the wifi, my gui gets spammed with the "nolinked power save leave/enter" messages. It would be nice if there was a way to disable this either in startup or the driver itself.

Additionally, is there a process which works better than others for connections? I am unable to connect to networks 95% of the time with nmtui. Would anyone advocate for using wpa_supplicant or something else entirely for stable connections?

Thanks for your time
pane


You can disable the power saving mode by editing the Makefile and turning power saving off

CONFIG_POWER_SAVING = n


Then recompile etc.
Reply
#3
(12-02-2018, 05:42 PM)evilbunny Wrote:
(12-02-2018, 05:31 PM)pane Wrote: Hi All,

I managed to get the RTL8812AU driver working with the help of evilbunny. However, I am having connection issues, and power saving issues.

Power save issues seem to occur when the driver is not connecting to wifi. Fair enough, but when I use nmtui to connect to the wifi, my gui gets spammed with the "nolinked power save leave/enter" messages. It would be nice if there was a way to disable this either in startup or the driver itself.

Additionally, is there a process which works better than others for connections? I am unable to connect to networks 95% of the time with nmtui. Would anyone advocate for using wpa_supplicant or something else entirely for stable connections?

Thanks for your time
pane


You can disable the power saving mode by editing the Makefile and turning power saving off

CONFIG_POWER_SAVING = n


Then recompile etc.

Thanks evilbunny I will recompile, I found that the output stream from power saving would spam the SSID key box in nmtui. What is your preferred process for connecting to networks? I have had limited success with nmtui - do you use wpa_supplicant or something else to reliably connect to networks?

Thanks
Reply
#4
(12-03-2018, 07:13 PM)pane Wrote: Thanks evilbunny I will recompile, I found that the output stream from power saving would spam the SSID key box in nmtui. What is your preferred process for connecting to networks? I have had limited success with nmtui - do you use wpa_supplicant or something else to reliably connect to networks?


I use network manager when I use a gui, but use /etc/network/interfaces.d/ on headless systems.

# cat /etc/network/interfaces.d/wlan0
Code:
auto wlan0
allow-hotplug wlan0
iface wlan0 inet dhcp
wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf

# cat /etc/wpa_supplicant/wpa_supplicant.conf
Code:
ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
update_config=1
network={
       ssid="myaccesspoint"
       psk="mypassword"
}
Reply
#5
(12-03-2018, 07:28 PM)evilbunny Wrote:
(12-03-2018, 07:13 PM)pane Wrote: Thanks evilbunny I will recompile, I found that the output stream from power saving would spam the SSID key box in nmtui. What is your preferred process for connecting to networks? I have had limited success with nmtui - do you use wpa_supplicant or something else to reliably connect to networks?


I use network manager when I use a gui, but use /etc/network/interfaces.d/ on headless systems.

# cat /etc/network/interfaces.d/wlan0
Code:
auto wlan0
allow-hotplug wlan0
iface wlan0 inet dhcp
wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf

# cat /etc/wpa_supplicant/wpa_supplicant.conf
Code:
ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
update_config=1
network={
       ssid="myaccesspoint"
       psk="mypassword"
}
Thanks for that evilbunny, your advice is always helpful - I consider my issue solved now, I will use wpa_supplicant then instead of nmtui as I am using headless debian
Reply
#6
(12-03-2018, 08:38 PM)pane Wrote:
(12-03-2018, 07:28 PM)evilbunny Wrote:
(12-03-2018, 07:13 PM)pane Wrote: Thanks evilbunny I will recompile, I found that the output stream from power saving would spam the SSID key box in nmtui. What is your preferred process for connecting to networks? I have had limited success with nmtui - do you use wpa_supplicant or something else to reliably connect to networks?


I use network manager when I use a gui, but use /etc/network/interfaces.d/ on headless systems.

# cat /etc/network/interfaces.d/wlan0
Code:
auto wlan0
allow-hotplug wlan0
iface wlan0 inet dhcp
wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf

# cat /etc/wpa_supplicant/wpa_supplicant.conf
Code:
ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
update_config=1
network={
       ssid="myaccesspoint"
       psk="mypassword"
}
Thanks for that evilbunny, your advice is always helpful - I consider my issue solved now, I will use wpa_supplicant then instead of nmtui as I am using headless debian

Hi evilbunny - have finally found the time to try this rock64 stuff again - I am still having trouble with connecting to wifi using the rtl8812au driver. I am attempting to use your interface.d method with wpa_supplicant, and get a whole lot of "IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready". HOWEVER, I notice that my wifi adapter is not called wlan0 but is instead wlxFFFFFFFFFF etc dependent on MAC address. So I think the reason my connection is not working is because wlan0 is hard coded into the driver somewhere, while my adapter itself is wlxFFFFFFFF. Would you agree?
Reply
#7
(12-18-2018, 06:22 PM)pane Wrote: Hi evilbunny - have finally found the time to try this rock64 stuff again - I am still having trouble with connecting to wifi using the rtl8812au driver. I am attempting to use your interface.d method with wpa_supplicant, and get a whole lot of "IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready". HOWEVER, I notice that my wifi adapter is not called wlan0 but is instead wlxFFFFFFFFFF etc dependent on MAC address. So I think the reason my connection is not working is because wlan0 is hard coded into the driver somewhere, while my adapter itself is wlxFFFFFFFF. Would you agree?


wlan0 shouldn't be hard coded anywhere. You can for the time being disable netbios names by editing /etc/default/extlinux and I'm not sure what the command is to make it update the current config so I manually edit /boot/extlinux/extlinux.conf for good measure by adding the following on the end of the append line:

Code:
net.ifnames=0 biosdevname=0
Reply
#8
Hi evilbunny, I believe I found the source of my errors and connection problems... MAC address filtering. Your dkms wifi drivers seem to work straight out of the box when I connect to my LAN AP, but not my office internet. Hence, my link was not ready as it was being denied by the routers MAC address filtering - when the network admin returns from holidays, I will confirm this. Thanks for your patience again in helping me debug.
Reply


Possibly Related Threads...
Thread Author Replies Views Last Post
  WIFI driver compilation wsk 1 163 11-01-2018, 12:21 AM
Last Post: wsk
  New github source for rtl8812au ! pytheas 2 562 03-07-2018, 02:55 AM
Last Post: pytheas
  Rock64 RTL8812AU dongle (from store) how to get working on Android? Nelly 4 773 02-07-2018, 10:28 PM
Last Post: varos16
  gpio driver porting from an r-pi3b gene83 9 912 12-02-2017, 03:44 AM
Last Post: xalius

Forum Jump:


Users browsing this thread: 1 Guest(s)