[Jan 14] KDE Neon (20190113-1500) - Pinebook1080P / Pinebook |[Jan 14] Q4OS (2.7-r1) - Pinebook1080P / Pinebook | [Dec 07] DietPi(v6.18) - Pinebook / Manjaro KDE (preview3) / Manjaro LXQT (preview3) - Pinebook |[Dec 06] Armbian Debian Stretch (5.67) / Armbian Ubuntu 18.04 Bionic Desktop (5.67) - RockPro64 |[Dec 05] DietPi(v6.18) - 1080P Pinebook

Project Inspiration | Get Started | IRC Logs | Forum Rules/Policy

Arduino IDE translucent fonts
I have an odd problem. The IDE by Arduino has transparent fonts. It's usable only if the window below is dark, however the menus are unreadable, as they appear over the IDE itself.

I found out that disabling the window compositor solves this issue (alt+shift+f12) anyway it gives others, like an annoying flickering of the panel that sometimes disappears for a while.
I tried disabling the graphical eye candies, but with no luck. Only disabling the screen compositor works.

I'm running the stock Linux version.
Processing has translucent fonts and menus, too.

Anyway, I found that it's possible to disable the compositor when an application starts. Right click on the title bar, select "more actions" then under "Appearence & Fixes" select "Block compositing" as Force and Yes. The compositor shuts down when the IDE starts and gets back when it closes.

Forum Jump:

Users browsing this thread: 1 Guest(s)