Ongoing HDMI limited compatability
#11
(04-19-2016, 12:09 PM)rahlquist Wrote:
(04-19-2016, 12:04 PM)longsleep Wrote: Well whatever it is, do not expect the situation to improve anytime soon. I do not care much about display and just made it work 1080p@60Hz no further questions asked.

To understand why I do not care you need to know that the HDMI driver in the BSP Kernel driver is missing sources for "libhdmi" (similar to libdram situation for SPL). See https://github.com/longsleep/linux-pine6...i_sun50iw1 for reference.

You know, I knew of A's reputation for not being very OSS supportive but based on the BS on the KS page I figured we would at least have basic functionality out the gate. 

I was a fool, I have now paid my stupid tax for the year. Lets hope nobody wants a double installment. At least it was cheap. 

Ohh look maybe I can pay stupid tax again! https://www.kickstarter.com/projects/udo...ecommended  LOL

Pine64+ is very nice for a lot of use cases  - i am sure you find plenty people willing to buy yours if you do not want it.

To come back to the HDMI issue, if you want to help debugging get yourself a serial adapter (http://linux-sunxi.org/Pine64#Serial_port_.2F_UART) and post the full boot log (starting from boot0) to something like http://paste.ubuntu.com and share the link. The outout you need to paste looks like that one https://www.stdin.xyz/downloads/people/l...OOTLOG.txt - if you provide that some people might be interested to take a look.
#12
(04-19-2016, 12:20 PM)longsleep Wrote:
(04-19-2016, 12:09 PM)rahlquist Wrote:
(04-19-2016, 12:04 PM)longsleep Wrote: Well whatever it is, do not expect the situation to improve anytime soon. I do not care much about display and just made it work 1080p@60Hz no further questions asked.

To understand why I do not care you need to know that the HDMI driver in the BSP Kernel driver is missing sources for "libhdmi" (similar to libdram situation for SPL). See https://github.com/longsleep/linux-pine6...i_sun50iw1 for reference.

You know, I knew of A's reputation for not being very OSS supportive but based on the BS on the KS page I figured we would at least have basic functionality out the gate. 

I was a fool, I have now paid my stupid tax for the year. Lets hope nobody wants a double installment. At least it was cheap. 

Ohh look maybe I can pay stupid tax again! https://www.kickstarter.com/projects/udo...ecommended  LOL

Pine64+ is very nice for a lot of use cases  - i am sure you find plenty people willing to buy yours if you do not want it.

To come back to the HDMI issue, if you want to help debugging get yourself a serial adapter (http://linux-sunxi.org/Pine64#Serial_port_.2F_UART) and post the full boot log (starting from boot0) to something like http://paste.ubuntu.com and share the link. The outout you need to paste looks like that one https://www.stdin.xyz/downloads/people/l...OOTLOG.txt - if you provide that some people might be interested to take a look.
http://pastebin.com/41D22vnt

Big Grin
#13
(04-19-2016, 01:02 PM)rahlquist Wrote: http://pastebin.com/41D22vnt

Hmm... this is VGA and not HDMI:

Code:
disp0 device type(4) enable
[DISP] boot_disp:0x40a
#14
Looks similar to mine. So what does not work exactly?

Please also post the output of

xxd hdmi/hdmi/attr/edid

and cat graphics/fb0/modes
#15
(04-19-2016, 01:17 PM)longsleep Wrote: Looks similar to mine.

4 is 'wrong' (VGA) and should be 3 (HDMI) instead. Just looked how it's with the rather similar sun8i BSP (H3/A83T). Similar 'wrong' but there this happens in the kernel and not u-boot. Fun stuff to deal with Wink
#16
(04-19-2016, 01:34 PM)tkaiser Wrote:
(04-19-2016, 01:17 PM)longsleep Wrote: Looks similar to mine.

4 is 'wrong' (VGA) and should be 3 (HDMI) instead. Just looked how it's with the rather similar sun8i BSP (H3/A83T). Similar 'wrong' but there this happens in the kernel and not u-boot. Fun stuff to deal with Wink

No, that is actually U-Boot is using a bitmask where 4 is HDMI, VGA is 8. See https://github.com/longsleep/u-boot-pine...ay2.h#L127
#17
So, the monitor won't wake up because it is expecting "something else"(1050p/60Hz), but Pine is pushing 1080p/60Hz?
#18
(04-19-2016, 01:17 PM)longsleep Wrote: Looks similar to mine. So what does not work exactly?

Please also post the output of

xxd hdmi/hdmi/attr/edid

and cat graphics/fb0/modes

Code:
root@localhost:~# xxd hdmi/hdmi/attr/edid
xxd: hdmi/hdmi/attr/edid: No such file or directory
root@localhost:~# which xxd
/usr/bin/xxd
root@localhost:~# cat graphics/fb0/modes
cat: graphics/fb0/modes: No such file or directory
#19
(04-20-2016, 05:49 AM)rahlquist Wrote: cat: graphics/fb0/modes: No such file or directory

These are relative paths, most likely relative to /sys/class (don't know -- booted the Pine64 a few weeks ago the last time). You might succeed doing a 'find /sys -type d -name fb0' to know the prefix needed to chdir to or create absolute paths.
#20
(04-20-2016, 06:24 AM)tkaiser Wrote:
(04-20-2016, 05:49 AM)rahlquist Wrote: cat: graphics/fb0/modes: No such file or directory

These are relative paths, most likely relative to /sys/class (don't know -- booted the Pine64 a few weeks ago the last time). You might succeed doing a 'find /sys -type d -name fb0' to know the prefix needed to chdir to or create absolute paths.

Thanks, when acting as 'smart hands' and troubleshooting using instructions from another person I tend to be terribly literal. Using the info you provided;

Code:
root@localhost:~# find /sys -type d -name fb0
/sys/devices/soc.0/1000000.disp/graphics/fb0
root@localhost:~# cat /sys/devices/soc.0/1000000.disp/graphics/fb0/modes
U:1920x1080p-0
Decided to get a bit more info using another method. I hooked my pi to the monitor and pulled EDID info. 
Code:
root@raspberrypioldpi:~# tvservice -s
state 0x120006 [DVI DMT (57) RGB full 16:10], 1680x1050 @ 60.00Hz, progressive
root@raspberrypioldpi:~# tvservice -m DMT
Group DMT has 4 modes:
          mode 4: 640x480 @ 60Hz 4:3, clock:25MHz progressive
          mode 9: 800x600 @ 60Hz 4:3, clock:40MHz progressive
          mode 16: 1024x768 @ 60Hz 4:3, clock:65MHz progressive
 (prefer) mode 57: 1680x1050 @ 60Hz 16:10, clock:119MHz progressive
root@raspberrypioldpi:~# tvservice -m CEA
Group CEA has 7 modes:
          mode 1: 640x480 @ 60Hz 4:3, clock:25MHz progressive
          mode 2: 720x480 @ 60Hz 4:3, clock:27MHz progressive
          mode 3: 720x480 @ 60Hz 16:9, clock:27MHz progressive
 (native) mode 4: 1280x720 @ 60Hz 16:9, clock:74MHz progressive
          mode 5: 1920x1080 @ 60Hz 16:9, clock:74MHz interlaced
          mode 6: 720x480 @ 60Hz 4:3, clock:27MHz x2 interlaced
          mode 7: 720x480 @ 60Hz 16:9, clock:27MHz x2 interlaced
Thats the simple stuff, attached is the output of;
Code:
root@raspberrypioldpi:~# tvservice -d edid.dat
Written 256 bytes to edid.dat
root@raspberrypioldpi:~# edidparser edid.dat > edid.txt
Also adding full pi serial console boot log.

Code:
root@raspberrypioldpi:~# cat /sys/devices/platform/soc/soc:fb/graphics/fb0/modes
U:1680x1050p-0


ATTENTION Moderator Note

Forum doesn't allow upload of files with the extension .log seriously? Might what to address that lol.

Have edited kernel startup params as some others have mentioned no luck 

Kernel command line: console=tty0 console=ttyS0,115200n8 no_console_suspend,disp.screen0_output_mode=EDID:1280x720p60, earlycon=uart,mmio32,0x01c28000 mac_addr=7a:6e:63:ac:21:f1 root=/dev/mmcblk0p2 ro rootwait


Attached Files
.txt   edid.txt (Size: 3.7 KB / Downloads: 123)
.txt   putty20160420093457.txt (Size: 16.37 KB / Downloads: 109)


Possibly Related Threads…
Thread Author Replies Views Last Post
  lcd touch screen and hdmi output moreaujacky 2 2,245 10-24-2018, 07:24 AM
Last Post: lisanke
  No HDMI Display need help with correct uEnv.txt settings dkebler 7 4,528 01-11-2018, 02:52 PM
Last Post: dkebler
  HDMI Compatability rahlquist 5 3,720 07-29-2017, 02:32 AM
Last Post: qwerty2002
  No HDMI Output martinarcher 2 3,887 04-28-2017, 07:05 AM
Last Post: martinarcher
  Thoughts on eoma-68 compatability? traverseda 4 2,258 02-23-2017, 06:47 AM
Last Post: lkcl
  Switching from touchscreen to HDMI AUDIOTEK 10 5,144 08-11-2016, 07:41 PM
Last Post: MarkHaysHarris777
  4K HDMI video output medapeta 3 3,447 06-10-2016, 04:36 PM
Last Post: shinobi
  HDMI Issue... LeRoms77 4 3,531 04-19-2016, 02:11 AM
Last Post: LeRoms77
  nexdock (laptop style HDMI display w/ BT keyboard/touchpad) neoaeon 5 4,253 03-10-2016, 07:43 PM
Last Post: hrh1818
  Kickstarter Limited PINE64 T-Shirt - $999 shipping cost to Poland logrus 3 2,774 02-18-2016, 06:53 AM
Last Post: Ghost

Forum Jump:


Users browsing this thread: 1 Guest(s)