Chromium?
#31
Hi everyone,

After using Chromium via Debian on Pine 64+ 2GB, I have a couple items I was hoping could be fixed.

First, I use Google Apps extensively. When using "Google Calendar", the calendar doesn't load correctly. It is jumbled up, much like when there is a CSS problem on a website and the text shows up, but not in proper order and no graphics show up.

Secondly, I can not log in to Chromium. With "Google Chrome", I am typically logged in to the browser with my Google account, but I can not do that in this version of Chromium.

Any ideas?

Thank you!
Pine 64+ 2GB. Android works OK. RemixOS has been buggy. Debian seems most stable to me so far.

  Reply
#32
looks like its working. Instead of doing an alias though, I just put it on the MATE launch bar edited the properties to include the 'chromium --disable-seccomp-filter-sandbox' command. YouTube is workin Smile
  Reply
#33
@jkmooney would you mind very much sharing the Linux command on how to do that (put Chromium with the command for it to work on the MATE launch bar)?

I am a complete Linux newbie, so not only am I learning Pine64, I'm learning command line too! (recipe for disaster, or perhaps for lots of fun!)

Thank you!


Quote:looks like its working. Instead of doing an alias though, I just put it on the MATE launch bar edited the properties to include the 'chromium --disable-seccomp-filter-sandbox' command. YouTube is workin [Image: smile.png]
  Reply
#34
(07-22-2016, 07:08 AM)cantcode Wrote: @jkmooney would you mind very much sharing the Linux command on how to do that (put Chromium with the command for it to work on the MATE launch bar)?

I am a complete Linux newbie, so not only am I learning Pine64, I'm learning command line too! (recipe for disaster, or perhaps for lots of fun!)

Thank you!


Quote:looks like its working. Instead of doing an alias though, I just put it on the MATE launch bar edited the properties to include the 'chromium --disable-seccomp-filter-sandbox' command. YouTube is workin [Image: smile.png]

Hey cantcode, I did the same on Debian 3.102. version and it works perfectly. Just go to the System menu and select Preferences and select Main Menu. There search for Chromium in the Internet section and right click on it and select Properties. Make the modifications in the Command entry. 

Hope that helps.
  Reply
#35
Hi jrullan and thank you for that tip! It works!

When you run Chromium, do you still always get that yellow warning box that talks about security and stability? I was trying to figure out a way to turn that warning off.
Pine 64+ 2GB. Android works OK. RemixOS has been buggy. Debian seems most stable to me so far.

  Reply
#36
(07-26-2016, 11:11 AM)cantcode Wrote: Hi jrullan and thank you for that tip! It works!

When you run Chromium, do you still always get that yellow warning box that talks about security and stability? I was trying to figure out a way to turn that warning off.

Yes I do. I think it is related to the options passed as arguments to the chromium executable. But frankly I just ignore it.
  Reply
#37
(07-26-2016, 11:11 AM)cantcode Wrote: Hi jrullan and thank you for that tip! It works!

When you run Chromium, do you still always get that yellow warning box that talks about security and stability? I was trying to figure out a way to turn that warning off.

Yeah, you're disabling the seccomp-bpf sandbox, which you can read about here. It leaves you pretty vulnerable, so don't browse any fishy sites.
Some with certainty insist no certainty exists.
  Reply
#38
i had to re-install chromium recently and now when i try to sign in to chromium i get an error that reads , "uh-oh, service unavailable try again later. "
thing is the sign in works on 2 other devices. i think it may be related to the 'disable-seccomp-filter-sandbox' flag used at startup. has anyone figured a way to get around this? i was able to sign in on last install and remember having this message before but do not remember the fix. any ideas/tips?
  Reply
#39
I wrote a script because I had problems installing on ubuntu: 


https://github.com/40da63260/pine64-scri...buntu.bash
  Reply
#40
I've been able to get Chromium working on my Pine 64 by adding this ppa:

https://launchpad.net/~saiarcot895/+arch...romium-dev

But I've been unable to get flash player to work.  I used these instructions to install the plugin:

https://ubuntu-mate.community/t/tutorial...refox/3598

Here are the CHROMIUM_FLAGS I have set in /etc/chromium-browser/default:

CHROMIUM_FLAGS="--disable-namespace-sandbox --disable-seccomp-filter-sandbox --disk-cache-size=200 --ppapi-flash-path=/home/ubuntu/PepperFlash/libpepflashplayer.so --ppapi-flash-version=22.0.0.209-r1"

When I leave out the "--disable-namespace-sandbox" flag and try to load a page that requires the flash plugin I get an error that says libpepflashplayer.so doesn't exist even though it clearly does.  When I add the "--disable-namespace-sandbox" flag I get this error:

[35:35:0907/204016:ERROR:ppapi_thread.cc(302)] Failed to load Pepper module from /home/ubuntu/PepperFlash/libpepflashplayer.so (error: /home/ubuntu/PepperFlash/libpepflashplayer.so: cannot open shared object file: Permission denied)

I've tried with the libpepflashplayer.so in /usr/lib/PepperFlash and owned by root, and I've tried with it in my home folder and owned by me.  I've tried with 755 permissions as well as 777.

I've tried using the Ubuntu Mate image from the Pine64 downloads page and I've tried using a Longsleep minimal image and then installing xubuntu-desktop.

Any idea what's really happening here?

Thanks,
Rich
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  Midori and Chromium (52) Cannot open display DuMees 3 1,192 01-12-2017, 02:36 AM
Last Post: DuMees

Forum Jump:


Users browsing this thread: 1 Guest(s)