Lid switch not working
#1
New 1080p Pinebook, running Q4OS/TDE from the EMMC. Logged in as administrator.

When I close the lid (without logging out) nothing happens. The display stays on, and eventually the screensaver starts.

How can I test to see if the lid switch is actually working?
  Reply
#2
Its a hall switch, so use a magnet.
You can find me on IRC, Discord and Twitter


  Reply
#3
@Luke: Thanks for the reply .

I know what a Hall switch is.

I have some fridge-door magnets.

Where should I try to turn off the screen with the magnet?

I tried with 4 fridge-door magnets in the corners, but the display didn't turn off.
  Reply
#4
The switch is located on the daughterboard, just over the SD and USB port. So try the magnet there instead.
You can find me on IRC, Discord and Twitter


  Reply
#5
Nope. Nada. I moved a fridge magnet along the casing beside the right side of the keyboard.

Thanks for the suggestion, Luke.

I do note that there are four magnets two in the top corners, with polarity "up", and two in the bottom corners, with polarity "down". But holding a magnet near them doesn't trigger the switch.
  Reply
#6
So, I decided to try with a different distro - I booted to AOSC/MATE from the microSD card, and LO! - when I slide the fridge-door magnet beside the Back Space/Right Bracket keys, the screen turns off, and I get to the AOSC Login screen.

There is something about my Q4OS/TDE installation that is preventing the lid switch from functioning.
  Reply
#7
(11-26-2018, 09:21 AM)jschall Wrote: So, I decided to try with a different distro - I booted to AOSC/MATE from the microSD card, and LO! - when I slide the fridge-door magnet beside the Back Space/Right Bracket keys, the screen turns off, and I get to the AOSC Login screen.

There is something about my Q4OS/TDE installation that is preventing the lid switch from functioning.

Please report it to Q4OS.
You can find me on IRC, Discord and Twitter


  Reply
#8
I reported to Q4OS Support. There is a bug.

q4osteam wrote:

"Yes, we can confirm a bug, that prevents lid switch from functioning properly. As we could find out, the issue lies in the Debian "Systemd" manager. The command "/lib/systemd/systemd-logind" doesn't detect Pinebook lid switch events at all for Debian Stretch based distros. The AOSC is based on Ubuntu, so it's the difference. Unfortunately, fixing this bug is quite complicated, it would involve low level systemd correction. We will add it into our internal task list and try to resolve, or at least workaround, it until an official fix will be available."
  Reply
#9
Hmm, I think this has been fixed in later implementations of systemd. For example, I am running systemd v237 on KDE Neon, and it sleeps just fine with the lid closed (unless you plug it in, then it wakes up).

You can see what version of systemd you are using by typing in a terminal
/lib/systemd/systemd --version

When I tried Q4OS, about 2 weeks ago, it was using systemd v232, which is kind of old.
  Reply
#10
Thank you, @cvmiller. That could be the problem.
  Reply


Possibly Related Threads...
Thread Author Replies Views Last Post
  Pinebook left USB port not working - while right port does. armhfadillo 2 166 08-04-2019, 07:06 PM
Last Post: armhfadillo
  IPv6 autoconfig not working on new pinebook acruhl 9 644 11-21-2018, 11:10 AM
Last Post: cvmiller
  How to switch Android to Ubuntu ? omnis2a 1 360 06-30-2017, 12:02 PM
Last Post: Luke

Forum Jump:


Users browsing this thread: 1 Guest(s)