reboot issue, hangs
#11
(01-24-2019, 07:46 PM)40four Wrote: I'm using the newest ayufan ubuntu minimal as well. I see what you guys are saying ...
Code:
sudo systemctl reboot

appears to 'hang up' for me too. Bbut for some reason this appears to be shutting down the board completely, similar to
Code:
sudo shutdown now

Then I have to hard restart with the buttons or unplug/ plug in power supply. To be fair, I'm not well versed in all of the flavors of restarting from the command line, but for me
Code:
sudo shutdown -r now
works, as does
Code:
sudo reboot
So I'd be curious if either of those commands work for you guys also. Might save you from doing any of the bash configuration stuff that has been mentioned.


I just learned few days ago that systemctl reboot, reboot and shutdown -r now should all work exactly the same way in systemd based distros (including Ubuntu 18.04, I guess openmediavault too). Similarly poweroff and shutdown now should work the same way. See: https://unix.stackexchange.com/questions...014#196014

In Ubuntu those commands should look like this (at least they do in my systems):
Code:
$ ls -l $(which reboot poweroff shutdown systemctl)
-rwxr-xr-x 1 root root 170320 Jan  9 17:11 /bin/systemctl
lrwxrwxrwx 1 root root     14 Jan  9 17:11 /sbin/poweroff -> /bin/systemctl
lrwxrwxrwx 1 root root     14 Jan  9 17:11 /sbin/reboot -> /bin/systemctl
lrwxrwxrwx 1 root root     14 Jan  9 17:11 /sbin/shutdown -> /bin/systemctl

$ for a in $(which reboot poweroff shutdown systemctl); do dpkg -S $a; done
systemd-sysv: /sbin/reboot
systemd-sysv: /sbin/poweroff
systemd-sysv: /sbin/shutdown
systemd: /bin/systemctl


In that sense it's curious if those reboot commands work differently. systemd has a ton of man pages and I'm too lazy right now read read them so there may be a devil in somewhere in details. I remember having some problems with reboot myself too but haven't experienced them lately. Then again I haven't been rebooting by boards that often any more.

systemd debugging page has some useful tips to try if experiencing hang during poweroff and/or reboot. See https://freedesktop.org/wiki/Software/sy.../#index2h1
In a nutshell:
  • Wait at least 5 minutes to distinguish a permanent hang from a broken service. Then try CTRL+ALT+DEL and see if systems reacts in any way.
  • If it's permanently stuck try reboot -f or poweroff -f. If they don't work it's more likely to be a kernel, not systemd bug.
  • If shutdown completes eventually try systemd debugging (see link above, be careful when modifying kernel command line parameters or you'll get non-booting system)

EDIT: About an hour later I figured out why I haven't experienced reboot problems as of late: I've running myRP64s with eMMC. I just tried rebooting with SD-card and it didn't work even once (tried about 10 times). I think it may have hanged once in shutdown but all other tries failed when trying to boot showing this in serial console:
Code:
pmugrf_os_reg[2] = 0x3AA1FAA1, stride = 0xD
OUT
U-Boot SPL board init

U-Boot SPL 2017.09-rockchip-ayufan-1035-gd646df03ac (Oct 26 2018 - 08:36:09)
booted from SD
Trying to boot from MMC2
mmc_load_image_raw_sector: mmc block read error
SPL: failed to boot from all boot devices
### ERROR ### Please RESET the board ###
(full boot + reboot log pastebin: https://pastebin.com/4RPFk8FA)

Maybe people familiar with U-Boot can tell what's going on here.
  Reply


Messages In This Thread
reboot issue, hangs - by dkebler - 11-12-2018, 01:05 PM
RE: reboot issue, hangs - by Bullet64 - 11-12-2018, 03:19 PM
RE: reboot issue, hangs - by dkebler - 11-12-2018, 06:10 PM
RE: reboot issue, hangs - by BackWoodsTech - 11-21-2018, 06:58 AM
RE: reboot issue, hangs - by dkebler - 11-24-2018, 01:54 PM
RE: reboot issue, hangs - by Belakor - 12-07-2018, 12:29 AM
RE: reboot issue, hangs - by lestat70 - 01-22-2019, 11:36 AM
RE: reboot issue, hangs - by Belakor - 01-24-2019, 01:55 PM
RE: reboot issue, hangs - by lestat70 - 01-25-2019, 10:40 PM
RE: reboot issue, hangs - by 40four - 01-24-2019, 07:46 PM
RE: reboot issue, hangs - by nuumio - 01-26-2019, 03:54 AM
RE: reboot issue, hangs - by Belakor - 02-12-2019, 05:14 PM
RE: reboot issue, hangs - by Belakor - 02-13-2019, 08:10 PM

Possibly Related Threads...
Thread Author Replies Views Last Post
  Linux reboot command dont' restart davide.duca 2 113 03-11-2020, 03:15 PM
Last Post: dukla2000
Question How to automatically reboot rockpro64 in case it shutdown abruptly ? seaurchin 2 200 11-25-2019, 08:46 AM
Last Post: tophneal
  RockPro64 not coming online after reboot imapc99 5 416 08-04-2019, 01:34 AM
Last Post: imapc99
  login to GUI desktop hangs when PCIe SSD is plugged in grimace 3 278 04-24-2019, 04:24 PM
Last Post: Luke
  Hardware issue overheating while booting and fail to boot DIDquest 13 1,418 03-23-2019, 02:50 AM
Last Post: nJoy.
  Performance issue/question bobdaroze 8 1,475 11-11-2018, 10:41 PM
Last Post: tuxd3v

Forum Jump:


Users browsing this thread: 1 Guest(s)