Linux not working properly (noobie)
#1
First of all this is my first sbc and I might not doing somethings properly.tas fan from pine store, 16GB eMMC in NAS Metal Case.
I used "LXDE Desktop aarch64 [microSD / eMMC Boot] [0.7.9]" 


1) How do you control the fan?
2) Is there any HW Acceleration? Youtube, daily motion are playing with 20-25 fps top. 
I played with some kernels but didn't see any difference (only in sound, the known bug). 

3) WiFi module doesn't work. Is this normal? I saw something in changelog. I also upgrade to 0.7.10 by changing apt lists and didn't see any difference.
4) Can't get the SATA PCIe work in graphic environment.
If I press ctrl+alt+f1 and login, I can see the PCIe card (lspci works), I can use parted, format the drive and mount it succesfully.
If I try to use LXDE everything freezes.
If I don't do anything with the drive, even lspci freezes the rpro64. 
So my HDD is useless in desktop mode.

Is anyone experience the same problems?
Is there any Linux distribution that works without problems? Any kernel suggestion?
  Reply
#2
2. Yes, there is hw accel for playing full screen content with ffmpeg and mpv decoding with libmali/mpp (userland should be available as rkmpv in ubuntu, so I'm told [1]). I'm playing youtube videos with mpv and the youtube-dl module from the linux console. It works in X11, too - fullscreen. Inside a browser I got the best results with chromium, but that was just normal arm/neon decoding - so cpu load at 2.x and fps around 22.

[1] https://github.com/ayufan-rock64/linux-b...layback.md
  Reply
#3
(10-21-2018, 02:25 PM)hunderteins Wrote: 2. Yes, there is hw accel for playing full screen content with ffmpeg and mpv decoding with libmali/mpp (userland should be available as rkmpv in ubuntu, so I'm told [1]). I'm playing youtube videos with mpv and the youtube-dl module from the linux console. It works in X11, too - fullscreen. Inside a browser I got the best results with chromium, but that was just normal arm/neon decoding - so cpu load at 2.x and fps around 22.

[1] https://github.com/ayufan-rock64/linux-b...layback.md


GitHub is experiencing some Storage problems..
Maybe because of that your system is is panic mode..

https://twitter.com/githubstatus
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  Xen EFI with Alpine Linux dom0 sir.lami 0 143 08-26-2020, 12:25 PM
Last Post: sir.lami
  Linux Host - QEMU Android Guest? rik-shaw 0 207 07-09-2020, 08:02 PM
Last Post: rik-shaw
  RETRO GAMING BATOCERA LINUX + ROSHAMBO CASE - Tutoriel Fr TheMiniCakeTV 0 929 07-02-2020, 12:45 PM
Last Post: TheMiniCakeTV
  Arch Linux on RockPro64 mmatyas 30 14,113 05-30-2020, 12:08 PM
Last Post: mmatyas
  RockPro64 Linux Manjaro HDMI 4K mkne 12 1,258 05-03-2020, 07:23 AM
Last Post: PakoSt
  Mainline U-Boot with Arch Linux PKGBUILD mmatyas 0 354 04-17-2020, 03:49 AM
Last Post: mmatyas
  Slow/dead ethernet on (non-Ayufan) Linux Mainline (fixed) mmatyas 1 372 04-17-2020, 02:53 AM
Last Post: Thra11
  Rockpro64 and stock arch linux TaborFife 6 1,538 01-15-2020, 05:17 PM
Last Post: dragop
  Problem with compiling ayufans linux kernel voegelit 4 676 01-14-2020, 07:38 AM
Last Post: patstew
  Netflix with hardware acceleration not working Helium75 1 414 12-15-2019, 09:26 AM
Last Post: Helium75

Forum Jump:


Users browsing this thread: 1 Guest(s)