PCIe Inconsistency Problems
#11
Do you have another HDD for testing?
Sorry for any mistakes. English is not my native language

1. Quartz64 Model B, 4GB RAM

2. Quartz64 Model A, 4GB RAM

3. RockPro64 v2.1

https://linux-nerds.org/
#12
(10-23-2018, 12:32 PM)Bullet64 Wrote: Do you have another HDD for testing?

Would be weird if it was the HDD, because it works fine on my desktop and even with the HDD unplugged the pci card doesn't show up.
#13
When i remember correct it's normal when no hhd is attached that lspci don't show anything. But it was a long time ago that i play with this sata card.
Sorry for any mistakes. English is not my native language

1. Quartz64 Model B, 4GB RAM

2. Quartz64 Model A, 4GB RAM

3. RockPro64 v2.1

https://linux-nerds.org/
#14
I can confirm jja2000 problem on 0.79.
Without HDD connected lspci works fine and it shows ASMEDIA.
If you connect the HDD it works fine (doesn't freeze), you can access HDD and lspci works properly.

If you load LXDE or Openbox system freezes.
#15
So is this a hardware error? On the rockpro64 or the SATA port? Any idea what I could do to either test or fix it?
#16
(10-24-2018, 11:52 PM)jannerman Wrote: I can confirm jja2000 problem on 0.79.
Without HDD connected lspci works fine and it shows ASMEDIA.
If you connect the HDD it works fine (doesn't freeze), you can access HDD and lspci works properly.

If you load LXDE or Openbox system freezes.

Looks like an software problem!?
Sorry for any mistakes. English is not my native language

1. Quartz64 Model B, 4GB RAM

2. Quartz64 Model A, 4GB RAM

3. RockPro64 v2.1

https://linux-nerds.org/
#17
(10-29-2018, 02:12 PM)Bullet64 Wrote:
(10-24-2018, 11:52 PM)jannerman Wrote: I can confirm jja2000 problem on 0.79.
Without HDD connected lspci works fine and it shows ASMEDIA.
If you connect the HDD it works fine (doesn't freeze), you can access HDD and lspci works properly.

If you load LXDE or Openbox system freezes.

Looks like an software problem!?

I'm running into the same problem running the minimal distribution as the lxde/openbox distribution.
So I hope you understand why I reckon it's a hardware problem :^)
#18
I expirenced similar problems lspci -vvv crashed the system when lxqt was started. 
It turned out to be the audio driver. When I started pulseaudio on the command line and then executing lspci -vvv the system would freeze. I disabled both audio drivers and uninstalled pulseaudio just to be sure
it seems to work now
#19
This thing doesn't work when using openmediavault on an entirely different harddrive on both ports of the pcie card.

How am I going to use this thing as intended if it doesn't work?


Possibly Related Threads…
Thread Author Replies Views Last Post
  Can RockPRO64 support PCIe Endpoint? andrewg132 3 509 10-14-2022, 06:24 AM
Last Post: rwk-
  No PCIe controller detected... Limhes 1 889 11-23-2021, 06:23 AM
Last Post: Limhes
  Using the PCIe slot of ROCKPro64 as EndPoint mode nonoriri 1 1,074 11-20-2021, 10:53 AM
Last Post: fire219
  WiFi not working with PCIe SSD installed mikeD 0 972 05-25-2021, 07:48 AM
Last Post: mikeD
  Power supply underpowered for Rockpro64, deficient PCIe SATA card, or something else? daffy 8 4,335 05-20-2021, 10:04 PM
Last Post: t4_4t
  Problems with my RockPro64 tuxd3v 0 1,489 08-19-2020, 11:47 AM
Last Post: tuxd3v
  Frequent kernel panic, possibly due to PCIe SSD? meier 4 4,442 11-22-2019, 05:15 PM
Last Post: meier
  My PCIe disk controller works with Linux 5.3.6 guannais 1 2,070 10-30-2019, 07:11 PM
Last Post: guannais
Information Update 22.02.2019 Feature-complete Debian build - SDIO WiFi/BT / PCIe / 3D / 2D Luke 100 94,884 10-04-2019, 08:57 PM
Last Post: tuxd3v
  PCIe ath10k on RockPro64 dasfranky 5 4,985 08-31-2019, 11:36 AM
Last Post: tuxd3v

Forum Jump:


Users browsing this thread: 1 Guest(s)